Music playback stops (a LibreElec - Bluetooth issue)

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
novus744 Offline
Junior Member
Posts: 3
Joined: May 2017
Reputation: 0
Post: #1
Hello all,

I'm new to KODI and to the RPi in general. I don't know what kind of information to post here exactly...

Yesterday I downloaded the LibreElec installer and put the latest version onto a micro SD card. I put that into a Pi 3. It seemed to work without any issues - though admittedly I didn't try very long. I then downloaded the zip file for the estouchy skin and installed it from a network location using the add-on installer in KODI.

Again, everything seemed to be working well. I added my music library, which is located on a NAS, to the library in KODI and started playing music. The problem I'm seeing is that music plays for a few minutes, and then stops playing. The play bar stops moving as well. It doesn't seem to be an issue with the network, because I can still navigate my library. I can go back/forward tracks, and it displays the new track, but will not start playing again.

I am using a bluetooth speaker and the 7" Pi touchscreen as well - both of which connected and worked without issue.

Any advice would be appreciated.
(This post was last modified: 2017-05-14 09:29 by DaveBlake.)
find quote
DaveBlake Offline
Team-Kodi Member
Posts: 2,441
Joined: Jun 2015
Reputation: 68
Location: South West England
Post: #2
That sounds very odd, what format are the music files that you are playing - mp3, flac, other?

Can you also provide a debu log of playback failing in this way. For more help with obtaining the log from a RPi have a look on the RPi subforum http://forum.kodi.tv/forumdisplay.php?fid=166.
find quote
novus744 Offline
Junior Member
Posts: 3
Joined: May 2017
Reputation: 0
Post: #3
(2017-05-11 17:32)DaveBlake Wrote:  That sounds very odd, what format are the music files that you are playing - mp3, flac, other?

Can you also provide a debu log of playback failing in this way. For more help with obtaining the log from a RPi have a look on the RPi subforum http://forum.kodi.tv/forumdisplay.php?fid=166.

I will post the log file asap. The format is mp3.

Thanks
find quote
novus744 Offline
Junior Member
Posts: 3
Joined: May 2017
Reputation: 0
Post: #4
So, I was finally able to get back to this and after doing a little more research discovered that the problem is with the Bluetooth drivers in LibreElec:

https://forum.libreelec.tv/thread-1196.html

I am having the same issues as all of these people. Interestingly, it works ok in OpenElec and also if I plug in an analog speaker...

Anyway, I don't think it's a Kodi problem, so thanks!
find quote