Windows - Odd colors in video playback

  Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Cakeofdestiny Offline
Junior Member
Posts: 6
Joined: Aug 2015
Reputation: 0
Video  Odd colors in video playback
Post: #1
Hey,

I have a color problem with Kodi. For some reason, Kodi drastically changes the colors of every video I play in it, with no exception (the videos look perfect in any other media player). I've tried fiddling with the settings, completely uninstalling it (I selected the `delete the profile folder option`) and earlier versions of Krypton and Jarvis, to no avail. Here's an album of screenshots from some of the shows:
watch gallery


Any help would be greatly appreciated Big Grin
(This post was last modified: 2017-05-19 13:22 by Cakeofdestiny.)
find quote
fritsch Offline
Team-Kodi Developer
Posts: 17,989
Joined: Aug 2011
Reputation: 560
Location: Stuttgart*
Post: #2
As you did not provide a Debug Log - only speculations helps: Intel GPU -> change the contrast setting in the graphics utility.

"Your most vocal users are not reflective of your userbase" J.M.
"Of course, they [XP Users and people with outdated hardware] need to tell the world about the kind of hero they are, and block innovation for everyone else because their decades old OS / hardware needs to work =p" nevcairiel (ffmpeg)
No Debug Log no issue.
find quote
bergamesk Offline
Junior Member
Posts: 14
Joined: Dec 2016
Reputation: 0
Post: #3
Hi

same such as me

-col.decoding false 17.1
-SD contents "bad"!! if bit-rate very low then really bad! when I check same SD contents fm my Bluray player or my TV's way better!
-HD contents OK but col.decoding issue!
-SD&HD a little bit stutter/unrealistic movement!

actually I do not use my SD contents on Kodi 17.1 and use my Bluray

Now before I use 16.1 Jarvis then SD contents a little bit better and also HD and col.rendering better too!

I generally for other purposes like it 17.1 than previous 16.1

For 17.1 as it seems that I need some help/suggestion especially to play video contents

Note;I use at present all "default" settings and do not touch any of set.

++

My box is "X92" Ram3Gb/Rom16Gb and its pretty good after 11 or 12 devices!
(This post was last modified: 2017-05-20 12:08 by bergamesk.)
find quote
Karellen Offline
Super Moderator
Posts: 2,386
Joined: Apr 2017
Reputation: 34
Location: Melbourne, Australia
Post: #4
as @fritsch said. We need a debug log to help you.

No-one will help until you provide it.

Link is in my signature below.

My Signature
Links to : Forum Rules | Banned Add-Ons | Free Movies/TV Shows | Debug Log |


find quote
Cakeofdestiny Offline
Junior Member
Posts: 6
Joined: Aug 2015
Reputation: 0
Post: #5
(2017-05-20 06:28)fritsch Wrote:  As you did not provide a Debug Log - only speculations helps: Intel GPU -> change the contrast setting in the graphics utility.

(2017-05-20 12:43)Karellen Wrote:  as @fritsch said. We need a debug log to help you.

No-one will help until you provide it.

Link is in my signature below.

Hey,

I apologize for not providing a debug log earlier. Here it is -- https://pastebin.com/g6VhY788

Many thanks
find quote
PatK Offline
Team-Kodi Member
Posts: 8,504
Joined: Mar 2010
Reputation: 207
Location: Canada
Post: #6
As Kodi looks for routines to accelerate graphics, it's possible that your hardware or o/s is at the root of this issue (ensure updated drivers) while 3rd party players routinely are set-up for software solutions. Video levels and color space (wiki) settings>video output>display>16-235 [expert mode on] and see if this forum has your solve http://forum.kodi.tv/showthread.php?tid=267528

You might want to migrate to Kodi 17 or 18, there has been a lot of re-working the video section and enjoy the newer features/fixes.

windows fresh start -> delete C:\Users\User Name\AppData\Roaming\Kodi First time user (wiki) Log file (wiki) Video management (wiki) Artwork (wiki) Supported hardware (wiki) Releases (wiki) Database versions (wiki) Skin features compatibility list (wiki) http://xbmc-skins.com
(This post was last modified: 2017-05-20 16:43 by PatK.)
find quote
fritsch Offline
Team-Kodi Developer
Posts: 17,989
Joined: Aug 2011
Reputation: 560
Location: Stuttgart*
Post: #7
Quote:13:26:22 T:16568 NOTICE: Found screen: Generic PnP Monitor on Intel® HD Graphics 5500, adapter 0.

^^ there is a setting in the intel utility for contrast or something, restore thse to default.

"Your most vocal users are not reflective of your userbase" J.M.
"Of course, they [XP Users and people with outdated hardware] need to tell the world about the kind of hero they are, and block innovation for everyone else because their decades old OS / hardware needs to work =p" nevcairiel (ffmpeg)
No Debug Log no issue.
find quote
Cakeofdestiny Offline
Junior Member
Posts: 6
Joined: Aug 2015
Reputation: 0
Post: #8
(2017-05-20 16:30)PatK Wrote:  As Kodi looks for routines to accelerate graphics, it's possible that your hardware or o/s is at the root of this issue (ensure updated drivers) while 3rd party players routinely are set-up for software solutions. Video levels and color space (wiki) settings>video output>display>16-235 [expert mode on] and see if this forum has your solve http://forum.kodi.tv/showthread.php?tid=267528

You might want to migrate to Kodi 17 or 18, there has been a lot of re-working the video section and enjoy the newer features/fixes.

(2017-05-20 17:02)fritsch Wrote:  
Quote:13:26:22 T:16568 NOTICE: Found screen: Generic PnP Monitor on Intel® HD Graphics 5500, adapter 0.

^^ there is a setting in the intel utility for contrast or something, restore thse to default.


I'll try your suggestions and report back in a day or two, thanks.
find quote
PatK Offline
Team-Kodi Member
Posts: 8,504
Joined: Mar 2010
Reputation: 207
Location: Canada
Post: #9
@ bergamesk don't high-jack threads; this forum is for video problems, your query is best handled in hardware. Moving post to http://forum.kodi.tv/showthread.php?tid=...pid2589430

windows fresh start -> delete C:\Users\User Name\AppData\Roaming\Kodi First time user (wiki) Log file (wiki) Video management (wiki) Artwork (wiki) Supported hardware (wiki) Releases (wiki) Database versions (wiki) Skin features compatibility list (wiki) http://xbmc-skins.com
(This post was last modified: 2017-05-21 23:16 by PatK.)
find quote
kimkl Offline
Grandpa Simpson
Posts: 347
Joined: Mar 2016
Reputation: 3
Location: Holbaek, Denmark
Post: #10
Could be Kodi switching fps to 50mhz and then color space to 4.2.2 or RGB, so look at the current settings for your GPU, then launch Kodi fire up a Video with "bad colors" let the video play alt tab and check you GPU settings see if fps, color space has changed,
i can't be certain from the images but it looks like it might be using RGB because i see a lot of yellow, and unless its the episode where Cartman fakes sickness then you def have some issues with your colors.
Thank You

#Ignore the Rubbish#
had not read the debug.log and the other guy who hijacked the thread i mistook for the Author
But have a look at my 2 attempt to help, i believe that is your problem.
The Windows 10 CU.

Grandpa Simpson: Unfortunately, like all true stories, this one has a crappy ending.
Your story's have an ending?
English is not my native language; please excuse typing errors.
Banned Add-Ons
(This post was last modified: 2017-05-21 21:47 by kimkl.)
find quote
fritsch Offline
Team-Kodi Developer
Posts: 17,989
Joined: Aug 2011
Reputation: 560
Location: Stuttgart*
Post: #11
No, no, no.

"Your most vocal users are not reflective of your userbase" J.M.
"Of course, they [XP Users and people with outdated hardware] need to tell the world about the kind of hero they are, and block innovation for everyone else because their decades old OS / hardware needs to work =p" nevcairiel (ffmpeg)
No Debug Log no issue.
find quote
kimkl Offline
Grandpa Simpson
Posts: 347
Joined: Mar 2016
Reputation: 3
Location: Holbaek, Denmark
Post: #12
Okay as my favorite "TK" would say RUBBISH, so ignore my first attempt to help.
Now have you installed the latest Windows 10 CU, from what i have read on the Intel Boards people are complaining about poor performance, corrupted Graphics and so on.
So ignore the Rubbish i wrote above in my first post, i had not read your debug.log yet and the other guy, i mistook for you so thought you were on 17.1
So hit or hold the Windows key + I
go to System, then about and write what Version your on, because when i installed the CU on my Desktop, my speaker system got replaced by Chip n Dale, my Movies had playback issues, but i am now on the latest update from MS (v. 1703) and most issues have been corrected.

So i am Guessing if this has just started happening, that its because you're PC/Laptop is getting the CU and then follows some 3 updates to fix the Breaks

Okay i hope this does not look like rubbish, if it does or is not understandable let me know.
ohh and i would def upgrade/migrate what ever to 17.1 you're missing out on so much
Thank You
Just in case my Post does not make sense you can read about the issues here on Intel's Board.
https://communities.intel.com/thread/113216

Grandpa Simpson: Unfortunately, like all true stories, this one has a crappy ending.
Your story's have an ending?
English is not my native language; please excuse typing errors.
Banned Add-Ons
(This post was last modified: 2017-05-21 21:54 by kimkl.)
find quote
Cakeofdestiny Offline
Junior Member
Posts: 6
Joined: Aug 2015
Reputation: 0
Post: #13
(2017-05-20 16:30)PatK Wrote:  As Kodi looks for routines to accelerate graphics, it's possible that your hardware or o/s is at the root of this issue (ensure updated drivers) while 3rd party players routinely are set-up for software solutions. Video levels and color space (wiki) settings>video output>display>16-235 [expert mode on] and see if this forum has your solve http://forum.kodi.tv/showthread.php?tid=267528

You might want to migrate to Kodi 17 or 18, there has been a lot of re-working the video section and enjoy the newer features/fixes.

(2017-05-20 17:02)fritsch Wrote:  
Quote:13:26:22 T:16568 NOTICE: Found screen: Generic PnP Monitor on Intel® HD Graphics 5500, adapter 0.

^^ there is a setting in the intel utility for contrast or something, restore thse to default.

(2017-05-21 21:47)kimkl Wrote:  Okay as my favorite "TK" would say RUBBISH, so ignore my first attempt to help.
Now have you installed the latest Windows 10 CU, from what i have read on the Intel Boards people are complaining about poor performance, corrupted Graphics and so on.
So ignore the Rubbish i wrote above in my first post, i had not read your debug.log yet and the other guy, i mistook for you so thought you were on 17.1
So hit or hold the Windows key + I
go to System, then about and write what Version your on, because when i installed the CU on my Desktop, my speaker system got replaced by Chip n Dale, my Movies had playback issues, but i am now on the latest update from MS (v. 1703) and most issues have been corrected.

So i am Guessing if this has just started happening, that its because you're PC/Laptop is getting the CU and then follows some 3 updates to fix the Breaks

Okay i hope this does not look like rubbish, if it does or is not understandable let me know.
ohh and i would def upgrade/migrate what ever to 17.1 you're missing out on so much
Thank You
Just in case my Post does not make sense you can read about the issues here on Intel's Board.
https://communities.intel.com/thread/113216

Hey,

None of these worked. I've upgraded to 18 (again), updated my drivers, changed color space to 16-235 (which only made everything look washed out), additionally, my Windows 10 is on 1703.

Thanks for the help
find quote
PatK Offline
Team-Kodi Member
Posts: 8,504
Joined: Mar 2010
Reputation: 207
Location: Canada
Post: #14
Quote:the videos look perfect in any other media player

Well don't suffer, External players (wiki) use your favourite. But I suspect your issue is some unbalanced hardware, it's not likely you'll have perfect calibration of both the PC monitor and the TV panel at the same time; it's going to be one or the other and we have given you enough information, that you should be able to come up with a compromise solution. As a last stab at a fix, check carefully your HDMI connection with another cable, it wouldn't be the first time that signal degradation or bad connection has been the culprit.

windows fresh start -> delete C:\Users\User Name\AppData\Roaming\Kodi First time user (wiki) Log file (wiki) Video management (wiki) Artwork (wiki) Supported hardware (wiki) Releases (wiki) Database versions (wiki) Skin features compatibility list (wiki) http://xbmc-skins.com
(This post was last modified: 2017-05-28 17:20 by PatK.)
find quote
Cakeofdestiny Offline
Junior Member
Posts: 6
Joined: Aug 2015
Reputation: 0
Post: #15
(2017-05-28 17:20)PatK Wrote:  
Quote:the videos look perfect in any other media player

Well don't suffer, External players (wiki) use your favourite. But I suspect your issue is some unbalanced hardware, it's not likely you'll have perfect calibration of both the PC monitor and the TV panel at the same time; it's going to be one or the other and we have given you enough information, that you should be able to come up with a compromise solution. As a last stab at a fix, check carefully your HDMI connection with another cable, it wouldn't be the first time that signal degradation or bad connection has been the culprit.

Hey,

I use a laptop, but thanks for the help anyway.
find quote