Linux kodi (17.3) doesn't start on Ubuntu 16.04
#1
Hi everyone, I tried to read some posts on the forum but I didn't resolve my problem (also because I am relatively new in the unix world).

My problem is that if I install Kodi either from the command link or from the Ubuntu Software Center the program never start.
I found the log (I am going to paste it under here), but I can find the cause. I tried to follow some post solution but it still doesn't work anything

Code:
############## Kodi CRASH LOG ###############

################ SYSTEM INFO ################
Date: Thu May 25 14:17:08 UTC 2017
Kodi Options:
Arch: x86_64
Kernel: Linux 2.6.32-042stab120.6 #1 SMP Thu Oct 27 16:59:03 MSK 2016
Release: Ubuntu 16.04.1 LTS (Xenial Xerus)
############## END SYSTEM INFO ##############

############### STACK TRACE #################
gdb not installed, can't get stack trace.
############# END STACK TRACE ###############

################# LOG FILE ##################

14:16:49.906 T:140538989320576  NOTICE: special://profile/ is mapped to: special://masterprofile/
14:16:49.906 T:140538989320576  NOTICE: -----------------------------------------------------------------------
14:16:49.906 T:140538989320576  NOTICE: Starting Kodi (17.3 Git:20170525-nogitfound). Platform: Linux x86 64-bit
14:16:49.906 T:140538989320576  NOTICE: Using Release Kodi x64 build
14:16:49.906 T:140538989320576  NOTICE: Kodi compiled Nov  4 2012 by GCC 5.4.0 for Linux x86 64-bit version 4.4.62 (263230)
14:16:49.906 T:140538989320576  NOTICE: Running on Ubuntu 16.04.1 LTS, kernel: Linux x86 64-bit version 2.6.32-042stab120.6
14:16:49.906 T:140538989320576  NOTICE: FFmpeg version/source: ffmpeg-3.1-kodi
14:16:49.906 T:140538989320576  NOTICE: special://xbmc/ is mapped to: /usr/share/kodi
14:16:49.906 T:140538989320576  NOTICE: special://xbmcbin/ is mapped to: /usr/lib/x86_64-linux-gnu/kodi
14:16:49.906 T:140538989320576  NOTICE: special://xbmcbinaddons/ is mapped to: /usr/lib/x86_64-linux-gnu/kodi/addons
14:16:49.906 T:140538989320576  NOTICE: special://masterprofile/ is mapped to: /home/user/.kodi/userdata
14:16:49.906 T:140538989320576  NOTICE: special://envhome/ is mapped to: /home/user
14:16:49.906 T:140538989320576  NOTICE: special://home/ is mapped to: /home/user/.kodi
14:16:49.906 T:140538989320576  NOTICE: special://temp/ is mapped to: /home/user/.kodi/temp
14:16:49.906 T:140538989320576  NOTICE: special://logpath/ is mapped to: /home/user/.kodi/temp
14:16:49.906 T:140538989320576  NOTICE: The executable running is: /usr/lib/x86_64-linux-gnu/kodi/kodi.bin
14:16:49.906 T:140538989320576  NOTICE: Local hostname: user_server
14:16:49.906 T:140538989320576  NOTICE: Log File is located: /home/user/.kodi/temp//kodi.log
14:16:49.906 T:140538989320576  NOTICE: -----------------------------------------------------------------------
14:16:49.908 T:140538989320576   ERROR: DBus: Error org.freedesktop.DBus.Error.ServiceUnknown - The name org.freedesktop.UPower was not provided by any .service files
14:16:49.918 T:140538989320576  NOTICE: load settings...
14:16:49.931 T:140538989320576   ERROR: PulseAudio: Failed to connect context
14:16:49.931 T:140538989320576  NOTICE: PulseAudio might not be running. Context was not created.
14:16:49.946 T:140538989320576  NOTICE: No Devices found - retry: 4
14:16:51.449 T:140538989320576   ERROR: PulseAudio: Failed to connect context
14:16:51.449 T:140538989320576  NOTICE: PulseAudio might not be running. Context was not created.
14:16:51.457 T:140538989320576  NOTICE: No Devices found - retry: 3
14:16:52.960 T:140538989320576   ERROR: PulseAudio: Failed to connect context
14:16:52.960 T:140538989320576  NOTICE: PulseAudio might not be running. Context was not created.
14:16:52.969 T:140538989320576  NOTICE: No Devices found - retry: 2
14:16:54.472 T:140538989320576   ERROR: PulseAudio: Failed to connect context
14:16:54.472 T:140538989320576  NOTICE: PulseAudio might not be running. Context was not created.
14:16:54.480 T:140538989320576  NOTICE: No Devices found - retry: 1
14:16:55.984 T:140538989320576   ERROR: PulseAudio: Failed to connect context
14:16:55.984 T:140538989320576  NOTICE: PulseAudio might not be running. Context was not created.
14:16:55.992 T:140538989320576  NOTICE: Found 0 Lists of Devices
14:16:55.994 T:140538989320576   ERROR: PulseAudio: Failed to connect context
14:16:55.994 T:140538989320576  NOTICE: PulseAudio might not be running. Context was not created.
14:16:55.999 T:140538989320576  NOTICE: No Devices found - retry: 4
14:16:57.502 T:140538989320576   ERROR: PulseAudio: Failed to connect context
14:16:57.502 T:140538989320576  NOTICE: PulseAudio might not be running. Context was not created.
14:16:57.511 T:140538989320576  NOTICE: No Devices found - retry: 3
14:16:59.015 T:140538989320576   ERROR: PulseAudio: Failed to connect context
14:16:59.015 T:140538989320576  NOTICE: PulseAudio might not be running. Context was not created.
14:16:59.021 T:140538989320576  NOTICE: No Devices found - retry: 2
14:17:00.524 T:140538989320576   ERROR: PulseAudio: Failed to connect context
14:17:00.524 T:140538989320576  NOTICE: PulseAudio might not be running. Context was not created.
14:17:00.533 T:140538989320576  NOTICE: No Devices found - retry: 1
14:17:02.036 T:140538989320576   ERROR: PulseAudio: Failed to connect context
14:17:02.036 T:140538989320576  NOTICE: PulseAudio might not be running. Context was not created.
14:17:02.044 T:140538989320576  NOTICE: Found 0 Lists of Devices
14:17:02.046 T:140538989320576  NOTICE: No settings file to load (special://xbmc/system/advancedsettings.xml)
14:17:02.046 T:140538989320576  NOTICE: No settings file to load (special://masterprofile/advancedsettings.xml)
14:17:02.046 T:140538989320576  NOTICE: Default Video Player: VideoPlayer
14:17:02.046 T:140538989320576  NOTICE: Default Audio Player: paplayer
14:17:02.046 T:140538989320576  NOTICE: Disabled debug logging due to GUI setting. Level 0.
14:17:02.046 T:140538989320576  NOTICE: Log level changed to "LOG_LEVEL_NORMAL"
14:17:02.046 T:140538989320576  NOTICE: Loading player core factory settings from special://xbmc/system/playercorefactory.xml.
14:17:02.046 T:140538989320576  NOTICE: Loaded playercorefactory configuration
14:17:02.046 T:140538989320576  NOTICE: Loading player core factory settings from special://masterprofile/playercorefactory.xml.
14:17:02.046 T:140538989320576  NOTICE: special://masterprofile/playercorefactory.xml does not exist. Skipping.
14:17:02.049 T:140538989320576  NOTICE: Running database version Addons27
14:17:02.152 T:140538989320576  NOTICE: ADDONS: Using repository repository.xbmc.org
14:17:02.157 T:140538480445184   ERROR: PulseAudio: Failed to connect context
14:17:02.157 T:140538480445184  NOTICE: PulseAudio might not be running. Context was not created.
14:17:02.164 T:140538480445184  NOTICE: No Devices found - retry: 4
14:17:03.668 T:140538480445184   ERROR: PulseAudio: Failed to connect context
14:17:03.668 T:140538480445184  NOTICE: PulseAudio might not be running. Context was not created.
14:17:03.677 T:140538480445184  NOTICE: No Devices found - retry: 3
14:17:05.182 T:140538480445184   ERROR: PulseAudio: Failed to connect context
14:17:05.182 T:140538480445184  NOTICE: PulseAudio might not be running. Context was not created.
14:17:05.190 T:140538480445184  NOTICE: No Devices found - retry: 2
14:17:06.694 T:140538480445184   ERROR: PulseAudio: Failed to connect context
14:17:06.694 T:140538480445184  NOTICE: PulseAudio might not be running. Context was not created.
14:17:06.703 T:140538480445184  NOTICE: No Devices found - retry: 1
14:17:08.207 T:140538480445184   ERROR: PulseAudio: Failed to connect context
14:17:08.207 T:140538480445184  NOTICE: PulseAudio might not be running. Context was not created.
14:17:08.215 T:140538480445184  NOTICE: Found 0 Lists of Devices
14:17:08.224 T:140538480445184 WARNING: ActiveAE::Configure - sink returned large buffer of 249 ms, reducing to 100 ms
14:17:08.252 T:140538989320576  NOTICE: Checking resolution 16
14:17:08.288 T:140538989320576   ERROR: Failed to find matching visual


############### END LOG FILE ################

############ END Kodi CRASH LOG #############
Reply
#2
Your problem is something completely different. Your xserver is not running, GPU drivers are 10 years too old. Your user is furthermore not in the appropriate groups. Sorry - we cannot fix your OS, we only provide an application.

Quote:14:16:49.906 T:140538989320576 NOTICE: Running on Ubuntu 16.04.1 LTS, kernel: Linux x86 64-bit version 2.6.32-042stab120.6
^^ is that a joke?
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#3
(2017-05-25, 16:50)fritsch Wrote:
Quote:14:16:49.906 T:140538989320576 NOTICE: Running on Ubuntu 16.04.1 LTS, kernel: Linux x86 64-bit version 2.6.32-042stab120.6
^^ is that a joke?

is really so dramatic? Undecided Blush

what can I do? I can't change the ubuntu release, but I can update everything else
Reply
#4
Provide:

dmesg | pastebinit
id | pastebinit
glxinfo | pastebinit

then we will see
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
kodi (17.3) doesn't start on Ubuntu 16.0400
This forum uses Lukasz Tkacz MyBB addons.