Thread Rating:
  • 0 Vote(s) - 0 Average
Please Provide subtitles security fix for Kodi 16.X
#31
(2017-06-19, 03:36)magao Wrote: Most graphics drivers will work with algorithmdirtyregions=1 or 2 these days (this thread prompted me to check on my Braswell NUC and it's fine with algorithmdirtyregions=1) so I recommend you try those and see how it goes.

This is wrong. On Linux OpenGL the state of the back buffer is undefined after swapping buffers. Hence changing algorithmdirtyregions is silly and absolutely not recommended. Further this variable won't have any effect on CPU load.
Please don't pretend knowledge in an area you obviously don't know much about.
Reply
#32
Photo 
(2017-06-18, 08:37)FernetMenta Wrote: This is nonsense. nofliptimeout had a default value of 0 and algorithmdirtyregions a default value of 3. Means your entries in advanced settings were useless.

Maybe it's psychosomatic Big Grin

I'm sorry but I have to stand for what I said before. I just played the same music video from Vevo both with and without my advancedsettings.xml file in userdata folder, look at the printscreens I took:

--> With:

Image

--> Without:

Image

Differs from 10% of cpu usage to 69% of cpu usage. None of the values are peaks.
So it is indeed changing something and that something is making all the difference on my pc.
Reply
#33
you said you played with and without the entire advancedsettings file. what else is in this file?
Reply
#34
I already wrote in the previous page that it happened when I removed only that single line: https://forum.kodi.tv/showthread.php?tid...pid2604650

But who knows, maybe during my testing there were glitches, like network, provider server, whatever that compromised all the tests. If you say it has no influence I am no one to be able to state otherwise.
Reply
#35
too bad you can't see the CPU clock speed on the linux task manager so that we could be sure it's not related to speed stepping. I'm not a linux guy, but I recall one was able to configure certain modes for the CPU govenor. If that's the case on your setup, could you set it to "max performance" or alike, so that speed stepping is basically disabled and redo the above test?
Please also make sure to wait at least a minute after startup of Kodi before you do the test, because some add-ons could run background tasks that eat up CPU. Best probably might be to temporarily use a clean Kodi profile by renaming your userdata folder, reconfigure HW acceleration as needed and then run the test with and without an advancedsettings file with only the dirtyregion setting. Thanks.
Reply
#36
I have no idea how to do such a thing nor if it can be done, browsed around a bit but found nothing useful. But there's really no point, if it is "nonsense" then it is what it is.
If that's not the problem/solution then theoretically you still have a solution, if things worked great in Kodi 16.1 and now work badly in 17.x and newer, at least theoretically all you gotta do is undo the changes made and it all should work great again.
Reply
#37
(2017-06-20, 23:10)pemartins Wrote: I have no idea how to do such a thing nor if it can be done, browsed around a bit but found nothing useful. But there's really no point, if it is "nonsense" then it is what it is.
If that's not the problem/solution then theoretically you still have a solution, if things worked great in Kodi 16.1 and now work badly in 17.x and newer, at least theoretically all you gotta do is undo the changes made and it all should work great again.

There as been A LOT of changes between kodi 16.1 and kodi 17.x

Removing all of them would only lead to goes back to kodi 16.1 (what you could already do by simply staying with kodi 16.1 obviously)

Now here is the thing: what you think should be the cause of the issue should not be it because your avancedsettings value were exactly the same than the ones kodi uses by default

But maybe default value is not applied correctly in kodi

Or, like da-anda said, applying it with advancedsettings may cause the CPU frequency to raise. In this case it would be a wild comparison between 10% usage at x GHz and 69% at y GHz
The only way to know would be to force the CPU to run at the same frequency no matter what
Moanbag is in da place!
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Please Provide subtitles security fix for Kodi 16.X00