• 1(current)
  • 2
  • 3
  • 4
  • 5
  • 7
  •   
Random GUI Lockups in newer SVN builds
#1
Has anyone else noticed the last few builds of XBMC are randomly locking up while using the menus and GUI of XBMC? It can be anything that causes this to happen whether your creating new sources, clicking down through movies anything at all. Not as often once a movie is in motion but if you start clicking on things while in the movie for example going back to the main menu while movie is paused.

I recently formatted my 400GB HD with 32k clusters as I had the problem with corrupted/missing data. I also had this locking up issue before I done the format. And for the last few weeks Ive updated XBMC to see if the issue might get resolved. But again last night it happened after few mins of latest T3CH build.

I read somewhere that some people reported unplugging the pads stopped it from happening. So I myself have done this and tried to monitor the problem and to my surprise it seemed to fix XBMC's frequent lockups. I know Ill be asked for a debug log my question is whats the best way to do one with the new feature that can be enabled from within XBMC?
#2
Turn it on in settings->system.

Reboot.

You now have debug logging enabled until you turn it off again.

i.e. wait for it to lock up.

FTP in and grab the log.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
#3
cool Ill do this 2mro night after work. Thanks!
#4
Hi here is the log of the lockup issue I'm having with the controller plugged in. If it makes a difference the controller is plugged into port 1 and the original MS IR receiver is plugged into port 2 all the other ports are empty.

http://pastebin.com/m4a112367

Thanks
#5
Try unplugging the IR receiver (i.e. using the controller only) and see if it still locks up.

Otherwise, do you have the ability to build (or ideally debug) yourself? If so, we can possibly add some better tracking to narrow it down a bit.

Cheers,
Jonathan
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
#6
Ok I will test from here on in without the remote to see what happens. I left a debug log on the last reply am I missing something on it? If you mean compile or build XBMC from the SVN code Ive never done that before but now that you say it I would love to try it. Don't I need to have the XDK and Visual studio apps to do this?
#7
Yes, you need the XDK and VS.Net 2003.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
#8
I build my own daily, and also noticed this problem. I'll turn my debug loggin on and try to also help with this. I also use a joystick in port 1, and IR in port 2 (although i rarely actually use my remote though.)
I'll post my log the next time it locks up.
#9
It'd be useful to know whether said lockups occur due to a direct action (i.e. press on controller or remote) or whether they happen as a result of some other action (eg the GUI does something) or whether they just happen while it's sitting idle.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
#10
Right for the last few days Ive been testing with just the controller plugged in this time to port 1 so without any IR remote at all or anything else in any other ports. And there has been no random crashes, so this may mean that its something to do with having 2 maybe more(Haven't tested more controllers) devices plugged in at any one time.

When I get the crashes it seems to be when I use the select and can even happen when I bring up the options pane to select for example movie info. Hope this info helps in some way.
#11
FWIW, I generally build from SVN every few days or so. My main Xbox has an IR receiver wired into Port 4 with an electrical relay to switch from it to the port if something is plugged in. Basically this means my box "always" has an IR dongle "plugged in" to port 4.
I haven't had any problems with random lockups, sometimes leave the Xbox on for long periods of time (a few days? a week? not sure).
Catchy Signature Here
#12
Hi,

I've also started to experience lockups, sopmetimes when playing, and other times in menus. I'm runing XBMC-SVN_2008-02-10_rev11601-T3CH with just the Microsoft IR plugged in and no controllers. I looked in settings | system but couldn't see an option to turn logging on. Is there a file I can edit to set this manually ?

I don't have the XDK etc to build it myself :-(

Cheers
#13
Ok as of last night I was testing with 2 controllers (Ports 1 and 2) and it hasn't crashed at all for about 2 hours so then I plugged in the IR remote receiver into port 3. So far it hasn't crashed at all which is really annoying me cos I'm starting to wonder is there even a bug anymore? I will continue to test in the meantime with different configurations to try narrow down the problem.

Hey SleepyP sounds like a nifty little mod you got going there would definitely be interested in doing something like that to my xbox. Its weird that this issue is not happening to many users here. Usualy I check the forums through and through and I always end up seeing someone else post about an issue I'm having then it is always fixed in no time thanks to devs. Its sorta mad TBH.

Hey thermionic the option to turn on debug logging from the GUI has only been introduced in last T3CH XBMC 2008-02-24 SVN rev11787. You gotta update to see the new feature mentioned.
#14
I have random lockups for months now, but I always figured it had to be a thermal issue, since I did a lot of silence modding and the debug logs never showed anything usefull.

Reading this it might be something else after all.

Sympthoms for my situation:
- Lockups may occur when using the menu's, especially when browsing media.
I enabled the 'remote code' display because I suspected the hangup to occur when I press a button on the remote.
- I never saw a lockup when playing a movie, except when seeking, or if the movie is pause and I want to continue.
#15
Ok its just happened again 2 secs ago I pressed the down button on the MS remote to exit from the screen saver. Screen saver quit and xbox took the usual 10 secs or so to wake up the the hard drive from low power mode then it happened. I now have a completely locked up XBMC as I write this :-(

Ok so the configuration is ports 1 and 2 both have controllers in them and port 3 has the MS IR Receiver plugged in. I'm now thinking this is a remote control issue when its combined with a controller.
  • 1(current)
  • 2
  • 3
  • 4
  • 5
  • 7
  •   
 
Thread Rating:
  • 1 Vote(s) - 4 Average



Logout Mark Read Team Forum Stats Members Help
Random GUI Lockups in newer SVN builds41