[Kodi 17 Krypton] pause in video playback changed?
#1
Hi,

I noticed a change in the behaviour of the way the remote buttons work during video playback since version 17 (Krypton).
Now i'm not sure if this is because of a version change in Kodi or if it has something to do with a different platform i'm using now.

I'll explain the difference and hope it can be solved to the way is was before.

I used Kodi/XBMC for a long time on a jailbroken Apple TV 2.
Always during video playback when I pressed the pause button (middle of the circle on the remote) the video would pause, just like you would expect it to.

I recently switched to Nvidia Shield (2017 model) and now the pause button doesn't pause the video but just shows the menu bar.
if you click pause again the video pauses but the menu bar remains on screen which is not what i want.

I noticed that during playback, when you hold the pause button, the video will pause but also showing the menu bar.
A: i don't want to press twice or hold the pause button to pause a movie and B: i don't want to see a menu bar when i pause a movie.
Makes sense right?

I just want the video to pause when i press pause with the video full screen just as it is with the older version of Kodi on the ATV2.
But also on many DVD players and other video palyback divices like Video recorders, camcorders andsoforth.. pause is pause.
I tried to get used to the new way but it just doesn't make sense and it annoys me.

The latest version of Kodi working on the ATV2 is Kodi 14 (Helix).
I skipped version 15 and 16 alltogether on the media boxes and the Shield came with version 17 of Kodi.
I used Kodi 15 and 16 on my Macbook Air but that works with a pointer which is totally different so i can't tell how these versions of Kodi behave on the pause button on the remote.

Also i'm not sure if this is a Kodi thing or just a difference in which the remote on the different platform behaves.
I suspect it is a change in the newer version(s) of Kodi.

The remote of the ATV and Shield work and look very much alike but i wish they would behave the same.
I also don't like the way volume is changed on the Shield remote.
With a touch bar which you keep touching accidentally resulting in unwanted volume changes all the time.
But that is a Nvidia thing i guess. On the ATV it was just the up-and-down keys which again make a lot of sense and works fine.

Same goes for the voice control that i never use and keeps popping up. Apple still is king when is comes to user friendlyness.
Unfortunately Kodi doesn't run on the never Apple TV's and the Shield is the next best thing in my opinion.
I just hope there is a way to turn these annoying behaviour differences out of the way.

I tried Kodi's Keymap editor but without any luck so far on the Shield remote.

Hope there is a solution for this, it would make my life a lot more livable.
Reply
#2
I figured a few things out, some things remain unsolved as for now.

Ik ordered a different remote control which will solve my trouble with the volume buttons and voice control.
It will be a while since i will recieve it but i'm confident these issues will be solved.

Remains the button assignment.
I'm pretty sure this is a Kodi issue since i found more people having trouble with it since version 17.
See here for instance:

https://forums.geforce.com/default/topic...ssignment/

Is there anyone who can help me out with this?
Reply
#3
I managed so sideload-install Kodi 16 Jarvis on the Shield TV and the crappy button assignment is still the same so i conclude it is all to blame on the Shield controller.
Reply
#4
You could try and install the Keymap editor add on from the official repo.
It provides a very easy way to assign the right actions to the particular buttons.
Worth a shot.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
[Kodi 17 Krypton] pause in video playback changed?00