Leia and EventClient updates

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Artstar Offline
Junior Member
Posts: 19
Joined: Jun 2014
Reputation: 0
Post: #1
Hi all,

Thought I'd get experimental with Leia nightly builds and so far, it's been fun. However, one thing I've noticed is that issuing a shutdown command to port 9777 from a remote server (using the kodi-send program) doesn't work anymore. I haven't tried any other commands but then again, it's the shutdown one that's more critical for my requirement to get the Kodi box to turn on and off, in sync with the TV set.

I take it the remote command structure for Leia has possibly changed, perhaps it's only possible via the webserver now. Is there an update for the old EventClients tool to suit Leia or has it been deprecated completely, leaving it solely to JSON-RPC?
find quote
DaVu Offline
Team-Kodi Member
Posts: 2,651
Joined: Jan 2011
Reputation: 48
Location: Germany
Post: #2
If I understand correctly, you don't have "Allow remote control from applications on other systems" enabled and if you do that it could be, that kodi crashes. That's a known thing for the moment and the fix is already done, but maybe not in the nightlies yet:

https://github.com/xbmc/xbmc/pull/12276

Locally, if running kodi-send from the same machine, it works pretty fine:

I defined "Quit" in system settings->system->Power saving->Shutdown function to prevent my computer to completely shut down and only quit kodi

then I used:

Code:
kodi-send --host=127.0.0.1 --port=9777 --action=ShutDown

from the same machine and Kodi was closed. Maybe test it locally to confirm it's working from the same machine.
find quote
Artstar Offline
Junior Member
Posts: 19
Joined: Jun 2014
Reputation: 0
Post: #3
Thank for the suggestions, DaVu. Seems like the Shutdown function only quits Kodi but doesn't initiate the Linux shutdown like it used to. I'll double-check the settings concerning the allowing of remote control but I dare say, if it's responding in so far as at least quitting the application, then it is allowing remote control.

I also tried with my Yatse remote application, which seemingly has full control but the Shutdown functionality still only results in Kodi itself closing but not shutting down Linux.

I'll just stick to the "sudo shutdown -P 0" command that I'm ssh'ing to the Kodi NUC. Seems to be the most robust approach.

Thanks again!
find quote
DaVu Offline
Team-Kodi Member
Posts: 2,651
Joined: Jan 2011
Reputation: 48
Location: Germany
Post: #4
@Artstar:

Did you check what is set at: system settings->system->Power saving->Shutdown

which value has this setting?
find quote
Artstar Offline
Junior Member
Posts: 19
Joined: Jun 2014
Reputation: 0
Post: #5
Strangest thing. I thought back to similar issues that I have with some broadcast hardware I work with (where it falsely indicates it's on the right setting). So, I thought I'd try the same trick in Kodi.

Kodi was set to power off, so as an experiment, I set it to Quit (and tested it). Then I set it back to Power Off and it did perform a complete shutdown this time.

Simple fix after all. Smile

Thanks again sir! I've reverted my remote management script back to having Kodi manage the shutdown, just to keep things elegant. Hopefully it will remain that way now.
find quote