Solved Issue - TheMovieDB Search Bug

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Cyntech Offline
Junior Member
Posts: 4
Joined: May 2015
Reputation: 0
Post: #1
Hi all,

I'm getting a bit frustrated with the fact that the OSX version of Kodi 17.3 isn't able to process themoviedb searches.

When viewing the log (https://pastebin.com/fZ0dE7Xa), it shows the search URL, which I've tested in a browser and was able to get a correct response. However, the log shows the results are undefined or empty.

OSX Version: Sierra (10.12.5)
Platform (eg. AppleTV, MacBook, PB170, etc.): MacBook Pro
Install Method (Launcher, dmg, scp, other): dmg
Version of Kodi/XBMC: Nightly kodi-20170606-21c2dba-Krypton-x86_64

To reproduce the issue, I simply right click on a movie, select scan into library. It asks me to manually enter the movie name, which would be reshown to me after clicking done, as if no result was found.
find quote
Karellen Online
Super Moderator
Posts: 2,465
Joined: Apr 2017
Reputation: 45
Post: #2
Hello Cyntech,

Multiple threads on this issue already...

https://forum.kodi.tv/showthread.php?tid=315813
https://forum.kodi.tv/showthread.php?tid=315803

My response from other posts...
Quote:It turns out that TMDB has made some changes to their API. The Kodi team have just yesterday released a fix for this issue. I am wondering if you were a victim of this issue as the symptoms seem similar.

Here is some further reading on the issue if you are interested... https://forum.kodi.tv/showthread.php?tid=315813

Can you check your TMDB addon and ensure you have updated to the latest version 3.9.4. Go to Add-Ons>My Add-Ons>Information Providers>Movie Information. Click "The Movie Database" and then select update.

Let us know if that resolves the problem

If you don't have the update yet, you can download from here and install as a zip via Add-ons... https://kodi.tv/addon/movie-information/movie-database

My Signature
Links to : Forum Rules | Banned Add-Ons | Free Movies/TV Shows | Debug Log |


find quote
Cyntech Offline
Junior Member
Posts: 4
Joined: May 2015
Reputation: 0
Post: #3
Hey Krellen,

I had spent about 30-40mins searching for pre-existing threads but it seems my forum-fu is not strong.

I wasn't sure if it was a scraper issue or a Kodi OSX issue because I use Kodi on OSMC as well and I don't seem to have a problem there. I have just confirmed that my MacBook had 3.9.3 and OSMC has 3.9.4.

The update fixed the issue, thanks for the heads up.
(This post was last modified: 2017-06-10 03:40 by Cyntech.)
find quote
Karellen Online
Super Moderator
Posts: 2,465
Joined: Apr 2017
Reputation: 45
Post: #4
Glad it solved the problem Smile

My Signature
Links to : Forum Rules | Banned Add-Ons | Free Movies/TV Shows | Debug Log |


find quote
Karellen Online
Super Moderator
Posts: 2,465
Joined: Apr 2017
Reputation: 45
Post: #5
Thread marked solved.

My Signature
Links to : Forum Rules | Banned Add-Ons | Free Movies/TV Shows | Debug Log |


find quote