Kodi - Instant recording not working as it should, kodi showing wrong notifications.
#1
When i press record watching live TV a message appears saying "recording scheduled". But it should be 'recording started'

I saw this thread on the NextPVR forum:
https://forums.nextpvr.com/showthread.ph...ifications

Could this be fixed for the MP backend too?

Sent from my ZP999
Reply
#2
does your recording actually start? when I do that I get recording scheduled but it never starts, I need to go back and edit the schedule before it will start. I posted the issue before I saw this.
Reply
#3
As posted in the other thread:

I've just checked. What I did was open the EPG, pressed 'i' on my keyboard to open the contextual menu, then selected 'record' from the buttons.

The remote I have connected to my main PC has very few buttons, so I can't just press 'record' on the remote.

When I press record, it gives me the 'recording scheduled' alert, but the recording does start immediately.

Checked with two different channels.
Reply
#4
I have same issue and wonder why it is not fixed on v18 yet. Following situation:
- Pvr is dvblink
- Instant recording is set to ask
- Epg have all needed infos
- When i click record button then message appears "recording scheduled" but did not start
- When i click record button (second) again then recording starts, red recording button is shown
- When i click record button (third) message appears recording finished but red rec. button is still there
- When i click record button (fourth) message appears recording finished again and then red rec. button is now white
That is not user friendly.
HTPC: Windows 10 v2004, Zalman HD135, Intel i3-7100, GTX 1070, UHD ASUS BW-16D1HT
NAS: Xpenology 6.2.2, Intel i5-6600
Reply
#5
(2017-09-24, 17:58)tehax Wrote: I have same issue and wonder why it is not fixed on v18 yet. Following situation:
- Pvr is dvblink

Two points.

1. This is the MediaPortal section of the forum. I know that someone has reported the same with MediaPortal.

2. As my own testing shows, this isn't a problem for everyone, and these problems are harder to diagnose.

If it does the same with every backend, this would be interesting. At least it might give the developers more chance to work out where in the code the problem lies, if anywhere.
Reply
#6
I search in the forum for my issue and do not notice at the end that i post in mediaportal forum. And yes i think this is a kodi related issue and i hope that some kodi developer will fix this.
HTPC: Windows 10 v2004, Zalman HD135, Intel i3-7100, GTX 1070, UHD ASUS BW-16D1HT
NAS: Xpenology 6.2.2, Intel i5-6600
Reply
#7
I recognize your problem. I had it too with the MediaPortal TVserver as backend. Now i use DVBlink as PVR backend the problem is over. So my guess is it MP related.
Reply
#8
(2017-06-09, 18:38)joostzilla Wrote: When i press record watching live TV a message appears saying "recording scheduled". But it should be 'recording started'

I saw this thread on the NextPVR forum:
https://forums.nextpvr.com/showthread.ph...ifications

Could this be fixed for the MP backend too?
I am getting this too. I have mediaportal tv server as my backend. IT happens on all recording options. SO when I hit the red record button on my Harmony Ultimate and my MCE remote or when I select the keyboard shortcut ctrl + R on my keyboard and even when I select the Kodi player controls and select the record button within the onscreen player controls ALL of those options invoke the "recording scheduled" message. THe recording actually starts but I have to hit the normal stop button to stop it (or the "x" button on the keyboard. When I hit the record button a second time it starts another recording and does all the weird stuff others have mentioned on this thread. 
In the PVR setting section I have "Instant recording action" set to "record current show" and all other buttons and commands are working fine. 
Tried the MCER remote addon, but no difference. Tried adding a keymap command into my userdata keymap folder to see if it made a difference but nope.
The keymap I put in I found searching that another guy had used to add a hotkey. I mapped it to my "g" key because its not used and was simply this:
<keymap>
<global>
<keyboard>
<g>PlayerControl(Record)</g>
</keyboard>
</global>
<FullScreenVideo>
<keyboard>
<g>PlayerControl(Record)</g>
</keyboard>
</FullScreenVideo>
</keymap>
Yep restarted and all of that, but regardless it didn't work, still getting recording scheduled not recording started. Its as if Kodi is somehow reading the signal incorrectly.
THe reason I am concluding that its Kodi is because the same problem seems to occur with a few different backends and as mentioned, it happens on all of the equipment used to initiate the record command.
Any help greatly appreciated.
Reply



Logout Mark Read Team Forum Stats Members Help
Kodi - Instant recording not working as it should, kodi showing wrong notifications.1
This forum uses Lukasz Tkacz MyBB addons.