Thread Rating:
  • 0 Vote(s) - 0 Average
Kodi not displaying 3D in correct aspect ratio
#1
Photo 
I have a lot of 3D movies that have been ripped in full over-under format. This means that the resolution of a single 3D frame for a movie that has an aspect ratio of 16:9 is 1920x2160 (stacking two 1920x1080 frames on top of each other). I don’t have problems with such an aspect ratio.

I have issues with movies that are not in 16:9 aspect ratio. For instance, The Martian bluray has an aspect ratio of 2.40:1, meaning the resolution of single frame is 1920x800 if we get rid of the black bars. So, a single 3D frame for a movie with an aspect ratio is 2.40:1 is 1920x1600 (stacking two 1920x800 frames on top of each other).

I used to watch 3D movies in full over-under format by connecting the TV to my laptop and playing the 3D movie via PotPlayer. Here’s how the movie shows when first opened in PotPlayer:

Image

I can easily change the aspect ratio in PotPlayer to match the original 2:40 aspect ratio. Notice that PotPlayer clearly knows where the resolutions of the top and bottom image and cleverly adds bothers to the top and bottom of each image, and not only to the top and bottom of the combined image. So, I activate the 3D button on the TV, the TV displays the movie in the correct aspect ratio.

Image

I don’t want to always be connecting my laptop to the TV just to watch a 3D movie. I am getting an Android TV box soon and will be running Kodi as my primary media player. The movie looks the same as in PotPlayer when it first launches in Kodi 17.3.

Image

However, when 3D mode is on, the only options available only zoom the picture. This is clearly not what I want as some of the picture is lost. The only mitigating (and non-ideal) solution is for me to set 3D mode off and stretch the picture to a 16:9 aspect ratio. The problem is, this is not the correct aspect ratio, and so the the movie gets stretched vertically.

Image

What can I do to make Kodi display the movie in the correct aspect ratio in the same way PotPlayer does ?
Reply
#2
Try editing the header using mkvmerge, video track - pixel and/or display width and/or height.
HOW TO - Kodi 2D - 3D - UHD (4k) HDR Guide Internal & External Players
Basic Server & Client Setup WOL
If I have been of help, please add to my reputation as a way of saying thanks, it's free.
Reply
#3
Try not to post duplicate messages, @brazen1 offered a solution. The 3D (wiki) wiki and some of the forums that are discussing 3D might help. https://forum.kodi.tv/showthread.php?tid=227437 or https://forum.kodi.tv/showthread.php?tid=214167

It's likely you might have to put your hacker hat on, or just be patient, as I understand a few of the devs have 3D displays, so sooner or later a fix might be in the works.

This is the likely area to be in 'video' issues to move ahead on this subject so I'll merge your two posts in this forum.
Reply
#4
(2017-06-16, 19:24)brazen1 Wrote: Try editing the header using mkvmerge, video track - pixel and/or display width and/or height.

That did the trick. Is there some way I can do edit the aspect ratio without having to demux and mux -- some files are 20GB in size ?
Reply
#5
Handbrake is the go 2 on this.
Reply



Kodi not displaying 3D in correct aspect ratio00