•   
  • 1
  • 40
  • 41
  • 42
  • 43
  • 44(current)
Release -  [CMIK] TFC.tv addon - repo / updates / support
(2018-11-14, 20:57)rpbg Wrote: @cmik,

I checked the ports.conf and found 2 entries of Listen 443:

-------------------------
# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default.conf

Listen 80

<IfModule ssl_module>
    Listen 443
</IfModule>

<IfModule mod_gnutls.c>
    Listen 443
</IfModule>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
------------------------

In addition, I also checked  the enabled modules as you suggested and my apache2 directory is the same as what you have posted.

Furthermore, I executed @d8a3th suggestion, see below for easy reference. 

-----------------------------
1) sudo a2enmod headers
then
2) sudo service apache2 restart
----------------------------
but it did not solve my issue .

The results below is similar to what I have reported yesterday:
----------------------------------
-- Unit apache2.service has begun starting up.
Nov 14 19:29:39 osmc apachectl[10934]: AH00526: Syntax error on line 2 of /etc/apache2/sites-enabled/default-ssl.conf:
Nov 14 19:29:39 osmc apachectl[10934]: Invalid command '\xc2\xa0', perhaps misspelled or defined by a module not included in the server configuration
Nov 14 19:29:39 osmc apachectl[10934]: Action 'start' failed.
Nov 14 19:29:39 osmc apachectl[10934]: The Apache error log may have more information.
Nov 14 19:29:39 osmc systemd[1]: apache2.service: Control process exited, code=exited status=1
Nov 14 19:29:39 osmc systemd[1]: Failed to start The Apache HTTP Server.
-- Subject: Unit apache2.service has failed
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- Unit apache2.service has failed.
--
-- The result is failed.
Nov 14 19:29:39 osmc systemd[1]: apache2.service: Unit entered failed state.
Nov 14 19:29:39 osmc systemd[1]: apache2.service: Failed with result 'exit-code'.
Nov 14 19:29:39 osmc sudo[10928]: pam_unix(sudoConfusedession): session closed for user root

----------------------------------

Any furhter hints where I can look into?

Thanks in advanced.
 Maybe look at this : https://community.atlassian.com/t5/Quest...q-p/433267
Reply
(2018-11-15, 00:49)d8a3th Wrote: /quote]

Can you check in your logs that you are passing through the Apache proxypass when you call akamai url ?

I'll check when I get home tonight. Thanks cmik.
Reply
(2018-11-14, 13:16)Bodoy Wrote: Thank you very much for the effort CMIK.
Meanwhile, I am using TFC apk for now. You can as well use ROKU as an alternative. Interface is similar to CMIK Kodi addon and cost effective as well.
 Does Roku have a full screen like CMIK's add-on?  Does it have ads before the show starts and at the middle of the show?
Reply
(2018-11-15, 04:49)timduncan Wrote:
(2018-11-14, 13:16)Bodoy Wrote: Thank you very much for the effort CMIK.
Meanwhile, I am using TFC apk for now. You can as well use ROKU as an alternative. Interface is similar to CMIK Kodi addon and cost effective as well.
 Does Roku have a full screen like CMIK's add-on?  Does it have ads before the show starts and at the middle of the show?


Roku has a pretty good interface, yes it plays in full screen (why wouldn’t it be?), though there’s no way to add your frequently watched teleseryes in a Favourites section like you could in Kodi, other than that Roku is great alternative. In terms of ads I think it depends on your Subscription, if you have Lite subscription then I guess you are more likely to see some form of ads.

Checkout the interface here:
https://channelstore.roku.com/en-gb/details/234709/tfc
Reply
@cmik,  here an update from me:

Thanks for your hint to check the following site:  https://community.atlassian.com/t5/Quest...q-p/433267
And, indeed after following the tips  to check any incorrect symbols in one of the configuration files.  I found and removed the incorrect symbols
in /etc/apache2/ports.conf.  However, amending/saving the configuration file and rerunning it   I have got new error, hence it failed again as follows:
------------------------------
-- Unit apache2.service has begun starting up.
Nov 15 14:06:55 osmc apachectl[4193]: AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1. Set the 'ServerName' directive gl
Nov 15 14:06:55 osmc apachectl[4193]: (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
Nov 15 14:06:55 osmc apachectl[4193]: no listening sockets available, shutting down
Nov 15 14:06:55 osmc apachectl[4193]: AH00015: Unable to open logs
Nov 15 14:06:55 osmc apachectl[4193]: Action 'start' failed.
Nov 15 14:06:55 osmc apachectl[4193]: The Apache error log may have more information.
Nov 15 14:06:55 osmc systemd[1]: apache2.service: Control process exited, code=exited status=1
Nov 15 14:06:55 osmc systemd[1]: Failed to start The Apache HTTP Server.
-- Subject: Unit apache2.service has failed
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- Unit apache2.service has failed.
--
-- The result is failed.
Nov 15 14:06:55 osmc systemd[1]: apache2.service: Unit entered failed state.
Nov 15 14:06:55 osmc systemd[1]: apache2.service: Failed with result 'exit-code'.
Nov 15 14:06:55 osmc sudo[4187]: pam_unix(sudoConfusedession): session closed for user root
------------------------------
Reply
Is there something missing in my Settings?  Here is the setting of my /etc/host (computer A (Kodi))
--------------------------
::1                    osmc localhost6.localdomain6 localhost6
127.0.1.1          osmc

127.0.0.1           localhost
::1                    localhost ip6-localhost ip6-loopback
fe00::0             ip6-localnet
ff00::0              ip6-mcastprefix
ff02::1              ip6-allnodes
ff02::2              ip6-allrouters
171.219.68.60   o2-i.akamaihd.net
-----------------------------------------------
Reply
(2018-11-15, 15:09)rpbg Wrote: @cmik,  here an update from me:

Thanks for your hint to check the following site:  https://community.atlassian.com/t5/Quest...q-p/433267
And, indeed after following the tips  to check any incorrect symbols in one of the configuration files.  I found and removed the incorrect symbols
in /etc/apache2/ports.conf.  However, amending/saving the configuration file and rerunning it   I have got new error, hence it failed again as follows:
------------------------------
-- Unit apache2.service has begun starting up.
Nov 15 14:06:55 osmc apachectl[4193]: AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1. Set the 'ServerName' directive gl
Nov 15 14:06:55 osmc apachectl[4193]: (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
Nov 15 14:06:55 osmc apachectl[4193]: no listening sockets available, shutting down
Nov 15 14:06:55 osmc apachectl[4193]: AH00015: Unable to open logs
Nov 15 14:06:55 osmc apachectl[4193]: Action 'start' failed.
Nov 15 14:06:55 osmc apachectl[4193]: The Apache error log may have more information.
Nov 15 14:06:55 osmc systemd[1]: apache2.service: Control process exited, code=exited status=1
Nov 15 14:06:55 osmc systemd[1]: Failed to start The Apache HTTP Server.
-- Subject: Unit apache2.service has failed
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- Unit apache2.service has failed.
--
-- The result is failed.
Nov 15 14:06:55 osmc systemd[1]: apache2.service: Unit entered failed state.
Nov 15 14:06:55 osmc systemd[1]: apache2.service: Failed with result 'exit-code'.
Nov 15 14:06:55 osmc sudo[4187]: pam_unix(sudoConfusedession): session closed for user root
------------------------------


It seems you already have something on port 80. Maybe change the port 80 to 8080.
Reply
Success !!!. Thanks cmik.

I have to do a fresh Raspbian install, because before I was using Octoprint which is also running on Apache2. Basically just followed your instructions and it worked.
Reply
@cmik,  Yes, it works for me as well  Shy .
Thanks a million.

Similar to d8a3th I used Raspbian (RPi 2,)  and installed Apache2 as well.
In my case, although I followed your easy instructions I had the following two issues 
(a)  incorrect symbols in configuration file /etc/apache2/sites-enabled/default-ssl.conf -  solution: edit default-ssl.conf, remove incorrect symbols and save.
(b)  /etc/apache2/ports.conf - solution:  since I already used port 80 I replaced Listen 80 to Listen 8080.

Both minor issues was definitely my bad And now it works for me as well.  Thanks you very much  again CMIK.
Reply
Can this be done on android boxes?
Reply
(2018-11-13, 21:49)cmik Wrote: sudo service apache2 restartTo use Apache as an SSL proxy :
- You will need an Apache server accessible from your Kodi system.
- You will need to access ssh to your Kodi system and be able to make changes to /etc/hosts file.


In my case, I use Kodi on a raspberry pi (computer A) and have an Apache server on another raspberry (computer B).

On computer B (Apache):
1. enable ssl and proxy on Apache server:
$ sudo a2enmod ssl
$ sudo a2enmod proxy
$ sudo a2enmod proxy_http

2. create SSL certificate :
$ sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/ssl/private/apache-selfsigned.key -out /etc/ssl/certs/apache-selfsigned.crt
$ sudo openssl dhparam -out /etc/ssl/certs/dhparam.pem 2048
see step one of this article : https://www.digitalocean.com/community/t...untu-16-04

3. create a virtual host :
$ sudo nano /etc/apache2/sites-enabled/default-ssl.conf
with content :
<IfModule mod_ssl.c>
        <VirtualHost *:443>
                ServerName o2-i.akamaihd.net

                ErrorLog ${APACHE_LOG_DIR}/error.log
                CustomLog ${APACHE_LOG_DIR}/access.log combined

                SSLEngine on
                SSLProxyEngine on
                SSLCertificateFile /etc/ssl/certs/apache-selfsigned.crt
                SSLCertificateKeyFile /etc/ssl/private/apache-selfsigned.key
                SSLCertificateChainFile /etc/ssl/certs/dhparam.pem

                ProxyRequests Off
                <Proxy *>
                        AllowOverride all
                        Order deny,allow
                        Allow from all
                </Proxy>

                ProxyErrorOverride On
                ProxyPreserveHost On

                RequestHeader unset Icy-MetaData
                RequestHeader unset User-Agent
                RequestHeader append User-Agent "Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0"

                ProxyPass / https://o2-i.akamaihd.net/
                ProxyPassReverse / https://o2-i.akamaihd.net/

                <Location />
                        Order allow,deny
                        Allow from all
                </Location>
        </VirtualHost>
</IfModule>
$ sudo service apache2 restart

On computer A (Kodi):
4. modify /etc/hosts and make the host o2-i.akamaihd.net point to address ip of your machine B (ex : 192.168.0.25):
Code:
192.168.0.25    o2-i.akamaihd.net




I couldn't get this to work on Apache, it wouldn't even start once I load the configuration file, it immediately crashes when I do 
sudo service apache2 restart
. Apache won't start until I remove the config file.

The apache error log only gives this:
[Sat Nov 17 12:05:38.195003 2018] [ssl:warn] [pid 26:tid 140268903777472] AH01909: 172.17.0.2:443:0 server certificate does NOT include an ID which matches the server name
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 172.17.0.2. Set the 'ServerName' directive globally to suppress this message
[Sat Nov 17 12:05:38.217427 2018] [ssl:warn] [pid 26:tid 140268903777472] AH01909: 172.17.0.2:443:0 server certificate does NOT include an ID which matches the server name
[Sat Nov 17 12:05:38.219076 2018] [mpm_event:notice] [pid 26:tid 140268903777472] AH00489: Apache/2.4.25 (Debian) OpenSSL/1.0.2l configured -- resuming normal operations
[Sat Nov 17 12:05:38.221437 2018] [core:notice] [pid 26:tid 140268903777472] AH00094: Command line: '/usr/sbin/apache2 -D FOREGROUND'
[Sat Nov 17 12:11:14.775481 2018] [mpm_event:notice] [pid 26:tid 140268903777472] AH00491: caught SIGTERM, shutting down

I also wonder what port will Kodi hit when it hits Apache, will it go straight to 443? The hosts file looks to me that it goes to port 80, but it's not configured in Apache? 🤔
Reply
(1 hour ago)markv Wrote:
(2018-11-13, 21:49)cmik Wrote: sudo service apache2 restartTo use Apache as an SSL proxy :
- You will need an Apache server accessible from your Kodi system.
- You will need to access ssh to your Kodi system and be able to make changes to /etc/hosts file.


In my case, I use Kodi on a raspberry pi (computer A) and have an Apache server on another raspberry (computer B).

On computer B (Apache):
1. enable ssl and proxy on Apache server:
$ sudo a2enmod ssl
$ sudo a2enmod proxy
$ sudo a2enmod proxy_http

2. create SSL certificate :
$ sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/ssl/private/apache-selfsigned.key -out /etc/ssl/certs/apache-selfsigned.crt
$ sudo openssl dhparam -out /etc/ssl/certs/dhparam.pem 2048
see step one of this article : https://www.digitalocean.com/community/t...untu-16-04

3. create a virtual host :
$ sudo nano /etc/apache2/sites-enabled/default-ssl.conf
with content :
<IfModule mod_ssl.c>
        <VirtualHost *:443>
                ServerName o2-i.akamaihd.net

                ErrorLog ${APACHE_LOG_DIR}/error.log
                CustomLog ${APACHE_LOG_DIR}/access.log combined

                SSLEngine on
                SSLProxyEngine on
                SSLCertificateFile /etc/ssl/certs/apache-selfsigned.crt
                SSLCertificateKeyFile /etc/ssl/private/apache-selfsigned.key
                SSLCertificateChainFile /etc/ssl/certs/dhparam.pem

                ProxyRequests Off
                <Proxy *>
                        AllowOverride all
                        Order deny,allow
                        Allow from all
                </Proxy>

                ProxyErrorOverride On
                ProxyPreserveHost On

                RequestHeader unset Icy-MetaData
                RequestHeader unset User-Agent
                RequestHeader append User-Agent "Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0"

                ProxyPass / https://o2-i.akamaihd.net/
                ProxyPassReverse / https://o2-i.akamaihd.net/

                <Location />
                        Order allow,deny
                        Allow from all
                </Location>
        </VirtualHost>
</IfModule>
$ sudo service apache2 restart

On computer A (Kodi):
4. modify /etc/hosts and make the host o2-i.akamaihd.net point to address ip of your machine B (ex : 192.168.0.25):
Code:
192.168.0.25    o2-i.akamaihd.net




I couldn't get this to work on Apache, it wouldn't even start once I load the configuration file, it immediately crashes when I do 
sudo service apache2 restart
. Apache won't start until I remove the config file.

The apache error log only gives this:
[Sat Nov 17 12:05:38.195003 2018] [ssl:warn] [pid 26:tid 140268903777472] AH01909: 172.17.0.2:443:0 server certificate does NOT include an ID which matches the server name
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 172.17.0.2. Set the 'ServerName' directive globally to suppress this message
[Sat Nov 17 12:05:38.217427 2018] [ssl:warn] [pid 26:tid 140268903777472] AH01909: 172.17.0.2:443:0 server certificate does NOT include an ID which matches the server name
[Sat Nov 17 12:05:38.219076 2018] [mpm_event:notice] [pid 26:tid 140268903777472] AH00489: Apache/2.4.25 (Debian) OpenSSL/1.0.2l configured -- resuming normal operations
[Sat Nov 17 12:05:38.221437 2018] [core:notice] [pid 26:tid 140268903777472] AH00094: Command line: '/usr/sbin/apache2 -D FOREGROUND'
[Sat Nov 17 12:11:14.775481 2018] [mpm_event:notice] [pid 26:tid 140268903777472] AH00491: caught SIGTERM, shutting down

I also wonder what port will Kodi hit when it hits Apache, will it go straight to 443? The hosts file looks to me that it goes to port 80, but it's not configured in Apache?

It is 443 (https).
Check if you have SSL enabled (with Listen 443 in ports.conf file) and headers also which I’ve forgotten in my post.
Reply
(1 hour ago)cmik Wrote:
(1 hour ago)markv Wrote:
(2018-11-13, 21:49)cmik Wrote: sudo service apache2 restartTo use Apache as an SSL proxy :
- You will need an Apache server accessible from your Kodi system.
- You will need to access ssh to your Kodi system and be able to make changes to /etc/hosts file.


In my case, I use Kodi on a raspberry pi (computer A) and have an Apache server on another raspberry (computer B).

On computer B (Apache):
1. enable ssl and proxy on Apache server:
$ sudo a2enmod ssl
$ sudo a2enmod proxy
$ sudo a2enmod proxy_http

2. create SSL certificate :
$ sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/ssl/private/apache-selfsigned.key -out /etc/ssl/certs/apache-selfsigned.crt
$ sudo openssl dhparam -out /etc/ssl/certs/dhparam.pem 2048
see step one of this article : https://www.digitalocean.com/community/t...untu-16-04

3. create a virtual host :
$ sudo nano /etc/apache2/sites-enabled/default-ssl.conf
with content :
<IfModule mod_ssl.c>
        <VirtualHost *:443>
                ServerName o2-i.akamaihd.net

                ErrorLog ${APACHE_LOG_DIR}/error.log
                CustomLog ${APACHE_LOG_DIR}/access.log combined

                SSLEngine on
                SSLProxyEngine on
                SSLCertificateFile /etc/ssl/certs/apache-selfsigned.crt
                SSLCertificateKeyFile /etc/ssl/private/apache-selfsigned.key
                SSLCertificateChainFile /etc/ssl/certs/dhparam.pem

                ProxyRequests Off
                <Proxy *>
                        AllowOverride all
                        Order deny,allow
                        Allow from all
                </Proxy>

                ProxyErrorOverride On
                ProxyPreserveHost On

                RequestHeader unset Icy-MetaData
                RequestHeader unset User-Agent
                RequestHeader append User-Agent "Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0"

                ProxyPass / https://o2-i.akamaihd.net/
                ProxyPassReverse / https://o2-i.akamaihd.net/

                <Location />
                        Order allow,deny
                        Allow from all
                </Location>
        </VirtualHost>
</IfModule>
$ sudo service apache2 restart

On computer A (Kodi):
4. modify /etc/hosts and make the host o2-i.akamaihd.net point to address ip of your machine B (ex : 192.168.0.25):
Code:
192.168.0.25    o2-i.akamaihd.net




I couldn't get this to work on Apache, it wouldn't even start once I load the configuration file, it immediately crashes when I do 
sudo service apache2 restart
. Apache won't start until I remove the config file.

The apache error log only gives this:
[Sat Nov 17 12:05:38.195003 2018][ssl:warn][pid 26:tid 140268903777472] AH01909: 172.17.0.2:443:0 server certificate does NOT include an ID which matches the server name
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 172.17.0.2. Set the 'ServerName' directive globally to suppress this message
[Sat Nov 17 12:05:38.217427 2018][ssl:warn][pid 26:tid 140268903777472] AH01909: 172.17.0.2:443:0 server certificate does NOT include an ID which matches the server name
[Sat Nov 17 12:05:38.219076 2018][mpm_event:notice][pid 26:tid 140268903777472] AH00489: Apache/2.4.25 (Debian) OpenSSL/1.0.2l configured -- resuming normal operations
[Sat Nov 17 12:05:38.221437 2018][core:notice][pid 26:tid 140268903777472] AH00094: Command line: '/usr/sbin/apache2 -D FOREGROUND'
[Sat Nov 17 12:11:14.775481 2018][mpm_event:notice][pid 26:tid 140268903777472] AH00491: caught SIGTERM, shutting down

I also wonder what port will Kodi hit when it hits Apache, will it go straight to 443? The hosts file looks to me that it goes to port 80, but it's not configured in Apache?  

It is 443 (https).
Check if you have SSL enabled (with Listen 443 in ports.conf file) and headers also which I’ve forgotten in my post.  
 
Thanks for the quick response, it still wouldn't work, I believe I've enabled all the modules you've stated


[email protected]:~# a2enmod ssl
Considering dependency setenvif for ssl:
Module setenvif already enabled
Considering dependency mime for ssl:
Module mime already enabled
Considering dependency socache_shmcb for ssl:
Module socache_shmcb already enabled
Module ssl already enabled
[email protected]:~# a2enmod proxy
Module proxy already enabled
[email protected]:~# a2enmod proxy_http
Considering dependency proxy for proxy_http:
Module proxy already enabled
Module proxy_http already enabled
[email protected]:~# a2enmod headers
Module headers already enabled
[email protected]:~# service apache2 reload
[FAIL] Reloading Apache httpd web server: apache2 failed!
[warn] The apache2 configtest failed. Not doing anything. ... (warning).
Output of config test was:
AH00526: Syntax error on line 2 of /etc/apache2/sites-enabled/default-ssl.conf:
Invalid command '\xc2\xa0', perhaps misspelled or defined by a module not included in the server configuration
Action 'configtest' failed.
The Apache error log may have more information.
[email protected]:~#

I only did reload just so it wouldn't crash, apache wouldn't start again without it getting fixed first.


and ports.conf looks ok:


Listen 80

<IfModule ssl_module>
    Listen 443
</IfModule>

<IfModule mod_gnutls.c>
    Listen 443
</IfModule>
Reply
(22 minutes ago)markv Wrote:
(1 hour ago)cmik Wrote:
(1 hour ago)markv Wrote: I couldn't get this to work on Apache, it wouldn't even start once I load the configuration file, it immediately crashes when I do 
sudo service apache2 restart
. Apache won't start until I remove the config file.

The apache error log only gives this:
[Sat Nov 17 12:05:38.195003 2018][ssl:warn][pid 26:tid 140268903777472] AH01909: 172.17.0.2:443:0 server certificate does NOT include an ID which matches the server name
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 172.17.0.2. Set the 'ServerName' directive globally to suppress this message
[Sat Nov 17 12:05:38.217427 2018][ssl:warn][pid 26:tid 140268903777472] AH01909: 172.17.0.2:443:0 server certificate does NOT include an ID which matches the server name
[Sat Nov 17 12:05:38.219076 2018][mpm_event:notice][pid 26:tid 140268903777472] AH00489: Apache/2.4.25 (Debian) OpenSSL/1.0.2l configured -- resuming normal operations
[Sat Nov 17 12:05:38.221437 2018][core:notice][pid 26:tid 140268903777472] AH00094: Command line: '/usr/sbin/apache2 -D FOREGROUND'
[Sat Nov 17 12:11:14.775481 2018][mpm_event:notice][pid 26:tid 140268903777472] AH00491: caught SIGTERM, shutting down

I also wonder what port will Kodi hit when it hits Apache, will it go straight to 443? The hosts file looks to me that it goes to port 80, but it's not configured in Apache?  

It is 443 (https).
Check if you have SSL enabled (with Listen 443 in ports.conf file) and headers also which I’ve forgotten in my post.  
 
Thanks for the quick response, it still wouldn't work, I believe I've enabled all the modules you've stated


[email protected]:~# a2enmod ssl
Considering dependency setenvif for ssl:
Module setenvif already enabled
Considering dependency mime for ssl:
Module mime already enabled
Considering dependency socache_shmcb for ssl:
Module socache_shmcb already enabled
Module ssl already enabled
[email protected]:~# a2enmod proxy
Module proxy already enabled
[email protected]:~# a2enmod proxy_http
Considering dependency proxy for proxy_http:
Module proxy already enabled
Module proxy_http already enabled
[email protected]:~# a2enmod headers
Module headers already enabled
[email protected]:~# service apache2 reload
[FAIL] Reloading Apache httpd web server: apache2 failed!
[warn] The apache2 configtest failed. Not doing anything. ... (warning).
Output of config test was:
AH00526: Syntax error on line 2 of /etc/apache2/sites-enabled/default-ssl.conf:
Invalid command '\xc2\xa0', perhaps misspelled or defined by a module not included in the server configuration
Action 'configtest' failed.
The Apache error log may have more information.
[email protected]:~#

I only did reload just so it wouldn't crash, apache wouldn't start again without it getting fixed first.


and ports.conf looks ok:


Listen 80

<IfModule ssl_module>
    Listen 443
</IfModule>

<IfModule mod_gnutls.c>
    Listen 443
</IfModule>

For that error message, please look at what I’ve answered to rpbg on posts above.
Reply
  •   
  • 1
  • 40
  • 41
  • 42
  • 43
  • 44(current)
 
Thread Rating:
  • 6 Vote(s) - 4.83 Average



Logout Mark Read Team Forum Stats Members Help
[CMIK] TFC.tv addon - repo / updates / support4.836