Thread Rating:
  • 0 Vote(s) - 0 Average
BUG - High fequence tone after playback, since Kodi 17
#1
Hi guys!

Since Kodi 17 I suffer from an annoying bug/feature: I hear a high frequency tone after playing a movie (with multi channel sound).

My setup: RP3 (running OSMC) <--HDMI--> AV Receiver <--HDMI--> TV

Kodi audio is configured with "Audio pass-through" and "adjust PLL" (don't know if that is related).

<= Kodi 16 (no issue):

Kodi starts. AVR shows "PCM" and two little symbols "L" "R" for stereo sound.
If I start e.g. a movie with surround sound, AVR shows "Dolby Digital" and "L" "C" "R" "SL" "SW" "SR".
When the movie comes to the end and stops (I see Kodi GUI), the AVR shows again PCM and "L" "R".

> Kodi 16 (I tried 17.x till current 17.3):
Kodi starts. AVR shows "PCM" and two little symbols "L" "R" for stereo sound.
If I start e.g. a movie with surround sound, AVR shows "Dolby Digital" and "L" "C" "R" "SL" "SW" "SR".
When the movie comes to the end and stops, the AVR shows again PCM, but NO "L" "R" symbols.
I could live with that Smile But: I also hear a continues very high frequency tone.
I can fix that by just starting the movie again and then manual stopping. AVR returns to PCM and "L" "R" (+no abnormal sound).

What I already tried:
I noticed the new option in Kodi 17 "send low volume noise". I disabled that, but with no success.
Also I played arround with PLL from "low" to "high" without any change.

I guess something must have changed in the way Kodi handles the end of the movie and returns to the GUI. Because manually stopping a movie doesn't suffer from that problem.

Debug log (provoking the issue): https://pastebin.com/raw/8zj4Whsk

Any advice would be highly appreciated. If you need further information, let me know.

Best regards,
Casper
Reply
#2
Can you post (e.g. to pastebin) the contents of ~/.kodi/userdata/guisettings.xml
Reply
#3
Have a look here: https://pastebin.com/raw/nwjCbHLg
Reply
#4
Okay, I think you have number of channels set to 8 and AC3 transcode enabled.
Can you try setting number of channels to 2?
(Note: this isn't number of speakers - AC3 uses 2 physical channels - you will still get 5.1 audio out)
Reply
#5
No, number of channels are set to 5.1.

Image

Image

I guess you saw in the guisettings.xml this:
Code:
<channels>8</channels>

I think, that this number does not represent the actual numbers of channels, but instead a kind of index. I figured this out:

Code:
Number of channels          guisettings.xml value

2                              1
2.1                            2
3                              3
3.1                            4
4.0                            5
...                           ...
5.1                            8

I've followed your advice and set the number of channels to 2.0 (+rebooted the RP). But unfortunately, that didn't fix it for me.

And thank you man for digging into it!
Reply
#6
Try turning off ”keep audio device alive”
If I have helped you or increased your knowledge, click the 'thank user' button to give thanks :) (People with less than 20 posts won't see the "Thank you" button.)
Reply
#7
This seems to fix it, but introduce another problem: When I now start a movie, I have at the beginning a short audio drop out Undecided

fyi: "Keep audio device alive" worked flawless for me until v17.
Reply
#8
In system/audio settings can you select "Reset above settings to default".
Does the problem occur?
If it doesn't then one at a time change the settings you want and test after each change. Which one causes it?
Reply
#9
I did reset the audio settings.

I enabled "PLL" and "pass through" (+ the two options, that my AVR is Dolby Digital and DTS capable), the rest of the settings I've left on the defaults: issue is there

If I disable Keep audio alive (default setting was 1min), the issue is gone.


Edit:

Quote:In system/audio settings can you select "Reset above settings to default".
Does the problem occur?
No, because it only happens with pass through, not with PCM sound.
Reply
#10
(2017-07-03, 20:39)casperklein Wrote: I did reset the audio settings.

I enabled "PLL" and "pass through" (+ the two options, that my AVR is Dolby Digital and DTS capable), the rest of the settings I've left on the defaults: issue is there

So after resetting settings and *just* enabling AC3 passthrough (and nothing else) you get the tone?
Reply
#11
If I only enable pass through, I just get PCM sound (no pass through bit stream).

fyi: That's because I've also set "sync playback to display" in the video settings, so Kodi will reencode the audio and send as PCM if PLL is not activated
Reply
#12
(2017-07-03, 22:15)casperklein Wrote: If I only enable pass through, I just get PCM sound (no pass through bit stream).

fyi: That's because I've also set "sync playback to display" in the video settings, so Kodi will reencode the audio and send as PCM if PLL is not activated

Okay, then remove "sync playback to display". Test with just AC3 enabled.
I want to know the minimum changes from defaults that has the problem.
Reply
#13
I disabled "Sync playback to display" and did reset the audio settings. Then I just enabled pass through and AC3 as you said + rebooted the RP. I could reproduce the issue.
Reply
#14
Thank you so far! If I can further test things or provide information please let me know Smile
Reply



High fequence tone after playback, since Kodi 1700