Library showing blank TV Show when there should be episodes
#1
I've been pulling my hair out trying everything I can think of but nothing is fixing my issue.

I recently upgraded all of the episodes of a TV Show (Parks and Recreation) from 720p to 1080p. I use Ember Media Manager to manage all of my TV Shows so I deleted all the old video and nfo files. Rescraped the entire show in EMM so that it created all new nfo files and then used the context menu in Kodi to remove Parks and Recreation from my library so that it would pull in all the new video and nfo files. Problem is it refuses to do so. I now just get 0 episodes under Parks and Recreation but it does show the fanart and poster art. I know the files aren't the issue because if I go into File Explorer in Kodi I can navigate to and play the files just fine.

I have tried deleting Myvideos107.db. I have tried removing the source and re-adding and recraping (locally) my entire library. I have even tried changing the source from the smb share (192.168.1.3) to the mapped network drive in Windows (G:\) but everytime I rescrape my library Parks and Recreation shows as 0 episodes.

As you can see from my screenshots, there is nothing wrong with my folder structure:
Image

Image

Can anyone please help?
Reply
#2
I went hunting in the log file and found the following:
Image

Anyone know why I'm getting this error?
Reply
#3
Holy shit I FINALLY figured it out! Turns out it was something as ridiculously simple as episode title mismatching. Ember Media Manager had the show title as Parks And Recreation, whereas my folder and files were named Parks and Recreation. Edited the show title in EMM to lower case "a" and updated the tvshow.nfo file and it scrapes fine in Kodi now!
Reply
#4
That sounds very strange... looks like a bug or something other strange situation in Kodi. In theory it can't be an issue that the tv shows folder don't have the same folder name like the title in tvshow.nfo. I mean, you can use "The.Simpsons" as folder name and set the title to "The Simpsons" in tvshow.nfo.
German Ember Media Manager Support

Daily Builds - Link
Latest official Ember-MM version - Ember Media Manager 1.4.x
Reply
#5
(2017-07-10, 17:33)DanCooper Wrote: That sounds very strange... looks like a bug or something other strange situation in Kodi. In theory it can't be an issue that the tv shows folder don't have the same folder name like the title in tvshow.nfo. I mean, you can use "The.Simpsons" as folder name and set the title to "The Simpsons" in tvshow.nfo.
Yeah, I'm really not sure because even when Kodi was showing 0 episodes it was still pulling in the tvshow.nfo file because it would show the tv show desciption and all of the show's details. Maybe it was because all of the episode nfo files weren't matched exactly? I updated all of those at the same time as updating the tvshow.nfo file so that may have been the fix.
Reply
#6
(2017-07-10, 17:02)Yousty Wrote: Holy shit I FINALLY figured it out! Turns out it was something as ridiculously simple as episode title mismatching. Ember Media Manager had the show title as Parks And Recreation, whereas my folder and files were named Parks and Recreation. Edited the show title in EMM to lower case "a" and updated the tvshow.nfo file and it scrapes fine in Kodi now!

Thanks you so much !
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Library showing blank TV Show when there should be episodes00