DS4 (PS4) controller not working on Kodi OSX; Cannot configure D-pad
Dear members of the Kodi forum,

I have an inquiry regarding the functionality of the PS4 DS4 Controller on Kodi 20170707, OSX Sierra 10.12.5.

I am unable to configure the D-pad on the PS4 controller, the controller button assignments work until I get to the d-pad, which does not register the buttons at all. I tried to skip the configuration of the D-pad and went to configure the other buttons instead but when I exit out of the controller configurator, the controller does not respond to input at all.

However, when I tried the PS4 controller on a Windows 10 PC with Kodi installed, the controller functioned 100%. Is the PS4 controller supported for the OS X version of Kodi?

I am using the original Playstation DS4 USB Wireless Adapter; Sierra 10.12.5; i5-6500; STRIX GTX960; the nightly and official Kodi OS X releases 20170707 were tested, none worked.

This is a really big deal for me! I really want to get it to work so I don't have to boot to Windows every time to use Kodi. Thank you very much. Any help is appreciated.

Best regards,

Hi DS4controllermac,

When I was writing the new joystick support for Kodi v17, I tested pretty much every controller on pretty much every platform. I remember running into this problem on OSX, and traced the missing D-pad all the way to the Cocoa joystick driver. It simply didn't generate events for the D-pad.

To isolate the problem, we should try to reproduce on as many other apps as possible. If we find one that works, I can update our Cocoa support, or implement a new API if need be.
Dear GarBear,

thank you very much for your reply, I really appreciate it.

I tried the PS4 controller on Steam in OSX and it works with the d-pad as well, but I can't think of any other apps to test it on. To be frank I am only using the PS4 controller for Kodi, as I find it very convenient that I can plug in my headphones to the controller and watch movies from across the room on the big TV connected to my 'Mac'.

Another thing I noticed was that in OSX Kodi, when I go to Settings > System Settings > Input > Peripherals , there is only a package without a name, which I find fairly strange. In W10 Kodi, the package has a name 'Dualshock 4 USB Wireless Adaptor'.

When using Steam in OSX, and also in the OSX itself, the controller is recognized as a 'Dualshock 4 USB Wireless Adaptor', and even in OSX Kodi I can set the audio output to 'Dualshock 4 USB Wireless Adaptor' without any problems, so it recognizes audio from the controller correctly, but not all the buttons, specifically not the d-pad. Inability to configure the d-pad now means that I cannot use the controller at all, as all other buttons that were successfully recognized are not saved when exiting out of the controller configurator tool.

Is it possible to switch to a different joystick driver other than Cocoa? Do you think that the fact that a missing package name in the > Input > Peripherals menu has something to do with the Cocoa joystick driver? I read on the PlayStation website that the DS4 USB Wireless adaptor is indeed compatible with OSX, but I cannot download any drivers for it, so I assumed that it does not require any third-party drivers.

I am willing to do some further testing to help determine the exact issue.

Thank you very much. Best regards,

I have the same problem, found this thread on google search. Mac Mini 2015, DS4 v2 controller with DS4 USB wireless adapter. I can live without non-functioning arrow keys, my problem is that I cannot get the DS4 controller to work in Kodi at all. Just like DS4controllermac said, when I leave the controller mapping window, none of the buttons/triggers/joysticks that I successfully mapped work.
Hi garbear,
Current versions of OpenEmu handle the PS4 controller well.
Maybe this will help: https://github.com/OpenEmu/OpenEmu-SDK/b...eHandler.h
Dolphin also handles it well.
I think there will be a lot of happy people if this popular controller could work properly.
thanks for linking source code! I don't know objective c (.mm files), so it'll take me a long time to integrate this code, but at least I know where to start. I'll check out Dolphin too. This will be a v19 change though.
in Retroarch 's osx version ,the d-pad was worked too, can you fix it ?
D-pad and touchPad on the PS4 controller still can't work.(KODI:18.6, Mac OS X: 10.15.4)
But D-pad and touchPad was worked on Steam,
and D-pad was work on RetroArch.
Kodi's joystick code on OSX still hasn't been updated, so some D-pads are still broken. Another developer will have to volunteer to port the joystick code from a working emulator like OpenEMU or Dolphin to Kodi.
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
DS4 (PS4) controller not working on Kodi OSX; Cannot configure D-pad00
This forum uses Lukasz Tkacz MyBB addons.