Solved Issue - Unable to play DTS-movies

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Necronomic77 Offline
Junior Member
Posts: 5
Joined: Jul 2017
Reputation: 0
Post: #1
Hi guys,

I've got a very strange problem here, hope someone can help me to an solution.

The problem is when i'm playing a movie with DTS-sound, Kodi 17.3 automaticlly encodes the sound to Dolby-sound.
I'm running Kodi in Windows 10 via a AVR reciever witch is an Onkyo TX-NR656.

In Kodi i've set it up to 2.0 sound and passthrough with WASAPI-HDMI. Enabled all exept E-AC3.
Speaker setting in Win10 also to 2.0.

I have even tried using older version of Kodi but the problem is still there. Had tried to uninstall and reinstall.

What shall i do?

When i run DTS-movie directly in Windows 10 with built in movieplayer i got DTS-sound without any setup??

Sorry for my bad english! Greetings from Sweden! Big Grin
(This post was last modified: 2017-07-14 19:47 by Klojum.)
find quote
brazen1 Offline
Posting Freak
Posts: 1,187
Joined: Dec 2012
Reputation: 60
Post: #2
I use 7.1 in Windows audio and Kodi settings and not 2.0.

Windows audio properties:
1st, Configure
7.1
next
next
full range speakers = OFF (you want to send low frequencies to your subwoofer and not your any of your others or they rob low frequencies from the subwoofer even if they handle it)
finish

Double click the AVR icon:
Advanced tab - 24bit 48000Hz
Check both exclusive modes

Enhancements tab - Disable all

This concludes Windows adjustments.

In Kodi select 7.1 Wasapi passthrough and enable all formats.

This should work.

HOW TO - Kodi 2D - 3D - UHD (4k) HDR Guide Internal & External Players
Basic Server & Client Setup WOL
If I have been of help, please add to my reputation as a way of saying thanks, it's free.
find quote
nickr Offline
Team-Kodi Member
Posts: 18,874
Joined: May 2009
Reputation: 387
Location: Christchurch NZ
Post: #3
Are you connected via hdmi or spdif?

If I have helped you or increased your knowledge, click the 'thank user' button to give thanks :) (People with less than 20 posts won't see the "Thank you" button.)
find quote
Necronomic77 Offline
Junior Member
Posts: 5
Joined: Jul 2017
Reputation: 0
Post: #4
(2017-07-14 21:47)nickr Wrote:  Are you connected via hdmi or spdif?

Im connected via HDMI
find quote
Necronomic77 Offline
Junior Member
Posts: 5
Joined: Jul 2017
Reputation: 0
Post: #5
(2017-07-14 19:39)brazen1 Wrote:  I use 7.1 in Windows audio and Kodi settings and not 2.0.

Windows audio properties:
1st, Configure
7.1
next
next
full range speakers = OFF (you want to send low frequencies to your subwoofer and not your any of your others or they rob low frequencies from the subwoofer even if they handle it)
finish

Double click the AVR icon:
Advanced tab - 24bit 48000Hz
Check both exclusive modes

Enhancements tab - Disable all

This concludes Windows adjustments.

In Kodi select 7.1 Wasapi passthrough and enable all formats.

This should work.

Hi,

Thanks for your reply. Unfortunatly this didnt help me out, With this method ive got MULTICHANNEL PCM instead. Any other suggestions?
find quote
Karellen Offline
Team-Kodi Member
Posts: 2,893
Joined: Apr 2017
Reputation: 51
Post: #6
Can you provide screenshots of your audio settings page in Kodi. Post to https://imgbb.com/ and link back here. No account required.

Provide a debug log using Basic method capturing a few minutes of you playing a DTS movie.

My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Free Movies/TV Shows | Debug Log (wiki) || Artwork (wiki) | NFO_files (wiki) | Import-Export_library (wiki)
find quote
Necronomic77 Offline
Junior Member
Posts: 5
Joined: Jul 2017
Reputation: 0
Post: #7
(2017-07-16 22:53)Karellen Wrote:  Can you provide screenshots of your audio settings page in Kodi. Post to https://imgbb.com/ and link back here. No account required.

Provide a debug log using Basic method capturing a few minutes of you playing a DTS movie.

Hello!

Here are some screenshots of my settings in Kodi

https://ibb.co/iwjCLF
https://ibb.co/iTJuZa

Debug log:
https://pastebin.com/tW1KNwng
find quote
Necronomic77 Offline
Junior Member
Posts: 5
Joined: Jul 2017
Reputation: 0
Post: #8
Whoohoo!

Finally got i working!
Settings>Player Settings>Video. Sync playback to display disabled.

Case closed!
find quote
Karellen Offline
Team-Kodi Member
Posts: 2,893
Joined: Apr 2017
Reputation: 51
Post: #9
Thread marked solved.

My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Free Movies/TV Shows | Debug Log (wiki) || Artwork (wiki) | NFO_files (wiki) | Import-Export_library (wiki)
find quote