Linux - KODI crashes

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
BangForBuck Offline
Junior Member
Posts: 3
Joined: Jul 2017
Reputation: 0
Post: #1
My KODI 17.3 is always crashing in my XUBUNTU on old computer
It crashes soon after opening it, when I try to look for recommended Youtube videos
or sometimes when it shows the list of videos, it crashes when I try to open a video.

Here is CRASH LOG:
https://pastebin.com/JZqLwmSr

Here is KODI.LOG:
https://pastebin.com/JMgJynRn

The last time I installed KODI in Ubuntu Software center.
Before that I also tried other options to (un)install but it's the same problem.

I have 32 bit Chalet OS based on XUBUNTU Arch: i686
Kernel: Linux 4.4.0-75-generic
Release: Ubuntu 16.04.2 LTS (Xenial Xerus)

This are basic computer specs:

-Computer-
Processor : 2x Intel® Pentium® D CPU 3.00GHz
Memory : 2037MB
-Display-
Resolution : 1024x768 pixels
OpenGL Renderer : Mesa DRI Intel® 965Q x86/MMX/SSE2
X11 Vendor : The X.Org Foundation

Audio Adapter : HDA-Intel - HDA Intel

-SCSI Disks-
ATA WDC WD5000AAKS-0


Is there any fix for this?
If you need some other information, tell me-if you can write where to look, it would be even better
(This post was last modified: 2017-07-16 11:41 by BangForBuck.)
find quote
Klojum Offline
Team-Kodi Member
Posts: 393
Joined: Nov 2009
Reputation: 3
Location: In a house
Post: #2
You may need to update some python packages, the defaults for Ubuntu 16.04.x can mess up things.
Look here for a possible fix.

EDIT: Oh, 32bit Ubuntu? I'm not sure if Ubuntu Zesty is available in 32bit...
EDIT2: You're in luck I believe Smile
(This post was last modified: 2017-07-16 11:47 by Klojum.)
find quote
fritsch Online
Team-Kodi Developer
Posts: 17,958
Joined: Aug 2011
Reputation: 558
Location: Stuttgart*
Post: #3
Quote:10:45:56.909 T:2995222592 NOTICE: GL_RENDERER = Mesa DRI Intel® 965Q x86/MMX/SSE2
10:45:56.909 T:2995222592 NOTICE: GL_VERSION = 2.1 Mesa 12.0.6

Not supported.

"Your most vocal users are not reflective of your userbase" J.M.
"Of course, they [XP Users and people with outdated hardware] need to tell the world about the kind of hero they are, and block innovation for everyone else because their decades old OS / hardware needs to work =p" nevcairiel (ffmpeg)
No Debug Log no issue.
find quote
Klojum Offline
Team-Kodi Member
Posts: 393
Joined: Nov 2009
Reputation: 3
Location: In a house
Post: #4
Oops.
find quote
BangForBuck Offline
Junior Member
Posts: 3
Joined: Jul 2017
Reputation: 0
Post: #5
[quote='Klojum' pid='2617965' dateline='1500198245']
You may need to update some python packages, the defaults for Ubuntu 16.04.x can mess up things.
Look here for a possible fix.



Klojum thank you very much , this works for me, now it didn't crash Smile
find quote