1 client tunes fine, additional clients won't tune to different channels
#1
Attempting to migrate a 4 tv mythfrontend household to using kodi frontends with mythtv pvr client (kodi-pvr-mythtv repo) instead.

The first frontend went well. Everything works as I hoped.

I did it on a second frontend today and every appeared to be fine but when I tuned to a new channel... it actually didn't change. It pulled the guide data for the new channel in the fade away info box, populated the new channel info elsewhere on the overlay, but it didn't actually tune the stream to the new channel.

Kodi#1 was already running with Comedy Central tuned.

Kodi#2 tried to tune from Comedy Central to any other channel, but it still displayed the Comedy Central stream. Obviously, this happens with any channel.

Any ideas?

The frontends are Xubuntu 16 boxes using just the standard kodi repo/kryoton.

They ran mythfrontend prior, just fine. The myth bin's are still in place but the myth processes are dead.
Reply
#2
Just to add, just tried it in in reverse. Stopped Kodi#1 pvr stream. Could tune to different channels just fine on Kodi#2 but now Kodi#1 was stuck to whatever channel Kodi#2 was tuned to.

My setup is fairly vanilla as well, so I really doubt I'd have some configuration issue... but I'm open to having done something wrong.
Reply
#3
Hm. I think I figured it out. I remembered that my tuners were duplicated (multiplex?) from the number that was physically available. I have 2 hdhomerun prime's with 3 tuners each, for a total of 6. But, before, with default settings, it actually supported 12 tuners.

There's an option in mythtv-setup to specify the number of recordings per tuner, and that was set to 2, as expected. I bumped it down to 1 per tuner and restarted mythbackend and now this "sticky" issue isn't happening anymore.

Now, my mythfrontend's handled this.. but I don't believe there were using the mythtv api, but their own comm method. So either the api is enforcing how it should work now or, more likely, the api doesn't handle multiplex'ing with multiple concurrent streams the right way.

Either way, not a big deal since all I really need are 6 tuners anyway, but I imagine it's a bug I should file somewhere.

This is what my tuner setup (via mythweb) looks like now...

Image

...before it was doubled. There's been no change in the # physical hardware.
Reply
#4
I can confirm this, although we don't watch live here, everything is recorded from timers set via mythweb.
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
#5
FYI.. logged a bug with mythtv...

https://code.mythtv.org/trac/ticket/13078#ticket
Reply



Logout Mark Read Team Forum Stats Members Help
1 client tunes fine, additional clients won't tune to different channels0
This forum uses Lukasz Tkacz MyBB addons.