CCurlFile::FillBuffer - Failed: SSL connect error(35) when accessing repository
#1
Hi,

i installed Kodi 18 alpha ( don't blame me plz) on a Windows machine. Usually i use kodi on Libreelec.

it works quite well, but it seems that SSL connections won't work.

This is quite bad because i cannot install Addons from custom repository when they are hosted on github...

DEBUG LOG: https://paste.ubuntu.com/25147978/

relevant log part:
Code:
20:07:54.036 T:4612   DEBUG: CGUIMediaWindow::GetDirectory (addons://repository.guilouz/)
20:07:54.036 T:4612   DEBUG:   ParentPath = [addons://repos/]
20:07:54.039 T:3608   DEBUG: CAddonDatabase: SELECT repo.id FROM repo .. took 0 ms
20:07:54.039 T:3608   DEBUG: CAddonDatabase: no valid repository matching 'repository.guilouz'
20:07:54.039 T:2688   DEBUG: CRepositoryUpdateJob[repository.guilouz] checking for updates.
20:07:54.041 T:2688   DEBUG: CFileCache::Open - opening <Guilouz/repository.guilouz/master/_repo/addons.xml.md5> using cache
20:07:54.043 T:2688   DEBUG: CurlFile::Open(000002257E9AF5D0) https://raw.githubusercontent.com/Guilouz/repository.guilouz/master/_repo/addons.xml.md5
20:07:54.043 T:2688    INFO: XCURL::DllLibCurlGlobal::easy_acquire - Created session to https://raw.githubusercontent.com
20:07:54.537 T:4612   DEBUG: ------ Window Init (DialogBusy.xml) ------
20:07:55.472 T:2688   ERROR: CCurlFile::FillBuffer - Failed: SSL connect error(35)
20:07:55.472 T:2688   ERROR: CCurlFile::Open failed with code 0 for https://raw.githubusercontent.com/Guilouz/repository.guilouz/master/_repo/addons.xml.md5
20:07:55.472 T:2688   ERROR: XFILE::CFileCache::Open - failed to open source <https://raw.githubusercontent.com/Guilouz/repository.guilouz/master/_repo/addons.xml.md5>
20:07:55.472 T:2688   ERROR: CRepository: failed read 'https://raw.githubusercontent.com/Guilouz/repository.guilouz/master/_repo/addons.xml.md5'
20:07:55.505 T:2688   DEBUG: CRepositoryUpdater: done.
20:07:55.506 T:3608   DEBUG: CAddonDatabase: SELECT repo.id FROM repo .. took 1 ms
20:07:55.506 T:3608   DEBUG: CAddonDatabase: no valid repository matching 'repository.guilouz'
20:07:55.516 T:4612   DEBUG: ------ Window Init (DialogConfirm.xml) ------
20:07:55.516 T:4612    INFO: Loading skin file: DialogConfirm.xml, load type: KEEP_IN_MEMORY
20:07:55.558 T:2688   DEBUG: CAddonMgr::GetAvailableUpdates took 53 ms
20:07:55.603 T:2688   DEBUG: CAddonMgr::GetAvailableUpdates took 44 ms
20:07:55.604 T:3372   DEBUG: Thread Timer 3372 terminating
20:07:55.613 T:2688   DEBUG: CRepositoryUpdater: previous update at 22.07.2017 19:52:36, next at 23.07.2017 19:52:36
20:07:55.613 T:7008   DEBUG: Thread Timer start, auto delete: false
20:07:55.622 T:4612   DEBUG: CGUIMediaWindow::GetDirectory (addons://repos/)
20:07:55.622 T:4612   DEBUG:   ParentPath = [addons://repos/]
20:07:55.632 T:4476   DEBUG: Thread BackgroundLoader start, auto delete: false
20:07:55.644 T:4476   DEBUG: Thread BackgroundLoader 4476 terminating
20:07:56.875 T:4612   DEBUG: Keyboard: scancode: 0x1c, sym: 0x000d, unicode: 0x000d, modifier: 0x0
20:07:57.015 T:4612   DEBUG: CInputManager::OnKey: return (0xf00d) pressed, action is Select
20:07:57.015 T:4612   DEBUG: Keyboard: scancode: 0x1c, sym: 0x000d, unicode: 0x0000, modifier: 0x0
20:07:57.258 T:4612   DEBUG: ------ Window Deinit (DialogConfirm.xml) ------
20:07:57.295 T:4612   ERROR: XFILE::CDirectory::GetDirectory - Error getting addons://repository.guilouz/
20:07:57.295 T:4612   ERROR: CGUIMediaWindow::GetDirectory(addons://repository.guilouz/) failed
20:07:57.295 T:4612   DEBUG: CGUIMediaWindow::GetDirectory (addons://repos/)
20:07:57.295 T:4612   DEBUG:   ParentPath = [addons://]
20:07:57.305 T:4612   DEBUG: Keyboard: scancode: 0x1c, sym: 0x000d, unicode: 0x0000, modifier: 0x0
20:07:57.305 T:6208   DEBUG: Thread BackgroundLoader start, auto delete: false
20:07:57.310 T:6208   DEBUG: Thread BackgroundLoader 6208 terminating
20:07:57.537 T:4612   DEBUG: ------ Window Deinit (DialogBusy.xml) ------

i tried resetting my configuration and i also tried the exact same version of kodi on another windows machine. SSL connection is working fine there, so it must be something wrong with this particular windows machine.
btw: accessing the urls from the logfile in a webbrowser works fine!

any guesses?

thanks
Reply



Logout Mark Read Team Forum Stats Members Help
CCurlFile::FillBuffer - Failed: SSL connect error(35) when accessing repository0
This forum uses Lukasz Tkacz MyBB addons.