Android Not finding library files
#1
Hey so a few months ago I installed Kodi on my Android TV and everything worked smoothly up until a week ago when I went to watch a movie and got the "file is no longer available" notification. I went on to discover this was the case with all my movies and TV shows, which are all located on the same external hard drive plugged into the usb port on the TV.
When I go to add files, the hard drive is still there and I can get into all the files that way, though they are all in their "raw" file formats, as if Kodi sees the hard drive as a new unsorted drive. So last week I wiped my library and readded all the files, and again everything ran fine up until today when the same issue has appeared again.
I could wipe the library and re-add my files again but it's a bit of a pain to keep having to sort all my files into their collections and such, so I would love if anyone could provide any kind of ideas for a solution. Thanks!
Reply
#2
Normally the only reason why Kodi cannot find videos anymore, is because *something* has changed in the full filepath to your videos. Double-check the video path in the video information tab and compare it to what the current file location is.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#3
(2017-07-29, 17:38)Klojum Wrote: Normally the only reason why Kodi cannot find videos anymore, is because *something* has changed in the full filepath to your videos. Double-check the video path in the video information tab and compare it to what the current file location is.

thanks for the response. so i compared the files in my library with those on the "new" filepath and noticed one difference, the library files are stored in /storage/z843671a... etc, whereas those on the hard-drive now are stored in /storage/843671a... etc. so this z seems to be the difference.

given i haven't made any changes to the hard drive in the time this happened, do you know what might have caused this?
Reply
#4
Does the HDD partition not have a partition name? If not, Linux/Android probably creates one itself and use it for mounting. If you create one yourself, you will still need to re-scrape your video collection.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#5
(2017-07-29, 18:44)Klojum Wrote: Does the HDD partition not have a partition name? If not, Linux/Android probably creates one itself and use it for mounting. If you create one yourself, you will still need to re-scrape your video collection.
It does have a name when connected to my PC, and when I go into add source on Kodi it appears as its usual name, but in the file locations on the videos it appears as this "/storage/" instead for whatever reason.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Not finding library files00