Solved Every track an album when NAS drive as upnp
Hi everyone,

Apologies if this question has been asked before. I have researched my problem but cant find a solution to my exact issue. Basically i have several various artists compilations (GTA vice city soundtracks) on a Nas drive that i am trying to get kodi to index (as well as my other music). I have used Musicbrainz picard to get the meta tags correct. When kodi starts indexing the music it puts all the tracks in the reletive albums correctly then when it finishes all the tracks seem to be in separate albums.

Any advice would be much appreciated.
Can you give the Musicbrainz website links (or the mb release ids) for at least some of these albums so that I can see what tagging Picard has applied.

I'm the goto tagging/ Kodi music library guy. Smile
Hi, thanks for your reply, sounds like im through to the right person!

Here are some of the mb release ids

That makes it nice and clear what you have Smile

(2017-08-11, 16:39)paulwilco Wrote: When kodi starts indexing the music it puts all the tracks in the reletive albums correctly then when it finishes all the tracks seem to be in separate albums.
Not so clear on what the problem is though. I'll make myself some fake music files later and test, but just looking at what Picard picks up from Musicbrainz it all looks OK to me.

I would expect Kodi to show you separate albums for each of these releases - they have different album titles and Musicbrainz release ids. Is that what it is doing when you say "all the tracks seem to be in separate albums"? Are you expecting some kind of disc set handling for all GTA?

Or is something else going on?
So the issue is if I go to music - albums in Kodi it shows an album for each track of the compilation. So, for example, I get 17 vice city volume 2 albums each containing one track. Hope that's a bit more clear!
That is odd!! I'll try to find time later to create some test files and see if I can repeat the issue.

What folder layout do you have the music files stored in?
What format of file and tag format - mp3 v2.4 or 2.3, or FLAC etc.?
How are the music files named?

If you just add one of these albums to the library does it do the same thing?

Tried a test with that tagging (ID3 v2.4 ), and can't reproduce the issue, so I need to know the above details as something else is happening.

Could there be a mix of tag formats in the music files? That can cause some odd results, and Picard doesn't show you everything. maybe use MP3tag to have a look at the tagging, it lists the formats it finds as well as the tag values.

Oh and I guess I should know what version of Kodi and what platform you are running it on.
Im using kodi on a pc and android phone with the same results. The files are stored on a NAS drive in a shared music folder. When i first install kodi add my nas drive. When i look at the albums at that point they are all in the correct folder (one folder containing the respective tracks). when i ask kodia to import the shared music folder into the music library it splits the tracks into one track per folder (all folders with the same name). i have mp3 tag so ill try thats aswell.
The format is all MP3 and the names are as per picard names them.

Hope this makes some sense!
Is that Krypton 17.3?

Fileview shows folders, the library shows albums derived from tagging. But I can't see why Picard tagging would produce this result.

It is mp3 files, but v2.3 or v2.4 tags?
Can you give an example full path of one of the music files?

Are you sure you are looking at the albums node when you say it is one album per track, not the songs node? Sorry, it just seems very odd, so I ask the obvious. A screenshot perhaps?

Also can you upload your Music60.db file somewhere for me to fetch, and maybe an example music file. I would prefer to be sent the link privately via PM, but until you have made 10 posts you can't do that.
I have the Windows app store version, i only downloaded it about a week ago. here is a link to the database file!AhVgTS18CRO5jsRUBHxyBBClcwJWUQ

Here are some pictures of what im seeing;

This is when i select my NAS drive to index the music from!AhVgTS18CRO5jsRZKFu1ZOtf10ZzYQ

I right click on the MyCloud to get the context menu and select scan item to library!AhVgTS18CRO5jsRWDA0p6wL6kqpXHA

When it has finished adding the music to the library this is what I get under the 'Albums' selection!AhVgTS18CRO5jsRa10_PCQ_W1IHfVg

This is how MP3tag sees the album;!AhVgTS18CRO5jsRYYnGH_ulmBkti-A

And finally here is a link to my mymusic60.db


Sorry about the pictures all being links, couldnt seem to embed them in the post!

EDIT: removed db link in case you didn't want to save your musc choices with the world - DB Smile
Great stuff, thank you for putting up with me asking the obvious Smile

My immediate thought is that it something in the IDE3 v1 tags that is causing this issue. The Mp3tag screen shot shows that you have both v1 and v2.3 tags. From memory v1 didn't support album artist so it is telling Kodi that each track is a different album. I'll do some more testing and get back to you, but still unable to reproduce.

Unfortunately your db file is empty, did you send it before scan to library?

One way or another I need a closer look, at a music file, and at the db with the album per track you are seeing.

Also a screenshot from Mp3tag of the detailed tags for a track - use ALT+Twhile on a tracked to show the extended tags
Sorry about the empty database file, ive deleted and re populated the library so many times!

Ok, here is the updated database file!AhVgTS18CRO5jsRUBHxyBBClcwJWUQ

And here is a screenshot of mp3tag detailed tags!AhVgTS18CRO5jsRfL0-p_vO9LjHixw

Ive noticed since ive been playing about with mp3tag and picard that more albums have the same problem!

Thanks very much for all your help!
(2017-08-13, 11:04)paulwilco Wrote: Ive noticed since ive been playing about with mp3tag and picard that more albums have the same problem!
Yeap. In that db 50 albums are as I would expect, but the other 26 albums have split into 345 as album per track. Most weird.

I am beginning to suspect that it may not be the tagging, but the way you have connected/configured your NAS drive. The paths are all "upnp://..." and lack hash values, not something I have encountered before but it is almost as if the scanning process has treated each track as a separate source.

I know nothing about upnp and Kodi, other than someone is working on it for video, but the music library has not be included in that yet.

BTW my music is on NAS drive, and Kodi works with it just fine, so fundamentally this should be configurable just not using upnp
Spot on Dave!

It was the NAS drive config. I went through Windows Network SMB as opposed to UPnP device and its fine now.

Thank you very much for your help Dave, i really appreciate it.
Paul, can you try connecting your NAS as SMB not upnp and see if it makes a difference?

Like Dave I use NAS but connect it via SMB and my library is ok as well.
SKIN: Aeon Madnox
RIP Schimi2k, we miss you.
When I grow up I want to be a skilled skinner
Thank me by ⬇ adding to my + reputation
Change thread title to be easy to find, and marked as solved (it is nice to have a "win" sometimes).

For interest I have my NAS set up as a NFS share, not SMB, so that is another alternative. I believe it is faster. See and the wiki

Logout Mark Read Team Forum Stats Members Help
Every track an album when NAS drive as upnp0
This forum uses Lukasz Tkacz MyBB addons.