"getting mediainfo" is endless and not stopable

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
buhtz Offline
Member
Posts: 58
Joined: Jul 2017
Reputation: 0
Post: #1
tmm does automaticly (?) do a "getting mediainfo" (in German: "hole mediainfo").

This takes hours, never stops and is not stopable. On Debian GNU/Linux unstable. When I click on the red cross (in the statusbar right) it disappear from the job list but still runs because all other jobs are still wating.
The video files on a NFS-share.

Using tmm from git.

EDIT: Just to be sure I copied the complete data (all videos, folders) to my local hard drive. The behaviour is the same. So I think it doesn't matter that the videos are on a remote drive (e.g. NFS share).
EDIT2: Did a second test with the Windows (ver7 on a VM) version (2.9.4) of tmm. It takes very long (>10m), too. But it finishs. Wink So there is a difference between these two systems. Which parts of the OS does tmm use when "getting mediainfo"? Maybe there is something "wrong" with one of the related OS-components.
(This post was last modified: 2017-08-20 16:00 by buhtz.)
find quote
myron Offline
Moderator
Posts: 806
Joined: Jan 2011
Reputation: 25
Location: de_AT
Post: #2
Well, on windows we currently ship MediaInfo 0.7.93
Dunno what version you have installed on Linux... but it should process file for file, and this should be visible in logfile....


Stopping IS possible, but it stops only when current file has been processed. (we cannot kill in between)

tinyMediaManager - THE media manager of your choice :)
Wanna help translate TMM ?
[Image: project_thin_badge?format=gif]
(This post was last modified: 2017-08-21 09:07 by myron.)
find quote
buhtz Offline
Member
Posts: 58
Joined: Jul 2017
Reputation: 0
Post: #3
Now I tried again while "tail -f tmm.log". He is working step by step. And it took vey long for the ISO files. Most of the files are ISO. Could this be the reason?
find quote
myron Offline
Moderator
Posts: 806
Joined: Jan 2011
Reputation: 25
Location: de_AT
Post: #4
MediaInfo is very IO intensive.
So you should have a fast NAS/network storage, and a wired gigabit connection (with jumbo frames activated)
Wireless also slows down as hell.

What is very long for an ISO?
But yes, MI processes every file at least once.... and it takes the time it needs....

tinyMediaManager - THE media manager of your choice :)
Wanna help translate TMM ?
[Image: project_thin_badge?format=gif]
find quote
buhtz Offline
Member
Posts: 58
Joined: Jul 2017
Reputation: 0
Post: #5
I see your point. Just to be sure: mediainfo use the complete file? So if there is a 6GB ISO all 6GB are read?

I think my comparison between NFS share and local files isn't usefull here. Because my HDD is quite old and slow, too. Wink
I will try an SSD someday.
find quote
myron Offline
Moderator
Posts: 806
Joined: Jan 2011
Reputation: 25
Location: de_AT
Post: #6
No.
We open internally the ISO, and feed the files (the stream positions) directly to mediaInfo.
It reads few bytes, and decides where to jump to find the missing information (per filetype)
So, not fully reading an ISO Smile

tinyMediaManager - THE media manager of your choice :)
Wanna help translate TMM ?
[Image: project_thin_badge?format=gif]
find quote
mlaggner Offline
Moderator
Posts: 1,250
Joined: Oct 2012
Reputation: 36
Post: #7
as far as my tests have shown, mediainfo may scan the whole file if it does not find the needed information in the first place - dunno if that applies also to ISO files (that's myrons part Big Grin)

but ISOs always caused problems :/ Single files (rips) are always better to handle

tinyMediaManager - THE media manager of your choice - available for Windows, Mac OSX and Linux
Wanna help translate TMM? Join us at transifex
[Image: project_thin_badge.gif]
find quote
buhtz Offline
Member
Posts: 58
Joined: Jul 2017
Reputation: 0
Post: #8
I tried the "mediainfo" from my OS (Debian GNU/Linux unstable). But I need to know which parameters (--Info-Parameters) does TMM use when calling mediainfo with an ISO file. There are a lot of them.
find quote
myron Offline
Moderator
Posts: 806
Joined: Jan 2011
Reputation: 25
Location: de_AT
Post: #9
We do not "call" mediainfo with parameters.
We use their SDK to feed MediaInfo the stream position of a file inside the ISO, (calling the libmediainfo methods directly)
and MediaInfo decides itself, how far it reads, or where it will find the needed information to jump to...

You find the "for each file in iso" loop here:
https://github.com/tinyMediaManager/tiny...java#L1479

tinyMediaManager - THE media manager of your choice :)
Wanna help translate TMM ?
[Image: project_thin_badge?format=gif]
(This post was last modified: 2017-08-24 23:19 by myron.)
find quote
buhtz Offline
Member
Posts: 58
Joined: Jul 2017
Reputation: 0
Post: #10
(2017-08-24 23:18)myron Wrote:  You find the "for each file in iso" loop here:
https://github.com/tinyMediaManager/tiny...java#L1479
Thanks for the valuable hint! Currently I do some testing with this and will report later.
find quote
buhtz Offline
Member
Posts: 58
Joined: Jul 2017
Reputation: 0
Post: #11
Did I understand your correct that TMM use its own (in-build) mediainfo-lib? So there is no influence from the operating system's own installed mediainfo?

Let me summarize my tests:
  1. I used tmm_2.9.4-SNAPSHOT_1ea70a2. Two tests on Debian GNU/Linux unstable and one on Windows 10.
  2. On Win10 everything is fine. Quick and without errors.
  3. On Debian it is endless. The first (of two) ISO took some minutes.
  4. The second ISO use endless time. I stoped it after hours. I see no read/write activity on the local hard disc. But one of the CPU core's is on 100%.

I used different ISO files to find out if it depends on a specific ISO. But I think (but not sure) it depends only on the second ISO file in the job queue. I mean it is not a specific ISO it could be every ISO on the second positioin of the job queue.

Hint: I added some LOGGER.debug lines to better understand what is going on. I snipped lot of content of the log files. But I can provide the full logs if you need them.

Here you see three logs:
  1. The first one runs over night.
  2. The second one the same machine but with two different ISO's. Same result.
  3. The third one is from Win10. No problems here.

1

@Karellen- Multiple Logs Removed

How should I handle this now? Open an Issue? Can someone reproduce this behaviour on Debian GNU/LInux unstable?

EDIT: Now I see the same problems on the Windows 10 machine. Different files but ISOs.
(This post was last modified: 2017-09-10 22:50 by Karellen.)
find quote
judocama Offline
Senior Member
Posts: 160
Joined: Apr 2013
Reputation: 2
Post: #12
I have the same problem in osx Sierra.
Medianfo are working and don´t finish never.
(This post was last modified: 2017-09-10 17:34 by judocama.)
find quote
Karellen Online
Team-Kodi Member
Posts: 2,947
Joined: Apr 2017
Reputation: 51
Post: #13
@buhtz

I have removed your three logs as we do not allow logs in the forum. Please use a pastbin type site.

My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Free Movies/TV Shows | Debug Log (wiki) || Artwork (wiki) | NFO_files (wiki) | Import-Export_library (wiki)
find quote
chrina Offline
Junior Member
Posts: 1
Joined: Sep 2017
Reputation: 0
Post: #14
I have the same bahaviour with 2.9.4 on Win 7!
It hangs with a cpu load of 50% (one 0, the other 100%) for hours and hours (over night). can't approve, that's the second iso-file
The "hanging" is reproducable after the same count of errors!
I reseted the database and started with an empty one; started and after 49 "Mediainfo could not open STREAM - trying fallback"-errors it hangs... reproducable!
More than two iso-files...
How can I get more information under Windows about the file / directory where it stops?
Any solution for the problem?

EDIT: taking several minutes for about 4000 files with 2.8.2, but it went through
(This post was last modified: 2017-09-15 05:55 by chrina.)
find quote
judocama Offline
Senior Member
Posts: 160
Joined: Apr 2013
Reputation: 2
Post: #15
(2017-09-10 17:33)judocama Wrote:  I have the same problem in osx Sierra.
Medianfo are working and don´t finish never.


I have noticed that only stops when it finds some file dvd.iso
Anysuggestion?
find quote
Post Reply