Thread Rating:
  • 0 Vote(s) - 0 Average
"getting mediainfo" is endless and not stopable
#16
TMM 2.8.2 used MediaInfo 0.7.85
You could try downloading this version, and overwriting your local one.
Does this fix your problems?
tinyMediaManager - THE media manager of your choice :)
Wanna help translate TMM ?
Image
Reply
#17
All is correct now.

Thanks a lot.
Reply
#18
i've been having this problem on windows 10 for a while now. i think ever since i downloaded 1.9.4

thought i would just say that. i haven't had the time nor patience to figure out the cause. i have reinstalled but haven't tried downgrading yet. But if anyone is curious if this problem is on windows or if someone else on windows has this problem the answer is yes

EDIT: As i said above, this is more of a curious post, but by removing 2 .iso files from my library, the problem (and others that iw as having) seem to have disappeared. i will add to this if the problem actually did not go away
Reply
#19
I'm having this problem, also. Just downloaded and setup TMM. The "getting mediainfo" part never finishes. According to the log, it's hanging at parsing ISO files. I even tried downloading the MediaInfo file posted above and replacing the one I have but it doesn't seem to help.
Reply
#20
Hi, the same issue in my Collection.
As soon as I remove the .iso extension from the file types, everything works.
Otherwise it is a never ending procedure.

DiDi
Reply
#21
I can not see reaction from Kodi developers in that thread. The problem seems to be usual and not specific to a person or machine. Would someone open a bug report for that to get more attention from the devs.
Reply
#22
can you try with latest nightly version, and report back?
tinyMediaManager - THE media manager of your choice :)
Wanna help translate TMM ?
Image
Reply
#23
I invested a lot of time in diagnosis of that problem. And I also used a fresh from source version build by myself and so on. This tetsts are some weeks old but today/currently I don't have enough ressources here.

Do you (as a developer) say that you can not reproduce the problem?
Reply
#24
Right;
have tested several hundrets of DVD ISOs, and never got this problem.
So i'm still searching for an ISO where this happens...

But i made some improvements to our ISO parser, and could need someone testing with nightly version...
tinyMediaManager - THE media manager of your choice :)
Wanna help translate TMM ?
Image
Reply
#25
(2017-11-10, 12:14)myron Wrote: So i'm still searching for an ISO where this happens...
Try this one, I've same issue on tinyMediaManager 2.9.5 on a ReadyNAS (Linux based with mediainfo v.17.10)

<link removed>

It take about 17 minutes (evrey time that you update the library, even if you have disable .iso files)

2017-11-12 12:35:45,290 DEBUG [tmmpool-mediainfo-T1-G918] o.t.core.entities.MediaFile:1657 - start MediaInfo for /c/media/Videos/Film/tinyMM_ISO_test.iso
2017-11-12 12:52:32,838 DEBUG [trackEventThread] org.tinymediamanager.scraper.http.Url:241 - getting https://ssl.google-analytics.com/...

--
Oge
Reply
#26
Thx for link - can at least confirm, it hangs here too Smile
tinyMediaManager - THE media manager of your choice :)
Wanna help translate TMM ?
Image
Reply
#27
Can someone please test with latest nightly?
I might have found something... Smile
tinyMediaManager - THE media manager of your choice :)
Wanna help translate TMM ?
Image
Reply
#28
(2017-11-14, 19:37)myron Wrote: Can someone please test with latest nightly?
I might have found something... Smile
Yes, the version 2.9.6-SNAPSHOT - NIGHTLY fix this issue.
 Now the same file take 17 seconds instead for 17 minutes :-D
 I've also tested this version with other 8 ISO files that was affected by the same issue and I can confirm that it seem be resolved at all.
 Many Thanks!
Reply



"getting mediainfo" is endless and not stopable00