•   
  • 1
  • 4
  • 5
  • 6(current)
  • 7
  • 8
  • 15
  •   
v17 Problem with video after Windows 10 Fall Creators 2017 Update
#76
Only choice, disable Fullscreen.
Works for me, well after disabling the refresh rate, I was able to keep fullscreen.
No idea which is the better choice.

Cheers
Tom
Reply
#77
I have the same problem with my Lenovo M73 (10axs0kq00) 
https://support.lenovo.com/dk/da/solutions/pd029621

I have disable the "sync picture with screen" i playes fine. But i always leave my mediacentre on so when i turn on my tv i just got a blackscreen but when hitting "windows key" i get picture.

Very frustrating.

Eney good ideas?

Regards Daniel and thanks
Reply
#78
Last night I forced the Windows updates (there are some Micrososft KB articles like this one that talk about some games having black screens) and downloaded the latest Intel HD graphics driver (for my NUC) and latest NVIDIA driver for my other HTPC. 

Also based on comments elsewhere with gamers having this issue with some games, I went into the "Game Bar" settings in the Settings app in Windows and I disabled Game Bar.

Once applied, I seem to be able to keep the Kodi player "Adjust Display Refresh Rate" setting to "Always", and my display set to Full Screen.  The result is that the video no longer makes the screen go black.  I've only tested a few videos, but the result is encouraging so far.
Reply
#79
(2017-10-22, 16:39)mambro Wrote: Same prb here. I have intel hd 4000 graphic. 
I'll try to reinstall latest version of drivers
Reply
#80
(2017-11-18, 17:09)jzpower Wrote:
(2017-10-22, 16:39)mambro Wrote: Same prb here. I have intel hd 4000 graphic. 
I'll try to reinstall latest version of drivers

Running Kodi 17.4 on a Lenovo T430 with Intel HD 4000 graphics driver.  I Googled Intel 4000 graphics driver download. Download from intel.  Make sure your processor is listed.  Fixed my video and sound.  Before my picture was still, no sound and movie was running.  Now works great full screen.  Intel driver 153345.4653.
Reply
#81
So most of my problems are now solved with what I previously posted.  The last remaining glitch is the NVIDIA HTPC.  I have my HTPC set to stay on 24/7.   When I turn on the projector the screen is black.  I have to use the "\" key to go out of full screen and then "\" again to go back in - that will restore the screen.  I've verified the problem isn't a screen blanking in either kodi or Windows, so it is some remaining issue with the Video card and the Windows update.

It isn't a huge problem, but I'm still trying to find a reasonable workaround for that one last issue.
Reply
#82
Hmmm even if i disable the full screen i get black screen. I rolled back to 1703 and no problems.

I have a Intel 4600 grafics but i cant install from intel (somthing with lenovo modifying the driver)

This i crap!
Reply
#83
Actually you can, just don't use the Setup program, select update driver from the Device Manager, browse computer for driver software and select "Let me pick from a list of available drivers on my computer". There select "Have Disk" and choose the directory where the driver was downloaded and unzipped and the Graphics folder.
Windows will probably complain about "cannot verify...." but you are good to go.
Side effect: In the future you can update by the Setup program

Cheers
Tom
Reply
#84
sollution is to disable the setting "use full screen window" and let let Kodi run in real full screen mode. 

Image
Reply
#85
(2017-11-22, 12:38)Retrospawn Wrote: sollution is to disable the setting "use full screen window" and let let Kodi run in real full screen mode. 

Image
Just wanted to give you a big thanks, that worked for me Smile

I have an old integrated Intel HD 2000 in my MB, and there are no updated drivers for it and I was getting a black screen when playing videos. Not sure what that setting does, but at least it works now....saves me from downgrading to previous windows build.
Reply
#86
Yep, same problem here. My Windows 10 updated to 1709 yesterday, and now I can no longer change refresh rate from within Kodi (neither automatically at playback, nor manually from the settings menu). What happens is that my TV changes the refresh rate as it should, but the screen remains black. Audio runs in the background (although slightly distorted). Like the others above, if I press the windows key while this happens, I get back to the Windows screen and can click to get back into Kodi, after which everything is OK.

I run Kodi 17.6 on an AMD APU A10-6800k. Unfortunately, no new drivers have been published in two years' time.

Running in full screen windowed mode makes my Kodi crash on startup (another really nasty problem which I haven't been able to solve, which was introduced in Kodi 16 I believe. But that's off-topic here.)


So if anyone has another solution that makes Kodi switch refresh rates again like it did pre-1709, without having to resort to the windowed mode, I would be very grateful. Big Grin
Reply
#87
For testing purposes I did a clean install of today's Kodi 18 x64 nightly. Same problem.

Here is a log: https://pastebin.com/1JwN15FS
(Started playing a 24p video at 21:00:48. My tv changed refresh rate, screen got black and remained black, audio started (but choppy), afterwards I stopped the video, pressed the Windows key to see Kodi again on screen, and quit Kodi.)

Can I do anything more?



Edit: In the full screen mode it does work in Kodi 18. So that's good. But I don't think 18 is ready for daily use as of yet. Big Grin
Reply
#88
This is in Kodi 17 post-1709.

Image

I started a video, Kodi automatically changed my TV's refresh rate to 24p. The screen remained black, but after I pressed the Windows key, I got back into Kodi. My TV still reported 24p, so no additional refresh rate change. But see in the screenshot, the video is 24p as it should, but Kodi thinks it's playing at 50hz. Why?! This must be related right?

To stress it again, before the 1709 Fall Creators Update, Kodi was doing just fine, which means - to me - that it cannot be related to my Kodi settings. I really hope there's some solution, other than to change to non-windowed full screen.
Reply
#89
(2017-11-23, 12:44)willemd Wrote: To stress it again, before the 1709 Fall Creators Update, Kodi was doing just fine, which means - to me - that it cannot be related to my Kodi settings. I really hope there's some solution, other than to change to non-windowed full screen.
 The problem seems to not be Kodi, but some combination of Windows and/or video drivers since the update.  As far as I have read, the only cures involve:
-Applying all the latest Windows patches
-Updating to the latest video card patches
-Switching to Full Screen Windowed
-Disabling the refresh rate changing on content

There may yet be fixes coming from Microsoft and/or via Video Drivers, however I think the Kodi team (based on PatK's response) consider this not to be a Kodi bug.
Reply
#90
Same problem with an Intel HD 530.
Tried with updating graphics driver and disabling game bar and didn't work.
However, disabling "Adjust Display Refresh Rate" did work.
Is not definitively the best solution, because I have media with different refresh rate, but well, is a work-around.
Reply
  •   
  • 1
  • 4
  • 5
  • 6(current)
  • 7
  • 8
  • 15
  •   



Logout Mark Read Team Forum Stats Members Help
Problem with video after Windows 10 Fall Creators 2017 Update2
This forum uses Lukasz Tkacz MyBB addons.