•   
  • 1
  • 6
  • 7
  • 8(current)
  • 9
  • 10
  • 15
  •   
v17 Problem with video after Windows 10 Fall Creators 2017 Update
Updated to Windows 10 fall creator version 1709 2 days ago. Wasn't anticipating any complications but I too am experiencing this 'always adjust display refresh rate' anomaly. Most annoying. 

Hardware: using a Dell 7020 ultra small pc as htpc (HD530 intel onboard gpu), Yamaha RX-A830 amp, Samsung UA55KU7000KA 4k set.

Hoping an update resolves this soonest...
Reply
I bought almost a new pc to try to eliminate the problem,
this time have a cpu AMD dualcore (instead of intel) with a new AMD R7 250 DirectX 12 compatible and wddm 2.3 ready, Fresh install Win10x64.

Now with "latest" nightly Kodi 18 dated "20171203",
similar problems arise with "Adjust display refresh rate" on start/stop:

now the video frequency is changed correctly no black screen, but,
the video starts with blows and then stabilizes after a few seconds,
after about a minute or so the video starts jamming and gets worse and worse.
If you use fast forwarding, buffering crazy always,
the buffer does not fill up remains zero, after a few minutes it resumes but does not work properly...

if i disable "Adjust display refresh rate" everything work as expected.

I want to mention this is not a problem only old video cards but ALSO NEW ONES!
Development on Kodi Netflix add-on - Skills Python, C#, VB.NET
Reply
(2017-12-06, 10:04)stefive83 Wrote: I bought almost a new pc to try to eliminate the problem,
this time have a cpu AMD dualcore (instead of intel) with a new AMD R7 250 DirectX 12 compatible and wddm 2.3 ready, Fresh install Win10x64.

Now with "latest" nightly Kodi 18 dated "20171203",
similar problems arise with "Adjust display refresh rate" on start/stop:

now the video frequency is changed correctly no black screen, but,
the video starts with blows and then stabilizes after a few seconds,
after about a minute or so the video starts jamming and gets worse and worse.
If you use fast forwarding, buffering crazy always,
the buffer does not fill up remains zero, after a few minutes it resumes but does not work properly...

if i disable "Adjust display refresh rate" everything work as expected.

I want to mention this is not a problem only old video cards but ALSO NEW ONES!
 Oohh that must be frustrating. Still nice to have a new machine, but you'd hoped it would fix the issue.



Anyway, the fact that Kodi 18 nightlies also have the same problem is disappointing. I had hoped the git commit I linked to had fixed it, but apparently that was something else.

A while back I made a bug report with logs etc. and a link to this topic on trac, but so far there has been no relevant reply. I think the Kodi programmers team is still relatively small, with just one Windows developer (who probably has more to do. Laugh ) Hopefully someone knowledgeable will find this topic.
Reply
Not sure if this has been adressed earlier or not, but there is a fix for the issue with Nvidia and Creators Fall Update. There will be an update, but for now you can fix it with setting the "output Color Depth" from 12 to 8. Hope that helps for some of you. It sure beats setting the refresh rate down.
Reply
Two test logs:
both with upnp, mkv, VA2 enabled, Adjust display refresh rate (start/stop mode), change resolution ok, jerky video, strange behavior video buffering

First: https://pastebin.com/NBG9mkic
Second: https://pastebin.com/Zy6W9tBR
Third: https://pastebin.com/8srugFmg

@Lokeole with amd videocard puo Color Depth to 8 doesn't change anything
Development on Kodi Netflix add-on - Skills Python, C#, VB.NET
Reply
i have reinstalled the "old" windows 10 1703,
so i have discovered that, also in this windows version there is a strange behavior video buffering and jerky laggy video,
this is caused by the option "USE ACCELERATION HARDWARE DXVA2" activated.

If i turn it off all the problem to buffering and jerky laggy video gone!

I noticed that older nightly versions of Kodi 18 approximately before November DXVA2 works properly,
then i believe that this is the cause of most of the problems we encounter,
somewhere in the source code regarding DXVA2 decoding, there is a regression that creates problems to perform video.

I think that solved this all works as before, since the resolution change now works.
I hope that some programmers will read this
Development on Kodi Netflix add-on - Skills Python, C#, VB.NET
Reply
I can confirm this issue for Leia v18 builds. Sometime in October the hardware acceleration don´t work for some tv channels (mostly all ARD HD and ZDF HD channel and their sub channels WDR,NDR and so on) as i post it Here . Strange is that 1080p tv channels have no issues but 720p have.
LOG
HTPC: Windows 10 Pro 20H2, Zalman HD135, Intel i3-7100, GTX 1070, UHD ASUS BW-16D1HT
NAS: Xpenology 6.2.2, Intel i5-6600
Reply
I also notice that jerky video is less or gone when opening some kodi kodi menu.
HTPC: Windows 10 Pro 20H2, Zalman HD135, Intel i3-7100, GTX 1070, UHD ASUS BW-16D1HT
NAS: Xpenology 6.2.2, Intel i5-6600
Reply
I have solved this problem for now by using the DSPlayer branch. Not the ideal solution, and it needs quite a lot of setting up (compared to regular Kodi), but at least it works with 1709 like I want it to.

https://forum.kodi.tv/showthread.php?tid=223175
Reply
(2017-12-10, 19:36)willemd Wrote: I have solved this problem for now by using the DSPlayer branch. Not the ideal solution, and it needs quite a lot of setting up (compared to regular Kodi), but at least it works with 1709 like I want it to.

https://forum.kodi.tv/showthread.php?tid=223175
 oh for now i have solved in this way,
Reinstalled Windows10 x64 (1709) + Regular Kodi 17.6
Disabled DXVA2 + advancedsettings.xml needed to increase the buffer,
that strangely buffer is no longer working well...(i use always same wifi conncetion the signal is almost full, wifi AC at 1600Mbps)

I hope that they correct kodi 18 video player before the official release,
nowadays on windows system does not work well...
Development on Kodi Netflix add-on - Skills Python, C#, VB.NET
Reply
Wink 
(2017-12-03, 13:07)bonapartyparty Wrote:
(2017-10-23, 23:59)mambro Wrote: On my pc with Intel HD 4000 and latest drivers the only workaround is to set 'Use fullscreen window' to OFF in Kodi settings.

Go to System Settings -> Display -> Use fullscreen window  and set it OFF

Hope helps someone Wink
Thank YOU!
I usually don't clutter a forum with "thank you's" but I see no like/upvote/plus option on this forum and still wanted to thank you. This will save me lots of time tinkering with drivers/settings/etc.
Thanks again! 
 you'r welcome Wink
Reply
Whenever I turn that off on either of my Intel NUC 2820's, Kodi goes transparent. I can hear Kodi when I move the selector around, but  All I can see is the desktop.
Reply
(2017-10-21, 14:45)JrPinto Wrote: Hi, there!

I run KODI 17.4 (Windows store app version) on a Zotac ID68 with Intel HD4400 Graphics adapter.

After I updated Windows 10 to the Fall Creators 2017 Update I got black screen every time I start a video on KODI. The audio runs normal, but no video.

I have to ctrl+alt+del so Task Manager screen appears and after hit ESC everything goes normal. When i hit STOP, black screen comes again and I have to go to the same keyboard procedure to bring the video back.

One thing I noticed is that the monitor accuses the refresh rate changes when I start and stop video as everything is OK, but the KODI screen is black.

A friend of mine who has the same hardware but runs modified KODI 17.4 to run 3D MVC, said me he got the same problem, but once he runs a 3D ISO there's no black screen anymore, even with 2D, until he restarts KODI.

Does anybody knows how to solve this issue?
 Soon after installing the Windows Creator update KODI would no longer execute. Just got an error message instead. Saw a number of posts saying that deleting a profiles file in userdata folder was the solution. It wasn't. Then, my PC screen went black. After  along while the pc did boot up but KODI still failed to execute. I saw a number of posts saying that Creator update had problems with video and audio drivers. I was able to update mine but KODI still failed. Finally, I just downloaded and installed Kodi 17.6 and the problem went away.
Reply
FIRST LET ME SAY THIS IS NOT A FIX!!! IF YOU MESS UP YOUR PC BURN DOWN YOUR HOUSE OR BREAK YOUR ARMS AND LEGS ITS YOUR PROBLEM.
Okay i have had same issues as some are posting here, i was ready to "fix" my PC using something heavy.
But then i remembered something MS is infamous for make your permissions F.U.B.A.R so i checked my permission to my own user folder Big Grin and guess what they had changed to READ and EXECUTE nothing else.
That means no saving settings no changing anything so i wen't back up the folder tree to C:\Users and my checked the security tab, well i also happen to click the sharing tab and i almost chocked om my coffee,
The C:\Users folder was shared and how that came to pass i have no idea but what that means is, i had 2 entries in the security tab 1 said full control to my own folder as it should , BUT because top folder was shared i also had permission that would only allow me to "read and execute" and it does not matter if your God himself or what ever those permissions will over-rule anything else even FC.
I checked further and looked at C:\Users\kimkl\AppData and i was speechless my username was not listed at all and SYSTEM was the owner of the folder that should have been me listed as the owner.
I checked this just to be sure on my "twin pc"
Okay the "FIX" for ME!!!! was simply to enable the Administrator AC and use that i tried fixing the permission for kimkl so i do not have to use the Administrator ac but no matter what i do my PC will not let me do anything like right click or enter start menu and my HD's play hide and seek on every reboot, but after i enabled the Administrator ac and use that my PC runs smooth no troubles no screen/monitor going black changing res or fps on me.
The only downside every program i own has to be activated again, this was the solution for me.
If you follow my way and "mess up" well 1 word TOUGH!!!!
Thank you
English is not my native language; please excuse typing errors.
Grampa Simpson: Unfortunately, like all true stories, this one has a crappy ending. You have a story with an ending.
Grampa, are you sure you're okay to drive at night? Grampa: It's night?
Banned add-ons
Reply
Any new progress to report?

Windows automatically updated last night, and guess what, this shit happened. I have an Intel HD4400 onboard GPU, with the same issues everyone here is reporting. Turning off "Adjust display refresh rate" makes the video work again, but cringeworthy playback to say the least. Alt+tab, Windows key, and other combinations to "reopen" the fullscreen playback Window makes the video and audio to come back, but there seems to be some "buffer lag" or something, as the video fast forwards to "catch up"?

FFS, this calls for a #MeToo
Reply
  •   
  • 1
  • 6
  • 7
  • 8(current)
  • 9
  • 10
  • 15
  •   



Logout Mark Read Team Forum Stats Members Help
Problem with video after Windows 10 Fall Creators 2017 Update2
This forum uses Lukasz Tkacz MyBB addons.