Difficulty downloading artwork
#1
Hello myron and mlaggner,

I have been experiencing problems when trying to scrape new movies and their artwork. I don't recall the exact date it first started, but within the last 2 weeks.

When scraping the movie, the artwork fails to download. If I try enough times, I will eventually get some artwork, but most times I am just left with a partial download file in my folder. I tried scraping Big Hero 6 today and same issue. I end up going to the sites directly and downloading the artwork.

I was using v2.9.3 when I started experiencing the issue. I upgraded to v2.9.5 thinking it might be an API issue that was fixed in the latest release, but it has not.

My log is here... https://paste.ubuntu.com/25791380/ Seem to be a few errors around line 5900

Thanks
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
#2
Hello,

I was going to post exactly the same comment.
for about two weeks and it does not matter if the video is recent or not ...
I had the last version and with that of the day it's the same.

Thank you.



Image
Image
#3
the only visible problems in the log is that the SSL (HTTPS) connection has been shut down while receiving data and throwing a http 500 on the next call...
looks like some server problems with fanart.tv or their CDN
tinyMediaManager - THE media manager of your choice - available for Windows, macOS and Linux
Help us translate tinyMediaManager at Weblate | Translations at 66%
Found a bug or want to submit a feature request? Contact us at GitLab
#4
At the moment it's fully functional, moreover it's much faster and error-free.
Maybe worries with servers or they saturate at certain times ...

Thank you.
#5
I am also having the same issue. It started about a month ago and is getting worse.
I don't think it is a site issue because I can get the images individually if I edit the movie, but extra art can not be found, also if I scrape the movie or TV show with MediaElch or Media companion all images are downloaded correctly
edit: tmm logs here: https://drive.google.com/file/d/0B0rAT1Y...sp=sharing
#6
@mlaggner

Thanks for the reply. I wanted to wait until I scraped another title before responding. I scraped Spy (2015), and same issue. Downloading the artwork is quite a lengthy process now, and ends up stalling and I am left with partial download files as shown in the image by @lepoilu in Post 2.

Downloading the Banner, I need to either go to the site directly and Save As, or I can view the image in TMM then right click and select Save As, then add the artwork with a local lookup.

Posters seem most problematic.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
#7
@hasmark, your java installation (1.8.0_60) is too old to handle let's encrypt certificates (which are used by fanart.tv) - please upgrade your java!

@Karellen, sorry I do not have any answer for you.. looking at your logs again told me, that the fanart.tv servers are acting strange (many http 500 errors, which indicates a problem with their servers)
tinyMediaManager - THE media manager of your choice - available for Windows, macOS and Linux
Help us translate tinyMediaManager at Weblate | Translations at 66%
Found a bug or want to submit a feature request? Contact us at GitLab
#8
Thanks for looking again @mlaggner,

I'll let some time pass and if I am still having issues in a couple of weeks I'll let you know.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
#9
I had that issue only briefly about a week ago. Maybe it varies geographically.
Anyway when such a thing happens clicking on "show original image" button just below each thumbnail helps me. Once the original image is shown after a while, it usually works.
#10
Same problem here with the artwork. Been about a month or more and it's either very slow getting artwork or fails all together. So now i just fetch the nfo and grab the artwork manually off the sites and add them in. Seems like Fanartv servers must be swamped because i noticed sometimes if it's late at night it seems to fetch artwork a lot better but during main/prime hours between 5pm-11pm it almost never fetches consistently. I dunno. Just my tinfoil theory.
#11
(2017-10-26, 10:00)mlaggner Wrote: @hasmark, your java installation (1.8.0_60) is too old to handle let's encrypt certificates (which are used by fanart.tv) - please upgrade your java!

@Karellen, sorry I do not have any answer for you.. looking at your logs again told me, that the fanart.tv servers are acting strange (many http 500 errors, which indicates a problem with their servers)

@mlaggner
Thanks
I updated java and its now working again
#12
@tars

Yep, that is what I find so strange, If I click the "Show Original Image", it downloads and I can right click and select Save. But trying to download as part of the scrape won't work.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
#13
I'm having the same issue randomly with only some images within a set. When I go to download they all populate on the screen but when I select one and hit OK it never downloads (HTTP 500 errors or Downloading artwork failed: SSL peer shut down incorrectly)

Must be servers are full or down right now.

(Are API not required with this app like they are within Kodi now? For Fanart.tv, themoviedb and tvdb?)
#14
we provide API keys for all "free/public" services.
with tmm v3 you will be able to use your own API key for the services

sorry, I did not have time to analyze the problem, but fanart.tv got some connection problems the last months and a HTTP 500 indicates something we cannot fix at tmm Big Grin
tinyMediaManager - THE media manager of your choice - available for Windows, macOS and Linux
Help us translate tinyMediaManager at Weblate | Translations at 66%
Found a bug or want to submit a feature request? Contact us at GitLab
#15
Yeah, it seems to be working a lot better tonight than it was last night.



Logout Mark Read Team Forum Stats Members Help
Difficulty downloading artwork0
This forum uses Lukasz Tkacz MyBB addons.