•   
  • 1
  • 4
  • 5
  • 6(current)
  • 7
  • 8
  • 12
  •   
Release Gamestarter: Retrogaming add-ons for LibreELEC (RPi/Generic).
#76
(2017-07-14, 10:21)Wintermute0110 Wrote:
(2017-07-13, 12:18)bite_your_idols Wrote: Last AEL version has change some xml tags so previous categories xml gives error Sad you can go back to AEL 0.9.5, you can edit your xml manually (i did it and it is quite boring)...
...
1) After upgrading to 0.9.6 go to AEL settings >> IO tab and execute "Check/Update all databases ...". If you don't do this AEL will crash constantly.
...

When I make changes in the database from version to version, the "Check/Update all databases ..." command should take care of upgrading everything. It is not necessary to update the database JSON files manually! Also, it is safe to execute "Check/Update all databases ..." more than once.


nice to confirm that!! I spent like 15 minutes "finding and replacing" in sublime text my lists when updated to 0.9.6 LOL ... just for not reading your release notes... Image

thanks for your work with AEL addon!!
Reply
#77
thanks for your help. in fact the "chec/update all databases" was all i needed to make it run again the way it did before.
Reply
#78
I'm having difficulty trying to use my usb keyboard as input for ScummVM games. The core/games load fine, I can use the mouse in-game, and retroarch hotkeys on the keyboard respond; I just can't enter any text within the games. I read on some other forums that the keyboard issue should be resolved in the latest core build, but if I manually update the ScummVM core from within RA, then I have another issue where loading ScummVM from within ES causes Kodi to reload. Oddly, it seems as if ES and Kodi are running simultaneously, since after a few button presses in kodi, it suddenly jumps into a random emulated game starting...So I re-installed cores from within the gamestarter options menu in kodi, and it loads into ScummVM properly again, but still no keyboard in-game.

ScummVM 1.9.0
Gamestarter 2.9.0
RA 1.6.3
LibreElec 8.0.2
RPi3

Thanks!

UPDATE: still having secondary issue where after exiting ScummVM, then exiting RA, Kodi reloads - but after several button presses jumps back into an random emulation within RA. It seems very apparent that kodi and ES are running simultaneously after a ScummVM exit. For some reason, exiting RA after using ScummVM causes a kodi reload, whereas exiting RA from other cores returns to ES with a kodi reload.

UPDATE2: (WORKAROUND) figured out how to use the DOSBOX core and edited the es_systems.cfg file to point to my PC games folder and specified exe/bat/com files as ROMs. Seems to be much more compatible with all dos games and keyboard works in-game. Took a bit of work: had to set the hotkey enabler so that I could type in-game without constantly hitting hotkeys https://retropie.org.uk/forum/topic/541/...keyboard/2. Now my PC/DOS games show up and can be launched directly from ES! Perfect!
Reply
#79
yes, Scummvm core is a little buggy one and it does some weird behaviour when exiting it if you launch it from EmulationStation. You can try using directly RetroArch addon instead and see what happens, but if you solve the situation switching to dosbox core and you can play games you want in that way it is ok, you don't need to waste more time making them work. Maybe, if dosbox works ok I should include it in default emulationstation systems config file.
Reply
#80
Just posting to comment that I am switching Gamestarter Addon into a Kodi Repository for LIbreELEC (RPi & Generic) that includes individual addons for RetroArch & EmulationStation. So everybody can install just what he/she needs and it is easy to backup, uninstall, restore and update.

At this moment there are only available the following addons:
- RetroArch
- EmulationStation
- Advanced Emulator Launcher
- DraStic RPi emulator.

If you want to give a try just download and install this repo zip: https://goo.gl/m36qLT

Feedback is welcome!
Reply
#81
Heyho,

first of all i want to thank you for your work (even if I can't test it Sad ). I freshly installed LIBREelec (8.0.2 I think) one hour ago, switched from OPENelec.I configured my PVR, all works fine, and the reason of the OS switch to LIBRE is your gamestarter. I installed and configured all like you wrote it on GIThub tutorial, activated the advanced launcher and so on. I just wanted to test one N 64 game, hope that this isnt the problem. When i click on the game, it just spend me a black screen and a few seconds later the normal KODI bootscreen. I also tried it with EmulationStation, but not with an tutorial, just with a bit knowledge (dont kill me for my english please Big Grin )

So, can u maybe tell me what I'm doing wrong ? I think it cant be a corrupt libreelec version, its freshly downloaded and installed, all other things working fine. I went through the tutorial and did all step by step. Am I to stupid ?

Would be nice if i hear from you Smile

Greetings mate
Reply
#82
(2017-08-06, 23:46)suppentrulli Wrote: Heyho,

first of all i want to thank you for your work (even if I can't test it Sad ). I freshly installed LIBREelec (8.0.2 I think) one hour ago, switched from OPENelec.I configured my PVR, all works fine, and the reason of the OS switch to LIBRE is your gamestarter. I installed and configured all like you wrote it on GIThub tutorial, activated the advanced launcher and so on. I just wanted to test one N 64 game, hope that this isnt the problem. When i click on the game, it just spend me a black screen and a few seconds later the normal KODI bootscreen. I also tried it with EmulationStation, but not with an tutorial, just with a bit knowledge (dont kill me for my english please Big Grin )

So, can u maybe tell me what I'm doing wrong ? I think it cant be a corrupt libreelec version, its freshly downloaded and installed, all other things working fine. I went through the tutorial and did all step by step. Am I to stupid ?

Would be nice if i hear from you Smile

Greetings mate

ok, let's check out.
First we need logs, they are located in /storage/.kodi/temp/
Also, the easiest test run is just to launch retroarch using gamestarter addon. It should work, if it doesn't we found where the problem is but we still need the log file. If retroarch works then you can try to load N64 core, then your rom. If N64 doesn't work you can try another core to test if the problem is with N64 core.
Reply
#83
Retro Arch isnt launching, kicks me same way back like the Advanced Launcher.

Here is my log: http://sprunge.us/cABc

Thanks for help in advance
Reply
#84
(2017-08-07, 16:29)suppentrulli Wrote: Retro Arch isnt launching, kicks me same way back like the Advanced Launcher.

Here is my log: http://sprunge.us/cABc

Thanks for help in advance

I need gamestarter.log or retroarch.log in the same folder, not kodi.log

did you download & install the right addon version for your device/OS?
Reply
#85
Oh okay, sorry ! I installed this one here: script.gamestarter-v2.9-GEN

Here is the gamestarter.log http://sprunge.us/acOJ
when i want the retroarch.log (via SSH) Putty tells me: cat: can't open '/storage/.kodi/temp/retroarch.log': No such file or directory

Greetings
Reply
#86
(2017-08-07, 16:46)suppentrulli Wrote: Oh okay, sorry ! I installed this one here: script.gamestarter-v2.9-GEN

Here is the gamestarter.log http://sprunge.us/acOJ
when i want the retroarch.log (via SSH) Putty tells me: cat: can't open '/storage/.kodi/temp/retroarch.log': No such file or directory

Greetings

You installed addon for generic libreelec, so what device are you using? Is that ok?

Try ls in logs directory, i can not remember if correct name is gamestarter_retroarch.log ... Sorry I am on holidays...
Reply
#87
iam using rasperry pi 3 with libreelec 8.0.2

Im new to kodi, so sorry for that. I get a file when i use gamestarter_retroarch.log (http://sprunge.us/VYHP) when i open it with editor i see this: https://pastebin.com/mDYPA3uQ

edit: oh man, im so stupid. i think i tried the wrong version, im gonna uninstall and try this one: script.gamestarter-v2.9-LE8.zip (dam, my mistake)

hope its enough when i uninstall it and install this new one, or do i have to delete some config files ? hope it works then !

edit2: its wroking PERFECTLY now. sorry that i annoyed u with this crap, my mistake. Wish you a good holiday, and thanks for your work and help !!

edit3: okay, games loading (psx and n64). but on some games the "pictures" are not displayed correctly. (i tested pokemon stadium on n64 and hogs of war on PSX). i saw it just on the main menu, ingame is all fine. i only got a problem with my controller. i wanna play all games on every emulator with my xbox 360 controller. X A B Y works fine, but on PSX game i cant use the analog stick. i already downloaded the psx controller addon, doenst helped. and on the startup from psx game, i got an message that i should install a bios system, i looked in the folder and there is already a bios. many questions now, but i think im on a good way Wink would be nice if somebody has some answers !

edit4: dam, many edits, hope u still reading Big Grin for PSX i fixed the gfx errors, i paste a bios inside the bios folder. analog stick is fixed to, from options in the gamestarter controller config.
Reply
#88
RA updated to 1.6.4 and PPSSPP standalone emulator addon for RPi included in repo.

enjoy!
Reply
#89
Hi, is it possible to use my existing RetroArch or does this install a new copy?
Reply
#90
(2017-08-09, 14:47)ameic Wrote: Hi, is it possible to use my existing RetroArch or does this install a new copy?

If you are using Gamestarter addon you can go to addon settings and update retroarch.
If you are using Retroarch addon from Gamestarter repo you can update addon from kodi.
If you are using gamestarter addon and you want to switch to retroarch addon from my repo you better copy your customized config files (retroarch.cfg...), install addon and them paste them in new directory.
Reply
  •   
  • 1
  • 4
  • 5
  • 6(current)
  • 7
  • 8
  • 12
  •   



Logout Mark Read Team Forum Stats Members Help
Gamestarter: Retrogaming add-ons for LibreELEC (RPi/Generic).1
This forum uses Lukasz Tkacz MyBB addons.