MediaPortal not skipping commercials in Kodi 18
#16
Anyone know the status on this or have it working? I know you said you'd post here when the new version was out but that was a few months ago so just checking in before I spend too much more time trying to figure it out...
Reply
#17
(2018-06-23, 17:48)syxrail Wrote: Anyone know the status on this or have it working? I know you said you'd post here when the new version was out but that was a few months ago so just checking in before I spend too much more time trying to figure it out...
  It seems margro has not yet gotten a change to update the MediaPortal PVR. We are still waiting for him to get a change to do that. He said he will post here when he has fixed it.
Reply
#18
Just checking in here - I'm looking to install Leia but don't want to if the commercial skipping won't work through mediaportal. Is there any change?
Reply
#19
Any word on when this update will be available?  The wifey says this is a game changer for her so I can't update until the comskip is working.
Reply
#20
The v17 behaviour should work again in v18.
When an .edl file is stored next to the recording and the TSReader is used for playback (no RTSP playback) Kodi should pick-up the .edl.

The MediaPortal PVR addon itself does not support commercial skipping, so when using ffmpeg mode (RTSP streams) or TSReader in RTSP mode, commercial skipping is not available.
Developer of the MediaPortal PVR addon and retired developer of the Argus-TV PVR-addon.
http://www.scintilla.utwente.nl/~marcelg/xbmc
Reply
#21
(2018-09-12, 05:10)deepskydiver Wrote: Just checking in here - I'm looking to install Leia but don't want to if the commercial skipping won't work through mediaportal. Is there any change?
In April 2018 they changed some internals of the EDL system. Part of the change was to change how they test if the request came from a PVR client if it did then it didn't try to find the EDL files from a local or network path but ask the PVR client to supply the file in the EPG tag. 

I've submitted a pull request to fix this.  So MediaPortal using TStreams to a network share should work again (like it did on the early 18 Pre April 6th alphas) 

https://github.com/xbmc/xbmc/pull/15110
Reply
#22
Good catch! Thanks for the fix.
Developer of the MediaPortal PVR addon and retired developer of the Argus-TV PVR-addon.
http://www.scintilla.utwente.nl/~marcelg/xbmc
Reply



Logout Mark Read Team Forum Stats Members Help
MediaPortal not skipping commercials in Kodi 180
This forum uses Lukasz Tkacz MyBB addons.