Solved play music in 7.1 how to???
#1
i have windows 10 ryzen 1700x, RX580 8gb. AVR 7.1, LG OLED.  how do i get kodi to play on all 7.1 speaker. when i play music it only plays on two front speakers.. in the setting system>audio> stereo upmix i have enable. what else do i need to enable or disable. Huh?
Reply
#2
How do you have your equipment connected together?

Assuming the Win 10 PC is connected direct to AVR then all you need to do is select WASAPI as the Audio output device, set Number of channels to 7.1 and enable Stereo Upmix.
Reply
#3
(2017-12-02, 12:50)jjd-uk Wrote: How do you have your equipment connected together?

Assuming the Win 10 PC is connected direct to AVR then all you need to do is select WASAPI as the Audio output device, set Number of channels to 7.1 and enable Stereo Upmix.
 thats exactly the way i have settings.   music still only plays front speakers
Reply
#4
To receive meaningful assistance you will need to provide a full debug log.

The instructions are here... debug log (wiki)

If you are using the Basic Method, then ensure the following is applied...
1.Enable debugging in Settings>System Settings>Logging,
2.Restart Kodi
3.Replicate the problem.

If you are using the Advanced Method ensure you have correctly created and applied the advancedsettings.xml file.

In both instances, you should see the word DEBUG throughout the log.

Note: Full logs only. No partial or redacted logs
Do NOT post your logs directly into the forum. Always use a paste site like pastebin.com. Post the link to your pasted log in the forum
Reply
#5
(2017-12-02, 19:57)jjd-uk Wrote: To receive meaningful assistance you will need to provide a full debug log.

The instructions are here... debug log (wiki)

If you are using the Basic Method, then ensure the following is applied...
1.Enable debugging in Settings>System Settings>Logging,
2.Restart Kodi
3.Replicate the problem.

If you are using the Advanced Method ensure you have correctly created and applied the advancedsettings.xml file.

In both instances, you should see the word DEBUG throughout the log.

Note: Full logs only. No partial or redacted logs
Do NOT post your logs directly into the forum. Always use a paste site like pastebin.com. Post the link to your pasted log in the forum

logfile
https://paste.ubuntu.com/26099303
Reply
#6
This is by design.  Stereo music will play in stereo.  Which means using your front two speakers.

To get it to fake the audio into ALL speakers you need to go into the setttings \ system \ audio.

Make sure the "Output Configuration" is set to 7.1 to match your actual speaker layout

And then tick "Stereo UpMix" to fill audio to all speakers.  This will copy the audio from the front pair to also play from the rear pair.
Reply
#7
(2017-12-03, 02:26)xbmcwood Wrote:
(2017-12-02, 19:57)jjd-uk Wrote: To receive meaningful assistance you will need to provide a full debug log.

The instructions are here... debug log (wiki)

If you are using the Basic Method, then ensure the following is applied...
1.Enable debugging in Settings>System Settings>Logging,
2.Restart Kodi
3.Replicate the problem.

If you are using the Advanced Method ensure you have correctly created and applied the advancedsettings.xml file.

In both instances, you should see the word DEBUG throughout the log.

Note: Full logs only. No partial or redacted logs
Do NOT post your logs directly into the forum. Always use a paste site like pastebin.com. Post the link to your pasted log in the forum

logfile
https://paste.ubuntu.com/26099303

Could you get a screenshot of your audio settings, copy it to a free hosting site such as imgur and post the link here.
Reply
#8
(2017-12-03, 14:57)jjd-uk Wrote:
(2017-12-03, 02:26)xbmcwood Wrote:
(2017-12-02, 19:57)jjd-uk Wrote: To receive meaningful assistance you will need to provide a full debug log.

The instructions are here... debug log (wiki)

If you are using the Basic Method, then ensure the following is applied...
1.Enable debugging in Settings>System Settings>Logging,
2.Restart Kodi
3.Replicate the problem.

If you are using the Advanced Method ensure you have correctly created and applied the advancedsettings.xml file.

In both instances, you should see the word DEBUG throughout the log.

Note: Full logs only. No partial or redacted logs
Do NOT post your logs directly into the forum. Always use a paste site like pastebin.com. Post the link to your pasted log in the forum

logfile
https://paste.ubuntu.com/26099303     

Could you get a screenshot of your audio settings, copy it to a free hosting site such as imgur and post the link here.     
 here are screen shots.. hope this helps.. ever since i been using kodi 17.. its been playing only front 2 speakers
Image
Image
Image
Reply
#9
Why don't you set your amp to Multi-Channel Stereo?
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#10
(2017-12-04, 05:30)Karellen Wrote: Why don't you set your amp to Multi-Channel Stereo?
 my AVR is fine.. when i use my phone to play music. it using all 7.1
Reply
#11
Try changing "Output configuration" to "Best Match".
Reply
#12
Looking at the log it seems your audio device is only reporting 2 channels capability, what does the Windows audio Playback devices -> Support Formats show on your system

Image
Reply
#13
(2017-12-04, 18:43)jjd-uk Wrote: Looking at the log it seems your audio device is only reporting 2 channels capability, what does the Windows audio Playback devices -> Support Formats show on your system

Image
 i will check windows 10 setting . when i get home from work.. but if this was to to 2 speakers. then when i watch movies should only play 2 speakers.. right??
because when i watch movies sound is fine i get atmos, DTS-HD just fine.
Reply
#14
(2017-12-04, 14:52)jjd-uk Wrote: Try changing "Output configuration" to "Best Match".
 yeah i try best match. and fix.. no change.
Reply
#15
You do realise that your AVR is literally playing things back correctly?  Music is generally 2.0 stereo.

What happens if you use VLC?  I assume that also plays music to 2.0 speakers, and films to 7.1?

When you play music - what do you see on the AVR display?

When you play films - what do you see on the AVR display?


The interesting bit is you say when you attach your phone to the AVR that it copies the audio to all speakers.  I assume that you are connecting the phone on a different input on the AVR.  Check the settings on the AVR to compare those two inputs.  It sounds like the one you connect that phone to is already set to copy front to back (or Multi-channel Stereo) whereas the HDMI inputs are playing the audio as it was meant to be.
Reply



Logout Mark Read Team Forum Stats Members Help
play music in 7.1 how to???0
This forum uses Lukasz Tkacz MyBB addons.