TMDB scrapes movies with wrong Provider-ID
#1
Ever since the problems with the API-Keys of TMDB and fanart.tv occured, it's been a hassle to retrieve artwork with artwork downloader.

After this got solved with personal API-keys, it worked for a while, but lately the artwork-downloader stopped working again. 
This is not obvious at first glance, because the TMDB-scraper downloads poster and fanart, so most skins and views look good unless one digs a bit deeper.

For every Aeon-User who uses the logo-view (like I do), the artwork-downloading-failure is pretty obvious though, because the TMDB-scraper does not download logos from fanart.tv, so all new titles won't have a logo.

It took quite a long time until it became clear, that this not a problem of the artwork-downloader, nor of the Aeon-Skin or of fanart.tv 

The reason was (and probably still is) that the TMDB-scraper writes wrong IDs for the scraped titles into kodi's database. The artwork-downloader uses these IDs to search for artwork - and fails with "wrong provider ID". 

I "solved" the problem now by switching to Universal-Movie-Scraper, setting everything to TMDB and german, cleaning and re-building the database. On 3 PCs, 3 HTPCs, 2 Tablets and 2 smartphones. Quite a hassle.

Before anyone asks:
I have not saved a logfile. I'm just happy that I have a working solution to this problem, and hopefully this post helps others who can't get the artwork-downloader to work. I have not the patience to re-create the problem.
Before that I have tried a lot of things, including a complete wipe of Kodi incl. database with a fresh re-install from scratch. Which means all the latest versions of all addons and TMDB scraping all infos anew. 
Maybe there's some way to get TMDB-scraper to work correctly at this time, but if so, it's not possible, obvious or doable for a common user.
Reply



Logout Mark Read Team Forum Stats Members Help
TMDB scrapes movies with wrong Provider-ID0
This forum uses Lukasz Tkacz MyBB addons.