GUI setting option to disable inloop deblocking (skip loop filter) for H.264 content?
#31
Hi everyone, I am not really familiar with file setting changes. I am experiencing the same problems everyone has posted regarding the m4v using H.264, and it it clear that the solution is to change advancedsettings.xml, parameter from 48 to <skiploopfilter>8<skiploopfilter/>

Could anyone make a detailed explanation on how to do that, starting on how to access that xml file? Is this using Terminal app?

On the other hand does ti really make the difference to store movies on m4v H.264 better that avi XviD for example?

Thank you for your help.
Reply
#32
I posted this yesterday, but I was able to get around it without using TERMIAL and difficult command lines which I am not used to. If this might help anyone else, I used FileZilla which is an FTP GUI really easy to use.

Nevertheless, even when I changed the advancesettings.xml from 48 to 8, I have problems watching m4v (H.264) videos. Quality is poor, since they look as if they were streming in slow motion and sound is weird.

Is that parametre the only one to check?
Reply
#33
lorenvazquez Wrote:I posted this yesterday, but I was able to get around it without using TERMIAL and difficult command lines which I am not used to. If this might help anyone else, I used FileZilla which is an FTP GUI really easy to use.

Nevertheless, even when I changed the advancesettings.xml from 48 to 8, I have problems watching m4v (H.264) videos. Quality is poor, since they look as if they were streming in slow motion and sound is weird.

Is that parametre the only one to check?

did you quit and relaunch xbmc. advancesettings.xml is read at launch of xbmc.
Reply
#34
Yes I did quit and relaunch, but I still have the problems. I have also increased the cache values and tried to turn off the library (which is one of my favourite features in XBMC) since this was also posted on other threads, but still not working properly.

My m4v (H.264) videos play great on my iMac under XBMC and they do too under ATV standard software, but I can not get around to play them correctly on the ATV's XBMC. AVI files work fine, so I can not understand.

Could someone tell me if there is really a big difference to store my movies on avi (XviD) vs. m4v (H-264)? If not, is there any preset on handbrake that is good to make avi files to be streamed over SMB to my XBMC on my APTV?

Thanks for your advice.
Loren
Reply
#35
So, you are happy with the way your Xvid files look on your ATV? If rip to h.264 with the same resolution but a lower bitrate than the DivX setting you use, they will probably play fine and look just as good.

On the other hand, the only disadvantage of Xvid is slightly large file sizes to get the same picture quality.
Reply
#36
Lightbulb 
I've turned on the skiploopfilter to get 1080i H264 files to playback smoothly without audio lag. This is a great measure so I can at least play the 1080i content until some form of GPU assisted H264 playback is supported.

I'd really like if it XBMC didn't use the skiploopfilter for 720p files though, because the CPU can keep up with those just fine.

Is there anyway that the skiploopfilter can be altered to be used, perhaps through configuration, based on the resolution of the content that is being played?

I'm already using the fastest AMD X2 dual core CPU I can get my hands on (6000+, 3.0 Ghz).
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
GUI setting option to disable inloop deblocking (skip loop filter) for H.264 content?00
This forum uses Lukasz Tkacz MyBB addons.