v18 PVR deinterlacing issue
#61
Ive been experiencing this with livetv via tvheadend on my vero 4k+, just started to try the osmc beta builds.

livetv is generally ok but it occasionally the picture 'tears' briefly like it isnt deinterlacing, then goes back to normal. Hope this is sorted before the final release
Reply
#62
No you don't. Please open your own thread. Your Video Decoder and deinterlacing / etc. is 100% different on AMLogic.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#63
Hi All,

Just to inform you that I have further requested help to solve this issue on github.

Hope it will be fixed for the Kodi 18 release.
Light IMDb Ratings Update - Keep updated the IMDb ratings for your movies and TV shows.
In case you found useful my work, feel free to offer me a cappuccino!
Reply
#64
Also having the same issue on a HTPC with a Core-i5 4670K, NVIDIA (EVGA) GTX950, Windows 10 (x64) using a HDHomeRun Connect (HDHR4) and Kodi 18.0, RC4.

Also affects SD channels (576i) as well as HD channels (1080i) for me.

EDIT: Of the 3x systems I have Kodi installed on (1x Desktop PC, 1x Laptop, and 1x HTPC). Only the HTPC suffers from this issue. It is connected to the TV (See my sig for model) via a Pulse-Eight USB-CEC adapter to the amplifier, then to the TV itself. The other two systems have dedicated "monitor" devices. The amplifier is set to "pass through" the video signal without modification or upscaling.

EDIT2: Just had a look at "Player Settings" on the HTPC. I had the option "Sync Playback to Display" set to "On Start/Stop" and "Render Method" set to "Auto". Since I use portable installs on all my systems that run Kodi, with the configuration of the desktop manually copied to the other two, the settings on all systems match (with some minor variations for specific add-ons like backup paths for XBMC Backup, etc.) Either way, by turning off "Sync Playback to Display" completely, and changing the render method from "Auto" to DXVA explicitly (The setting "Allow DXVA2 Hardware Acceleration" was already enabled), this cured the issue for me.

I still get a 1/4 second black screen / flicker at the same time into the stream as the de-interlacing was stopping previously, but once the picture returns, it is being handled properly (i.e: de-interlaced as expected). The same is true of both SD (576i) and HD (1080i) terrestrial Freeview TV broadcasts.
Image
DT: Intel Core-i7 - 4770K / Nvidia GTX-980 Ti | HTPC: Intel Core-i5 - 4670K / Nvidia GTX-950 | LT: Asus N550JK-CM531H
TV: Sony KDL-40EX524 | AVR: Onkyo TX-NR515 | SPK: 2x Pioneer CS-7070 / 3x Tannoy F1 Custom
Reply
#65
(2019-01-08, 21:17)gibxxi Wrote: Also having the same issue on a HTPC with a Core-i5 4670K, NVIDIA (EVGA) GTX950, Windows 10 (x64) using a HDHomeRun Connect (HDHR4) and Kodi 18.0, RC4.

Also affects SD channels (576i) as well as HD channels (1080i) for me.

EDIT: Of the 3x systems I have Kodi installed on (1x Desktop PC, 1x Laptop, and 1x HTPC). Only the HTPC suffers from this issue. It is connected to the TV (See my sig for model) via a Pulse-Eight USB-CEC adapter to the amplifier, then to the TV itself. The other two systems have dedicated "monitor" devices. The amplifier is set to "pass through" the video signal without modification or upscaling.
Thanks for reporting your experience as well. Can you also confirm that if you switch the deinterlacing method to Off and again to DVXA, the deinterlacing starts to work properly until you change to another TV channel?
Light IMDb Ratings Update - Keep updated the IMDb ratings for your movies and TV shows.
In case you found useful my work, feel free to offer me a cappuccino!
Reply
#66
For me, no. Doing so in the "Video Options Menu" (via playback OSD) had no effect whatsoever.

I would however still say that there is evidently some form of issue present. Setting the "Render Method" to "Auto" should automatically select the correct option based on installed hardware / driver support. So in my case it *should* be automatically be selecting DXVA render mode if Kodi is able to determine it's supported and available. Given I have to explicitly select DXVA mode to get it to work, this is evidently not the case at this point.
Image
DT: Intel Core-i7 - 4770K / Nvidia GTX-980 Ti | HTPC: Intel Core-i5 - 4670K / Nvidia GTX-950 | LT: Asus N550JK-CM531H
TV: Sony KDL-40EX524 | AVR: Onkyo TX-NR515 | SPK: 2x Pioneer CS-7070 / 3x Tannoy F1 Custom
Reply
#67
(2019-01-08, 22:59)gibxxi Wrote: For me, no. Doing so in the "Video Options Menu" (via playback OSD) had no effect whatsoever.

I would however still say that there is evidently some form of issue present. Setting the "Render Method" to "Auto" should automatically select the correct option based on installed hardware / driver support. So in my case it *should* be automatically be selecting DXVA render mode if Kodi is able to determine it's supported and available. Given I have to explicitly select DXVA mode to get it to work, this is evidently not the case at this point.
Looking at the EDIT2 in your previous post it seems that something is working at the end...I have to try also this way on my setup (besides the one I have described you before, i.e. acting on DXVA deinterlacing option through the OSD menu). Does your approach maintain the correct de-interlacing even when you change the TV channel?

I think that the only way to solve the issue is to debug the code while playing some TV content...but it is something that goes beyond my knowledge and that only a developer can do...Unfortunately it seems that there is a lack of resources to focus also on this issue. I just can not just imagine the first official release of Kodi 18 with this problem...taking into acocunt tha Kodi 17 is working without any deinterlacing issues. Can you also confirm this on your setup?
Light IMDb Ratings Update - Keep updated the IMDb ratings for your movies and TV shows.
In case you found useful my work, feel free to offer me a cappuccino!
Reply
#68
I only tried a channel switch once during my testing, in order to test a HD channel, after the initial test of an SD channel. It worked as expected. I get the 5 second "mini-flicker" and a short microsecond of lost audio, but the channel gets processed (de-interlaced) correctly after that point. I would point out though, in case it has a bearing, that I live in the UK and we use DVB-T (SD) / T2 (HD) reception, which differs from ATSC used in North America.
Image
DT: Intel Core-i7 - 4770K / Nvidia GTX-980 Ti | HTPC: Intel Core-i5 - 4670K / Nvidia GTX-950 | LT: Asus N550JK-CM531H
TV: Sony KDL-40EX524 | AVR: Onkyo TX-NR515 | SPK: 2x Pioneer CS-7070 / 3x Tannoy F1 Custom
Reply
#69
Are they seriously releasing an final build with issue? I am hoping not...
Reply
#70
We exactly do this. Lack of developers and your fix did not yet arrive.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#71
Hi,

I can confirm that "Render Method" set to "Auto" in Settings/Player/Videos settings is the key to getting the DXVA to be invoked correctly on my Beta 5 Win 10 AMD HTPC setup.

Adjust display refresh rate "On start / stop"
Sync playback to display - Off
Allow hardware acceleration - DXVA2 - On


Neeto
Reply
#72
Unfortunately I have to report back that the issue is still present on my HTPC setup. I have tried both settings from @gibxxi and @neeto33 posts but without success...
Light IMDb Ratings Update - Keep updated the IMDb ratings for your movies and TV shows.
In case you found useful my work, feel free to offer me a cappuccino!
Reply
 
Thread Rating:
  • 2 Vote(s) - 1 Average



Logout Mark Read Team Forum Stats Members Help
PVR deinterlacing issue12