Blank video in most movies with 17.6
#1
I tried 17.x (again, having tried an earlier build before with similar results), but I get a completely blank screen on most videos; can't seem to find out why.  Audio (and everything else) seems to work fine, and a few videos do work, but most don't.  These all work fine and were added with 16.1 in Ubuntu.  The platform is an Asus Z97I+ with Core I5-4570S @GHz x 4 , which has an Intel video (Haswell Desktop).  Ubuntu is 14.04 LTS.

Any suggestions what to look for?  What could be wrong?
Reply
#2
To receive meaningful assistance you will need to provide a full debug log.

The instructions are here... debug log (wiki)

If you are using the Basic Method, then ensure the following is applied...
1.Enable debugging in Settings>System Settings>Logging,
2.Restart Kodi
3.Replicate the problem.

If you are using the Advanced Method ensure you have correctly created and applied the advancedsettings.xml file.

In both instances, you should see the word DEBUG throughout the log.

Note: Full logs only. No partial or redacted logs
Do NOT post your logs directly into the forum. Always use a paste site like pastebin.com. Post the link to your pasted log in the forum
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki) || Artwork (wiki) | NFO_files (wiki) | Import-Export_library (wiki) | HOW-TO:Create_Music_Library (wiki) | Movie_Sets (wiki)
Reply
#3
Log at https://paste.ubuntu.com/26375183/

This was playing the first few seconds of the intro of a video that displays a blank screen.  Audio was fine, just no video.  If it would help, I could find a video that works correctly and post that as well.
-- Thanks!
Reply
#4
Actually, I'll go ahead and also post a log from one that does work:  https://paste.ubuntu.com/26375262/

In this one, the first few moments appear to be fine; I didn't go all the way in, but it looked OK, as opposed to the one above.  I don't know what differences are in these files.  They're both .mkv files, but I don't know the encoding source.

As you can see, there were a slew of VAAPI erors in the failed one posted above, but I have no idea what that indicates. 

This one that worked had no such errors.
Reply
#5
You are using far too old libva / i965-va-drivers - nearly 4 years old.

Update these drivers from wsnipex vaapi ppa:
Code:
sudo apt-add-repository ppa:wsnipex/vaapi
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install i965-va-driver

Then restart kodi and post the Debug Log again if this continues to happen.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#6
That seems to do the trick!  Many thanks:  I would never have worked that out!
Reply
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Blank video in most movies with 17.651