Solved H265 video crashes KODI
#1
I'm running Kodi 17.5 bare bones (i.e. no addons) under Win10 on an Intel NUC 5i5ryk. All videos play fine except for those encoded with H265. It doesn't matter if they are 8 or 10 bit H265, but Kodi crashes right away when I start the video. (I've heard some have problems only with resume, but I can't even start the video). The thing is I know I had this working before but I'm not sure if H265 worked with 17.5. It certainly worked under 17.3 which is the first build I used. I don't believe the 5i5 has hardware decoding for H265, but it still should be able to play the video.

The Render method was "Auto detect". I tried changing it to "DXVA" as well as "Software", but the result is the same for both those choices. (All videos play except H265). Note that DXVA2 is not shown as an option.
I also changed the "Enable HQ scalers" setting from 20% to 100%, also with no effect.

I normally have used a resolution of 1920x1080p although tried much lower resolutions, but H265 still crashes. I also have tried both display modes (windowed or full screen) as well as both settings for the "Use fullscreen window" slider, but all these settings didn't change the problem.

Does anyone have any suggestions of what to try next to allow the playback of H265 videos?

Thanks
~Paul
Reply
#2
First I would try running a clean copy of Kodi. You could use the Portable Mode mode for this.
There's no need to import the entire library again, you could start the movie from file mode or copy the original databases to the portable version.
If the problem is gone, the culprit is somewhere in the settings or the addons you were using in your main installation.

A log file might also help to find the cause.
I think all righthtinking people in this country are sick and tired of being told that ordinary, decent people are fed up in this country with being sick and tired.
Reply
#3
Thanks for alerting me to the portable mode. I was not aware of that. Wow, that is so much nicer. I have long been frustrated that I can't just start over again with a clean slate (that is, without a very long and tedious sequence of steps that is impossible to remember). Now I can just rename the kodi folder and install it again like I never installed it in the first place. This is so much nicer it is hard to imagine why portable mode is not the default.

That said, even with a clean install (this time with Kodi 17.6) with the default settings/skin and no addons, when I select an H265 video with the file mode, Kodi crashes within a few seconds, never even getting to the point of displaying an image. Again I tried switching from AutoDetect to Software decoding, but still no joy. This seems pretty weird considering this has worked for me before. Does this point to a windows driver issue then? If so, what drivers should I try to reinstall? Yes, I suppose I could make a log file ... although I don't remember how and I'm not particularly looking forward to relearning that ... or is that my only option at this point?

Thanks.
~Paul
Reply
#4
Your 5th generation NUC is not compatible with hardware acceleration of h265 under windows, you will need to turn it off if you want to play those files.

A log file needs to be posted to confirm.

See https://forum.kodi.tv/showthread.php?tid=325689

@afedchin is there any way to stop the crashes and inform the user? This seems to be a common problem coming up on the forums.
Reply
#5
(2018-02-05, 12:52)docwra Wrote: Your 5th generation NUC is not compatible with hardware acceleration of h265 under windows, you will need to turn it off if you want to play those files.
 Thanks docwra for your reply, although it appears that you didn't read my entire message. In both my original question and my follow-on post I mentioned selecting "Software rendering" which turns off hardware acceleration. So I have already followed your advice and the problem persists. Plus I know that this particular CPU is strong enough to decode H265 in software because while running an earlier build (17.3) I played many dozens of H265 encoded videos and I didn't notice any skipping or other artifacts. With my recent testing I have tried many H265 files (mostly 8bit) including some I have watched successfully before but now kodi always crashes a few seconds after the video is selected.

~Paul
Reply
#6
Yet after being asked twice you still have provided no log.... Sad
Reply
#7
In my previous post I posted a link to the kodiwiki, where it's explained how to enable logfiles. If you check the link and use the easy method to enable logfiles.
Logfiles aren't the holy grail but without it we're just guessing what the problem might be. It could be a bug in Kodi but since you're at 17.6 most obvious errors have probably been ironed out. The most likely cause outside Kodi is the display driver IMHO but it might be something entirely different, like a problem with Visual C++, hardware going bad etc.
I think all righthtinking people in this country are sick and tired of being told that ordinary, decent people are fed up in this country with being sick and tired.
Reply
#8
(2018-02-05, 21:30)docwra Wrote: Yet after being asked twice you still have provided no log.... Sad
 Well, yes - I was getting to that, and in fact since then I have created the log file. Still I thought your reply was useless telling me to disable hardware acceleration, which I already said I had done ... yet oddly enough you were on the right track. Just before I was about to post my log file I discovered the problem. I had claimed that I had disabled hardware acceleration by selecting "Software rendering", but it turns out that this did not disable hardware acceleration as I expected.

The confusion was that when I looked at the Settings/Player, Videos page at the bottom of the page I saw:

Processing
-------------
Render method ..........................................................
- Enable HQ scalers for scaling above ..........................

And that was it! Except I didn't notice the skinny scroll bar indicating that there was one additional setting because the scroll bar doesn't fully appear until you hover over it. The last setting in the processing settings page (that I didn't see) is "Allow hardware acceleration - DXVA2", which of course was checked!! Once I unchecked this setting, Kodi started working fine again.

While looking for a solution to this problem I found an awful lot of users struggling with this issue. I wonder how many of them were also lulled into the same trap that I was by the subtle indication of the scrollbar.

Thanks to all of you who replied to my question.
~Paul
Reply
#9
Thread marked solved.
Got a Kodi problem? Provide a full Debug log (wiki) | Usefull pages: First time user (wiki) | Troubleshooting (wiki) | Free content (wiki) | Forum rules (wiki) | VPN policy (wiki)
Reply
#10
Great! glad its fixed Smile

The reason we ask for a log is it should show straight away if hardware acceleration is enabled or not.

The bug is due to this Intel Driver bug on windows, and is well known sadly without them fixing it, its hard for the Kodi devs to do anything about as it only seems to effect older Intel setups.

https://communities.intel.com/thread/116386?start=15
Reply



Logout Mark Read Team Forum Stats Members Help
H265 video crashes KODI0
This forum uses Lukasz Tkacz MyBB addons.