•   
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 18
  •   
Release CBC TV (Canadian Broadcasting Corporation)
#46
(2018-03-18, 20:11)frozen Wrote: Micahg, given all the effort you have obviously put into this I hesitate to add to the list of people who want you do do more, but here goes.
If we could access paid content, particularly CBC News Network, this thing would be perfect (not that it's not excellent now, don't get me wrong). If this is doable it would be MUCH appreciated!
Thanks!
I can add cbcnn but I have no account myself. If someone has access and wants it added they can PM me to coordinate.
Reply
#47
I would be happy to support this project but the forum won't let me PM you (maybe I'm too new??). If you want to PM me maybe that will work
Reply
#48
(2018-03-20, 20:36)frozen Wrote: I would be happy to support this project but the forum won't let me PM you (maybe I'm too new??). If you want to PM me maybe that will work
Ok, I pm'd you. Let me know if you got it.
Reply
#49
Greetings,

CBC TV has been working great on my RPi3/LibreELEC (Kodi v17.6 - Krypton) system (Thanks to micahg)!

I have a question/observation for anyone using the "Shows" section/feature of this amazing Add-on (and here it is):

Once an episode is played/completed, I do NOT see the "watched" indicator (check mark) appear and was wondering if this function/feature is not available/enabled, or just not appearing on my specific system?

Thanks.
Reply
#50
(2018-03-21, 18:38)mentat Wrote: Greetings,

CBC TV has been working great on my RPi3/LibreELEC (Kodi v17.6 - Krypton) system (Thanks to micahg)!

I have a question/observation for anyone using the "Shows" section/feature of this amazing Add-on (and here it is):

Once an episode is played/completed, I do NOT see the "watched" indicator (check mark) appear and was wondering if this function/feature is not available/enabled, or just not appearing on my specific system?

Thanks.
Yaeh, I want that too... No idea how to do it but I should look into it.
Reply
#51
For some unknown reason, the CBC 4.0.0 addon on some of my computers no longer retrieves the Shows listings.

The following debug log is from RetroPie 4.3 running on a Raspberry Pi 2 with Kodi 17.3.

https://paste.ubuntu.com/p/Bd4X8xnb3S/

After starting Kodi, I navigated to Videos -> Video Add-ons.
Then I chose Canadian Broadcasting Corp (CBC).
Next I chose Shows.
At this point a dialog with the title Retrieving show list briefly popped up, then it disappeared and another dialog briefly popped up and indicated "Canadian Broadcasting Corp (CBC) error.  Check the log for more information."

If you would like any additional debugging information then please let me know.
Reply
#52
Same here can't open shows, live still works OK. Running on Android.
Reply
#53
Hi @kodaksmith and @rocko -- I just tried to reproduce here at home and I can't -- Anne and 21 Thunder are both working.

The logs help, but can you guys follow the link on the first post and turn up the (debug + network -- don't worry about ffmpeg for this one) and reproduce the problem?

Thanks very much.
Reply
#54
This is a vexing problem.  On some of my systems the Canadian Broadcasting Corporation (CBC) add-on continues to work.  On others it has ceased to function properly.  Even stranger is that I have two different MicroSD cards that each have OpenElec 8.2.4 with Kodi 17.3.  These were both originally created from the same disk image, yet for some unknown reason one continues to work and the other has stopped working for this CBC add-on.

Following is the debug log from my RetroPie 4.3 running on a Raspberry Pi 2 with Kodi 17.3.  I used the same test steps as listed in my first report of this issue.

https://paste.ubuntu.com/p/QbDJ2sWgfd/

For the above debug log I enabled:
  • Enable debug logging
  • Enable component-specific logging
  • Under Specify component-specific logging I enabled:
    • libcURL library (HTTP(S), DAV)
    • JSON-RPC requests
    • Webserver component

Note that in the Confluence skin the enabled/disabled status is not obvious.  For the above three components the text color changed to yellow from white to indicated that I had toggled the values.  I also tried reverting to the Estuary skin but the same problem with the CBC add-on persists.

If there is anything else I can provide then please don't hesitate to ask.
Reply
#55
I've got great news.  To fix the issue with the Shows not loading, all I had to do was delete the userdata cache for the CBC add-on.  To do this I removed the kodi/userdata/addon_data/plugin.video.cbc directory which contained authorization and cookies files.

On my RetroPie 4.3 Raspberry Pi image this cache was stored at:

/opt/retropie/configs/ports/kodi/userdata/addon_data/plugin.video.cbc/

On OpenELEC and LibreELEC this same directory should be stored at:

/storage/.kodi/userdata/addon_data/plugin.video.cbc/

My initial hunch was that perhaps there was a corrupt cache somewhere, so I did a search  with:

find / -name "*cbc*" -print 2>/dev/null

One of the entries returned from the above command was in the above mentioned directory.

@micahg do you think there would be a way to enhance the add-on to either detect or prevent this issue?
Reply
#56
Following are links to copies of the two files under the kodi/userdata/addon_data/plugin.video.cbc/ directory from my RetroPie 4.3 Raspberry Pi 2 with Kodi 17.3 that would not display the list of Shows using the Canadian Broadcast Corporation (CBC) video add-on.

authorization
cookies

These have been provided in case they are helpful to troubleshoot the issue.
Reply
#57
Hi,

I believe that information is sufficiently helpful -- I'm not entirely sure why but it looks like the authorisation token is not stored properly. I've got a fixes branch open if anyone wants to try it on a system that is still failing: https://github.com/micahg/plugin.video.c.../fixes.zip.

If I see a 401 (authorisation failed) for show list or stream retrieval I just reauthorize... if that fails, then we'll dig a little deeper.
Reply
#58
Thank you @micahg for the sample fix.  I tested this on my Raspberry Pi 3 with OpenElec 8.2.4 and Kodi 17.3.  The add-on displays version 4.0.1 so it appears that I installed the zipped fixes file correctly.  Unfortunately the issue remains -- the list of Shows will not load.

Further the timestamps of the files in the kodi/userdata/addon_data/plugin.video.cbc directory did not change at all.

Note that if I delete the kodi/userdata/addon_data/plugin.video.cbc directory then the Shows do load properly.

I have kept a copy of the contents of the kodi/userdata/addon_data/plugin.video.cbc directory so that I can test any future fixes you might create.
Reply
#59
(2018-03-28, 17:48)kodaksmith Wrote: Thank you @micahg for the sample fix.  I tested this on my Raspberry Pi 3 with OpenElec 8.2.4 and Kodi 17.3.  The add-on displays version 4.0.1 so it appears that I installed the zipped fixes file correctly.  Unfortunately the issue remains -- the list of Shows will not load.

Further the timestamps of the files in the kodi/userdata/addon_data/plugin.video.cbc directory did not change at all.

Note that if I delete the kodi/userdata/addon_data/plugin.video.cbc directory then the Shows do load properly.

I have kept a copy of the contents of the kodi/userdata/addon_data/plugin.video.cbc directory so that I can test any future fixes you might create.
Can you post the logs for the updated machine?
Reply
#60
Micahg, I tried to post a debug log, first time. I don't know if I did it rite.

http://ix.io/zuS
Reply
  •   
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 18
  •   
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
CBC TV (Canadian Broadcasting Corporation)51