Not playing music from Logitech Media Server
#1
I have installed KODI over OSMC on a Raspberry3, and for movies, videos and tv it works well. But my FLAC files will not play. I have my files on a Debian server, and I see the files, but they won't play. I've also tried to copy a few files to a memory stick and plug it in. Same shit. Is there something I have to do to be able to play FLAC? 

I have searched the forum, but not found anything.
Reply
#2
Btw: I tested with mp3, same result. The player won't play them.
Reply
#3
To receive meaningful assistance you will need to provide a full debug log.

The instructions are here... debug log (wiki)

If you are using the Basic Method, then ensure the following is applied...
1.Enable debugging in Settings>System Settings>Logging,
2.Restart Kodi
3.Replicate the problem.

If you are using the Advanced Method ensure you have correctly created and applied the advancedsettings.xml file.

In both instances, you should see the word DEBUG throughout the log.

Note: Full logs only. No partial or redacted logs
Do NOT post your logs directly into the forum. Always use a paste site like pastebin.com. Post the link to your pasted log in the forum
Reply
#4
Nothing special should be required hence asking for the log.
Reply
#5
Log file: http://ix.io/GXv
Reply
#6
I don't see you trying to play any flac file
Reply
#7
I actually did
Reply
#8
Can you try again. Can you first play another format, say an mp3, then play a FLAC file.

Post again, and tell us the name of the songs you played.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#9
Sorry: actually I played a mp3.file, still some of the files on my server are mp3s. But still, the same result. I gave it another try, this time first a flac, then a mp3: http://ix.io/GYj
Reply
#10
flac file: 04 Bo Kaspers Orkester - Amerika.flac
mp3 file: Bob Marley - One Love-People Get Ready - One Love- The Very Best of Bob Marley (1 of 2).mp3
Reply
#11
How are you playing those files. I see some references to the skin helper widget but can't see you actually starting to play something. Can you at first try to play one through the music library or the file manager, and play a single song, not an entire album?
Do you get any kind of feedback when it is playing (or not playing)? If the audio settings are wrong the song might actually be playing without you hearing anything.
I think all righthtinking people in this country are sick and tired of being told that ordinary, decent people are fed up in this country with being sick and tired.
Reply
#12
I made a "screenshot" of the error message I get when I try to play music: https://www.dropbox.com/s/ia9xthgbk8jmjp...r.jpg?dl=0 Hope this is of any help. I use the standard audio player: PAPlayer. As I said in my first post: this error only applies when I try to play music. But the title of my thread is a bit misleading, the error applies to both flac and mp3 files. Probably other audio formats too.
Reply
#13
In the background of your screenshot I see Logitech Media Server, what exactly is this? how are your music sources added?
Reply
#14
Ah think I've got it now as I see attempts to play from UPnP, so you're using Logitech Media Server as a UPnP server and have most likely added this as a UPnP source in Kodi. In that case you're not directly accessing the files, what is being presented to Kodi is a UPnP playlist and it seems that is not understood by Kodi. Why have you not created a NFS or SMB share on your server then used that to share your music files to Kodi?
Reply
#15
I have tried different methods, both samba & nfs: same result. I've also tried to copy files to a usb memory stick, plug it into the pi3, and play the files from it. Same result there. I've also tried to copy files to the msd-card, but with no success. It simply won't play audio files.
Reply



Logout Mark Read Team Forum Stats Members Help
Not playing music from Logitech Media Server0
This forum uses Lukasz Tkacz MyBB addons.