Solved Android TV - smb network not visible
#1
Hallo

i have been searching this and other forums on this topic for two past weeks but found no working solutions.

Facts:
KODI on Android TV(latest/updated on PHILIPS TV)
KODI 17.6
2 pc's nad a Synology NAS in local network

Problem: 
KODI on Android TV does not see the network shares thru SMB, regardless of the origin- PC nor NAS. It does see the server as a DLNA/UPNP or NFC. 
Installs on both pc's have no problem with recognizing the SMB shares in the local network. I even installed KODI on my Phone (Android) to check whether the issue can be coused by the Android TV soft but i found that the same behavior occurs in my phone.

Seems to be a issue of KODI on android platforms.

i would be greatfull for a working solution.
Reply
#2
(2018-03-19, 21:02)bosz Wrote: Hallo

i have been searching this and other forums on this topic for two past weeks but found no working solutions.

Facts:
KODI on Android TV(latest/updated on PHILIPS TV)
KODI 17.6
2 pc's nad a Synology NAS in local network

Problem: 
KODI on Android TV does not see the network shares thru SMB, regardless of the origin- PC nor NAS. It does see the server as a DLNA/UPNP or NFC. 
Installs on both pc's have no problem with recognizing the SMB shares in the local network. I even installed KODI on my Phone (Android) to check whether the issue can be coused by the Android TV soft but i found that the same behavior occurs in my phone.

Seems to be a issue of KODI on android platforms.

i would be greatfull for a working solution.
I am not sure if this will help. I assume you want to add videos as a source. 

Add videos, then browse, add a network location, smb  in server name put the ip address, then user name & password, give it a name. Then click ok.

Then go back to add  videos, select the network location you have just created, browse to the folders you want to add, etc
Reply
#3
(2018-03-19, 21:02)bosz Wrote: Seems to be a issue of KODI on android platforms.
No, Kodi as a whole moved on to SMBv2 instead of SMBv1. SMBv2 no longer supports browsing and requires a user account on your Samba server with a password. SMBv1 is [finally] no longer considered safe. I'm sure you can remember the worldwide WannaCry outbreak last year?
Got a Kodi problem? Provide a full Debug log (wiki) | Usefull pages: First time user (wiki) | Troubleshooting (wiki) | Free content (wiki) | Forum rules (wiki) | VPN policy (wiki)
Reply
#4
(2018-03-19, 21:12)bubblegum57 Wrote: ....Add videos, then browse, add a network location, smb  in server name put the ip address, then user name & password, give it a name. Then click ok.
.... 
 Thanks but it seems i have to further explain what is it my post about -  this is not a problem with adding a new source - its an issue with SMB shares visibility on KODI on android devices. SMB shows no locations in networks dialog, even thru IP adresses ergo i cannot connect to smb shares 
Quote:No, Kodi as a whole moved on to SMBv2 instead of SMBv1. SMBv2 no longer supports browsing and requires a user account on your Samba server with a password. SMBv1 is [finally] no longer considered safe. I'm sure you can remember the worldwide WannaCry outbreak last year?
I have tested this with SMB1 as well as SMB2. Both ways the outcome was indetical - no visible sources. And like i said earlier evertyhings works perfectly on Kodi on windows PC. The issue with the SMB occurs on android devices. 

Does anyone have a clue how to overcome this?
Reply
#5
I think in the Libreelec config addon, you can change max & min smb versions. Not sure if that will help. Not sure if you have tried that
Reply
#6
to clear this up
-> This is what i see on android devices (same WIFI network)
Image
-> and kodi on windows
Image
Reply
#7
and what happens if you go to Add network location in previous step? The only way I can add smb share on Android TV is to do it manually. And that works just fine.
Reply
#8
(2018-03-20, 09:57)kinggo Wrote: and what happens if you go to Add network location in previous step? The only way I can add smb share on Android TV is to do it manually. And that works just fine.
 Gave it a go - i added the server location login and pass manualy and ended up with "Connection timed out" message.  This is clearly in issue with either KODI on android or and android  it self having problems with smb protocol handling
Reply
#9
I don't think so. I have 4 different android devices and all of them can access my smb share. Did you try any filemanager on your TV. I also use ES file explorer and it can access smb just fine.
Reply
#10
Hi,

I don't know if my experiences will help but when I moved onto an Android box (after using PC based Kodi for years) I had terrible trouble adding sources through SMB.  I have a PC with a number of HDD's attached.  The first problem was the one the OP is experiencing & from memory the solution was a huge amount of trial & error but it revolved around Workgroups & Homegroups.  Homegroups did not work for me at all & counter intuitively it needed to be sourced from a Workgroup.

My second problem was that whatever I did I couldn't connect to various HDD's.  After much toing & froing I worked out that any HDD attached to a USB hub (powered or not) will not work with Android (in my setup anyway).

I don't know if that helps in anyway?

MartinK
Reply
#11
....and all my drives are attached via USB. And to a router with NAS, so not even proper OS.
Reply
#12
(2018-03-20, 11:51)kinggo Wrote: I don't think so. I have 4 different android devices and all of them can access my smb share. Did you try any filemanager on your TV. I also use ES file explorer and it can access smb just fine.
 Have tried it yesterday with solid explorer. Both SMB2 and FTP(but only thru IP) work perfectly. It appears that this is in fact a KODI issue.
Reply
#13
(2018-03-21, 19:08)bosz Wrote:
(2018-03-20, 11:51)kinggo Wrote: I don't think so. I have 4 different android devices and all of them can access my smb share. Did you try any filemanager on your TV. I also use ES file explorer and it can access smb just fine.
 Have tried it yesterday with solid explorer. Both SMB2 and FTP(but only thru IP) work perfectly. It appears that this is in fact a KODI issue. 
Many many people (myself included) have SMB working fine with Kodi on Android, I think we're gonna need a debug log of you trying to connect to a share so we can see if we can ascertain what's happening.
Reply
#14
(2018-03-20, 19:45)kinggo Wrote: ....and all my drives are attached via USB. And to a router with NAS, so not even proper OS.
      I spent a few days on this issue and tried every "Fix" I found.  Since you're on a NAS you can eliminate one like Enable SMB1 in Windows and alter the registry settings.  Just to be clear when you manually enter a source as smb://servername/sharename you get the time out message. Did it prompt for a password?  There's two android side fixes I found.  One was to uninstall v17 then side load version 16 which worked with SMB then upgrade to v17.  The other one was the location of the smb.conf file.  The suggestion was to copy smb.conf to the files folder just above the Kodi folder.   I have no idea what actually fixed it but it did start working and I could actually browse to the Windows shares...then it stopped working via browsing but still works by manually entering the smb path.
Mythbuntu doesn't need viruses - we have Sudo
Reply
#15
I really can't remember. I never used v16 on my TV but I also didn't have any issues when I was doing it on v17. I know that it's somehow confusing when you see it for the first time but once you figure out what info goes where it just works.
Browsing never worked but I wouldn't use it anyway. All my devices are on static IP and configured manually.
Reply



Logout Mark Read Team Forum Stats Members Help
Android TV - smb network not visible0
This forum uses Lukasz Tkacz MyBB addons.