Solved Android TV - smb network not visible
#16
OK, so I did it agin but on tablet since I can take ss there.....
Image
click browse and...
Image
than add network location
Image
select protocol, so SMB in our case and enter server IP and username and password. That's all, OK to get....
Image
so, our new network location is here. Selecting that....
Image
gives me my server with my two drives
Image

Now, those steps after adding server will probably look different on different servers but this is how it works for me since I first tried kodi on my TV. And this was done again on tablet. And I can do it on the phone. And any other file manager works with that server so I don't think that there is an issue with kodi or android. If there are than it's more likely on windows side (and I don't have win machine to try that) or that people symply don't know how to do it.
Choosing Windows network (SMB) in step 2 won't work. Also, trying to browse in step 3 doesn't work, it gives me some kind of error (but not the time out).
Reply
#17
(2018-03-19, 21:32)Klojum Wrote: No, Kodi as a whole moved on to SMBv2 instead of SMBv1. SMBv2 no longer supports browsing and requires a user account on your Samba server with a password. 
SMBv2/v3 doesn't actually work on Krypton on Android, so not exactly "as a whole" until Leia releases.
Reply
#18
I ran into this issue again today after swapping out my 10 year old Win 10 machine for a new ryzen 3 2200g system. After the PC was all set up my Android boxes got the time out message. First tried activating SMB v1 server then reboot server and Android. Still not working. Went into network settings and added netbios over tcpip then rebooted everything again. Go into video sources and edit source then bingo..prompt for user and password. Life is good again...mama happy she can get back to her 3,000 episodes of Star Trek.
Mythbuntu doesn't need viruses - we have Sudo
Reply
#19
(2018-03-22, 11:35)Mnementh Wrote: Many many people (myself included) have SMB working fine with Kodi on Android, I think we're gonna need a debug log of you trying to connect to a share so we can see if we can ascertain what's happening. 
 I have not tried the IP adress with SMB, but even if it would work this work around does not suit me - a cannot assign a static ip on my router - but ill keep You posted once i test it

as for the debug log - how to generate it ?
Reply
#20
(2018-03-28, 21:14)bosz Wrote:  I have not tried the IP adress with SMB, but even if it would work this work around does not suit me - a cannot assign a static ip on my router - but ill keep You posted once i test it

as for the debug log - how to generate it ? 
 I'm pretty sure it already has a static one. Maybe you can't cahnge it but that is something you don't need to do anyway.
Reply
#21
(2018-03-28, 21:14)bosz Wrote:
(2018-03-22, 11:35)Mnementh Wrote: Many many people (myself included) have SMB working fine with Kodi on Android, I think we're gonna need a debug log of you trying to connect to a share so we can see if we can ascertain what's happening. 
 I have not tried the IP adress with SMB, but even if it would work this work around does not suit me - a cannot assign a static ip on my router - but ill keep You posted once i test it

as for the debug log - how to generate it ? 
Perhaps I have missed something, but assign a static ip address in the kodi configuration, not the router
Reply
#22
(2018-03-28, 22:28)kinggo Wrote:   I'm pretty sure it already has a static one. Maybe you can't change it but that is something you don't need to do anyway. 
 No, the IP was generated upon the order of loging onto the network. I managed to set a static IP on the NAS it self. Tried to switch to  the FTP protocol to get things up and running. I was able to log into the NAS this way but unfortunately KODI refused to successfully download a movie from a source, but this in not important - I GOT IT(smb) TO WORK PROPERLY on my last attempt - literally i was about to quit the sh*t, and have a beer
Since i'm seeing i'm not the only one with this "issue" according to the entries in Google i wanna lay it out for everyone to see .

The solution to SMB shares not being visible on android devices is:
1) You need to enter your servers name (or IP, does not matter) by hand, as KINGGO mentioned in this thread
2)BE SURE TO ENTER THE LOCATION OF THE FOLDER YOU WANT TO ACCESS AS SHOWN BELOW - yes this is that simple ;]
Image

I'm not aware of the rules and regulations of this board, but i'd mark this tread as solved, a pin it some place to others to learn from. It's up to the mods.

I'd like to thank Everyone that tried to help and wish all of You a happy easter.
Reply
#23
Thread marked solved.
|Banned add-ons (wiki)|Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

Kodi Blog Posts
Reply
#24
(2018-03-31, 21:55)bosz Wrote:
(2018-03-28, 22:28)kinggo Wrote:   I'm pretty sure it already has a static one. Maybe you can't change it but that is something you don't need to do anyway. 
 No, the IP was generated upon the order of loging onto the network. 
ermmmmm......... OK, your adress on internet is not fixed (otherwise we could run our servers very easily and providers don't want that) but the adress of your router for all in house devices is fixed. I mean, how would you even configure your router and network if it would change the adress all the time? How would you configere NAS or KODI or...... to acces something that is always on a different adress?
Reply
#25
Hi I have the same issue,
I'm able to connect to network HDD through kodi with windows, but on Android Tv is impossible.

I put the same address:

Image from Windows
Image

ANdroid
Image

Any idea¿
Reply
#26
Kodi for Android stable builds only support SMB v1, which means up to date (build 1803+) Windows 10 shares will no longer work, even if you attempt to reinstate SMB v1. The only workaround is to upgrade to the Kodi v18a (Leia) builds, which support SMB 2/3.

Don't waste any more of your time on this.
Reply
#27
(2018-05-30, 10:02)FireInMyHole Wrote: Kodi for Android stable builds only support SMB v1, which means up to date (build 1803+) Windows 10 shares will no longer work, even if you attempt to reinstate SMB v1. The only workaround is to upgrade to the Kodi v18a (Leia) builds, which support SMB 2/3.

Don't waste any more of your time on this.
 and how I can upgrade to Leia?
Reply
#28
Use the Android Installer add-on from the official repo (in the program addons section).

You can use that to update to the current Leia nightly - note that at the moment it's still in an alpha state so there are no officially stable builds (although it's been working just fine for a while now).

To use it you will have to enable installation from 3rd party sources in your Android settings (not in Kodi, in the main Android set-up) if applicable.
|Banned add-ons (wiki)|Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

Kodi Blog Posts
Reply
#29
(2018-05-30, 10:02)FireInMyHole Wrote: Kodi for Android stable builds only support SMB v1, which means up to date (build 1803+) Windows 10 shares will no longer work, even if you attempt to reinstate SMB v1. The only workaround is to upgrade to the Kodi v18a (Leia) builds, which support SMB 2/3.
SMBv1 just isn't installed by default. You can install SMBv1 on Windows 10 under "turn windows features  on and off" and Kodi v17 works fine. On my ShieldTV it does, anyway.

I had a lot of problems with Leia last time I tried it, which admittedly was like 6 months ago. So back-up your installation before upgrading.
Reply
#30
I've written instructions here:

https://forum.kodi.tv/showthread.php?tid...pid2741932
Reply



Logout Mark Read Team Forum Stats Members Help
Android TV - smb network not visible0
This forum uses Lukasz Tkacz MyBB addons.