Solved Android TV - smb network not visible
#31
(2018-03-31, 21:55)bosz Wrote:
(2018-03-28, 22:28)kinggo Wrote:   I'm pretty sure it already has a static one. Maybe you can't change it but that is something you don't need to do anyway. 
 No, the IP was generated upon the order of loging onto the network. I managed to set a static IP on the NAS it self. Tried to switch to  the FTP protocol to get things up and running. I was able to log into the NAS this way but unfortunately KODI refused to successfully download a movie from a source, but this in not important - I GOT IT(smb) TO WORK PROPERLY on my last attempt - literally i was about to quit the sh*t, and have a beer
Since i'm seeing i'm not the only one with this "issue" according to the entries in Google i wanna lay it out for everyone to see .

The solution to SMB shares not being visible on android devices is:
1) You need to enter your servers name (or IP, does not matter) by hand, as KINGGO mentioned in this thread
2)BE SURE TO ENTER THE LOCATION OF THE FOLDER YOU WANT TO ACCESS AS SHOWN BELOW - yes this is that simple ;]
Image

I'm not aware of the rules and regulations of this board, but i'd mark this tread as solved, a pin it some place to others to learn from. It's up to the mods.

I'd like to thank Everyone that tried to help and wish all of You a happy easter. 
Hello bosz,
The image under 2)BE SURE...AS SHOWN BELOW... is not accessible. Could you explain how you entered the folder location? I have tried SMB://xxx.xxx.xxx.xxx/Folder with no luck.
Thanks
Reply
#32
(2018-03-19, 21:02)bosz Wrote: Hallo

i have been searching this and other forums on this topic for two past weeks but found no working solutions.

Facts:
KODI on Android TV(latest/updated on PHILIPS TV)
KODI 17.6
2 pc's nad a Synology NAS in local network

Problem: 
KODI on Android TV does not see the network shares thru SMB, regardless of the origin- PC nor NAS. It does see the server as a DLNA/UPNP or NFC. 
Installs on both pc's have no problem with recognizing the SMB shares in the local network. I even installed KODI on my Phone (Android) to check whether the issue can be coused by the Android TV soft but i found that the same behavior occurs in my phone.

Seems to be a issue of KODI on android platforms.

i would be greatfull for a working solution.

Turns out that the solution isnt all that tricky but is easy to miss. You probably have an older NAS that doesnt support SMB2 so just tell Kodi to negotiate for SMB1 - here's how

In Kodi go to settings. Then go to services, then SMB client.

Once there set the maximum version to SMB1 and the minimum to SMB1. accept the changes (you may be prompted to restart Kodi) and then try browsing for your SMB share and it shoudl appear.
Reply
#33
The Easy Way:

tested on a Mi Box....

For those with a NAS, OSX/MacOS or Linux based file server (inc. LibreELEC, OSMC & CoreELEC) -->> they all usually have Apple Bonjour, network discovery protocols included when network sharing files.
https://en.wikipedia.org/wiki/Bonjour_(software)

How to Install or Uninstall Bonjour on Windows 10 (click)

So what that means is when you select...

Videos > Files > Add Videos > Browse > select Zeroconf browser to very easily add your network shares.

W.

Reply



Logout Mark Read Team Forum Stats Members Help
Android TV - smb network not visible0
This forum uses Lukasz Tkacz MyBB addons.