•   
  • 1
  • 61
  • 62
  • 63(current)
  • 64
  • 65
  • 82
  •   
Release IPTV Recorder
I would like to thank Primaeval for the excellent work on helping me out with my problem!

Since I moved to a self-created epg list with Webgrabplus, the recording was not possible anymore. This was due to the fact that the tvg-id were not matching with the m3u file. The tvg-id was only possible to see with the help of database tool e.g. SQL lite. after updating the epg list with the correct tvg-id, I was able again to record.

Thanks again!!
Reply
(2019-03-21, 19:49)primaeval Wrote: Maybe the reconnect options are specific to the device. I can't find any pre-build android ffmpeg 4.x binaries either.
Anyway, you need to turn them off so they don't appear in the jobs file.
This should not be in the cmd line:
'-reconnect_at_eof', '1', '-reconnect_streamed', '1', '-reconnect_delay_max'

Try changing the m3u and xml so that you have a simple channel name and program title.
The ones in the tests folder were designed to test awkward punctuation and unicode characters.
Call the channel "test" and the program title "test" so the filename is just ascii.
Make sure the tvg-id is test and the "channel id" is test too to be safe.

Remember to turn the ffmpeg debug setting off again that writes the stdout/stderr files to actually record something. 

Finally i it works! 
As you said, the problem were the reconnect options.
However, turning it off in the settings does not works, it still generates the options in the job py file.
I made it working by commenting the corrisponding lines in the main.py.
I also had to download a newer version of ffmpeg from here
Thank you primaeval for your support!
Reply
(2019-03-25, 10:51)encol Wrote:
(2019-03-21, 19:49)primaeval Wrote: Maybe the reconnect options are specific to the device. I can't find any pre-build android ffmpeg 4.x binaries either.
Anyway, you need to turn them off so they don't appear in the jobs file.
This should not be in the cmd line:
'-reconnect_at_eof', '1', '-reconnect_streamed', '1', '-reconnect_delay_max'

Try changing the m3u and xml so that you have a simple channel name and program title.
The ones in the tests folder were designed to test awkward punctuation and unicode characters.
Call the channel "test" and the program title "test" so the filename is just ascii.
Make sure the tvg-id is test and the "channel id" is test too to be safe.

Remember to turn the ffmpeg debug setting off again that writes the stdout/stderr files to actually record something. 

Finally i it works! 
As you said, the problem were the reconnect options.
However, turning it off in the settings does not works, it still generates the options in the job py file.
I made it working by commenting the corrisponding lines in the main.py.
I also had to download a newer version of ffmpeg from here
Thank you primaeval for your support! 
Thanks.
version 0.0.124 should fix the reconnect options.

Are you running the linux build of ffmpeg on spmc on android 4.4?
Reply
(2019-03-25, 11:18)primaeval Wrote:
(2019-03-25, 10:51)encol Wrote:
(2019-03-21, 19:49)primaeval Wrote: Maybe the reconnect options are specific to the device. I can't find any pre-build android ffmpeg 4.x binaries either.
Anyway, you need to turn them off so they don't appear in the jobs file.
This should not be in the cmd line:
'-reconnect_at_eof', '1', '-reconnect_streamed', '1', '-reconnect_delay_max'

Try changing the m3u and xml so that you have a simple channel name and program title.
The ones in the tests folder were designed to test awkward punctuation and unicode characters.
Call the channel "test" and the program title "test" so the filename is just ascii.
Make sure the tvg-id is test and the "channel id" is test too to be safe.

Remember to turn the ffmpeg debug setting off again that writes the stdout/stderr files to actually record something. 

Finally i it works! 
As you said, the problem were the reconnect options.
However, turning it off in the settings does not works, it still generates the options in the job py file.
I made it working by commenting the corrisponding lines in the main.py.
I also had to download a newer version of ffmpeg from here
Thank you primaeval for your support!  
Thanks.
version 0.0.124 should fix the reconnect options.

Are you running the linux build of ffmpeg on spmc on android 4.4? 
the ffmpeg-4.1-linux-armel-32.zip prebuild image
Reply
Hello, hope it’s ok that I post this here. Is it possible to change the format to mp4 in your addon recorder addon?
Reply
(2019-03-25, 20:03)darealwy Wrote: Hello, hope it’s ok that I post this here. Is it possible to change the format to mp4 in your addon recorder addon?

Hello.
You can try but I wouldn't recommend it. You probably won't be able to safely watch a program as it records.
Change
Settings \ Jobs and Rules \ ffmpeg file extension (ts is recommended)
You might need to add extra ffmpeg arguments too. Some streams are very picky about formats.

There is a post-processing command too. You could use that to convert to mp4. I'm not sure if that still works but you can experiment.
Reply
Hi @primaeval

I have noticed that there is an option to add weekly show, when I do the following:

Navigate to a show I want to record on the simple client guide

Click the name of the show and a dialogue box comes up with IPTV Recorder button.

Click the IPTV Rrecorder button and a list comes up.

Click the add weekly recording and complete the wild card name.

After doing this the problem is that the rule exists but the jobs are never created.

Is this weekly record supposed to be accessible from here or is it only available through the Channel Groups?
Reply
(2019-03-30, 05:21)ed_davidson01 Wrote: Hi @primaeval

I have noticed that there is an option to add weekly show, when I do the following:

Navigate to a show I want to record on the simple client guide

Click the name of the show and a dialogue box comes up with IPTV Recorder button.

Click the IPTV Rrecorder button and a list comes up.

Click the add weekly recording and complete the wild card name.

After doing this the problem is that the rule exists but the jobs are never created.

Is this weekly record supposed to be accessible from here or is it only available through the Channel Groups?

You can get to Weekly Recordings from the PVR EPG or Channel Groups if there is a matching Program.
It won't work for Timed Recordings.

There is no way to do differentiate between a missing program or the data just not being loaded yet until the time has passed.

Wildcard is %. So "BBC%" matches "BBC News". "%Graham%" matches "The Graham Norton Show".
That works.
Reply
iptv recorder doesn't read some data from my epg. in epg guide it shows ok, but in iptv recorder there is no data for some channels.
ie, here is expert from my xmltv for data that doesn't show in iptv recorder: zevopabavu (paste)

i tried to delete epg from IPTV simple and to nuke in iptv recorder.

tia
Reply
(2019-03-31, 08:30)pirlone Wrote: iptv recorder doesn't read some data from my epg. in epg guide it shows ok, but in iptv recorder there is no data for some channels.
ie, here is expert from my xmltv for data that doesn't show in iptv recorder: zevopabavu (paste)

i tried to delete epg from IPTV simple and to nuke in iptv recorder.

tia
The xml looks ok. The channel id matches the programme channel.
Have you got a stream in your m3u with a tvg-id="rtl" ?
Are there errors in the kodi.log file?
If it is not a missing tvg-id value it is usually some kind of unicode bug.
Reply
(2019-03-31, 08:41)primaeval Wrote:
(2019-03-31, 08:30)pirlone Wrote: iptv recorder doesn't read some data from my epg. in epg guide it shows ok, but in iptv recorder there is no data for some channels.
ie, here is expert from my xmltv for data that doesn't show in iptv recorder: zevopabavu (paste)

i tried to delete epg from IPTV simple and to nuke in iptv recorder.

tia
The xml looks ok. The channel id matches the programme channel.
Have you got a stream in your m3u with a tvg-id="rtl" ?
Are there errors in the kodi.log file?
If it is not a missing tvg-id value it is usually some kind of unicode bug. 

here is kodi.log: hugetujixu.kodi (paste)
can't recognize any error regarding this issue.

here is m3u stream definition:
#EXTINF:-1 tvg-ID="RTL" tvg-name="RTL"  group-title="FAVORITI",RTL
http://...

can I send you complete xmltv?

tia
Reply
(2019-03-31, 14:31)pirlone Wrote:
(2019-03-31, 08:41)primaeval Wrote:
(2019-03-31, 08:30)pirlone Wrote: iptv recorder doesn't read some data from my epg. in epg guide it shows ok, but in iptv recorder there is no data for some channels.
ie, here is expert from my xmltv for data that doesn't show in iptv recorder: zevopabavu (paste)

i tried to delete epg from IPTV simple and to nuke in iptv recorder.

tia
The xml looks ok. The channel id matches the programme channel.
Have you got a stream in your m3u with a tvg-id="rtl" ?
Are there errors in the kodi.log file?
If it is not a missing tvg-id value it is usually some kind of unicode bug.  

here is kodi.log: hugetujixu.kodi (paste)
can't recognize any error regarding this issue.

here is m3u stream definition:
#EXTINF:-1 tvg-ID="RTL" tvg-name="RTL"  group-title="FAVORITI",RTL
http://...

can I send you complete xmltv?

tia 

The m3u is case sensitive.
Try tvg-id="rtl"
Reply
(2019-03-31, 15:27)primaeval Wrote:
(2019-03-31, 14:31)pirlone Wrote:
(2019-03-31, 08:41)primaeval Wrote: The xml looks ok. The channel id matches the programme channel.
Have you got a stream in your m3u with a tvg-id="rtl" ?
Are there errors in the kodi.log file?
If it is not a missing tvg-id value it is usually some kind of unicode bug.  

here is kodi.log: hugetujixu.kodi (paste)
can't recognize any error regarding this issue.

here is m3u stream definition:
#EXTINF:-1 tvg-ID="RTL" tvg-name="RTL"  group-title="FAVORITI",RTL
http://...

can I send you complete xmltv?

tia  

The m3u is case sensitive.
Try tvg-id="rtl" 

no, it's not that. I tried and it is the same.
i suspect unicode problem.

rgds
Reply
(2019-03-31, 15:31)pirlone Wrote:
(2019-03-31, 15:27)primaeval Wrote:
(2019-03-31, 14:31)pirlone Wrote: here is kodi.log: hugetujixu.kodi (paste)
can't recognize any error regarding this issue.

here is m3u stream definition:
#EXTINF:-1 tvg-ID="RTL" tvg-name="RTL"  group-title="FAVORITI",RTL
http://...

can I send you complete xmltv?

tia  

The m3u is case sensitive.
Try tvg-id="rtl"  

no, it's not that. I tried and it is the same.
i suspect unicode problem.

rgds 
pm me your m3u and xml and I'll have a look.
Reply
Evening lads,

Sorry if jumping in on any ongoing issues - looked like thread has been quiet a few days so I thought I'd post my problem.

I'm running Leia 18.1 on Win 10.

My IPTV service is running great - M3U and XML feeds are URL fed and I got them matching time correctly (+1 hr) on EPG.

Followed the IPTV recorder instructions and everything went in smooth, no troubles/errors.  When I go to Channel Groups and pick something to Record Once, I see the .json file show up in my recording destination, but nothing else.

I'm pointing to a huge (capacity) NAS where my Movies and Music feed fine, and I can write/play files without issue from the Kodi Box under Win 10.  So I doubt it's a permission/SMB issue (I'm a network engineer by trade; just new to Kodi).

I downloaded the ffpmepg 4.1.1 stable/static version for Win64 and mapped in the IPTV Recorder settings to where it is sitting (which is the Downloads directory) of the box user account.  (Possible issue?  Need to be in directory with any of the python stuff installed?)

Anyway - hoping this is something simple/stupid I missed in going through the 60+ pages of this thread. 

It really feels like it went in well; just that something silly is missing/wrong.

Hope you guys can help - thanks in advance!
Reply
  •   
  • 1
  • 61
  • 62
  • 63(current)
  • 64
  • 65
  • 82
  •   



Logout Mark Read Team Forum Stats Members Help
IPTV Recorder4
This forum uses Lukasz Tkacz MyBB addons.