Kodi's Dirty Regions - ARM GPU Tech - improving Kodi rendering performance
#16
I did some tests with a recent Kodi Leia nightly on my Sony BRAVIA with MediaTek MT5891 (Quad ARM Cortex [email protected], ARM Mali T860MP2).

default settings (algorithmdirtyregions: 3; smartredraw: false)

Idle CPU usage: 3%
GUI navigation: quite smooth

algorithmdirtyregions: 1; guismartredraw: false

Idle CPU usage: 3%
GUI navigation: quite smooth

algorithmdirtyregions: 2; guismartredraw: false

Idle CPU usage: 3%
GUI navigation: noticably less smooth (especially in animations)

algorithmdirtyregions: 0; guismartredraw: false

Idle CPU usage: 20%
GUI navigation: quite smooth

algorithmdirtyregions: 0; guismartredraw: true

Idle CPU usage: 20%
GUI navigation: quite smooth


Idle CPU usage has been checked while on Kodi's main page. algorithmdirtyregions 1 and 3 give me the best results. Multi-pass (2) does not seem to be too efficient on my CPU/GPU combination. 0 is also fine, but raises CPU (and most probably also GPU) usage while idle. I haven't yet figured out how smartredraw should impact the whole thing. It does not seem to have any effect.
I haven't yet found a scenario in my daily use of Kodi in which DR=0 improves anything.
Sony BRAVIA KD-65XF9005 (FW V6.6520 / Android TV Oreo 8.0)
Reply
#17
Quote:I haven't yet figured out how smartredraw should impact the whole thing.
OK. The setting is not called guismartredraw as described here ("advancedsettings::gui:guismartredraw"), but only smartredraw within the gui section. Now algorithmdirtyregions=0 and smartredraw=true also gives me the reduced CPU usage while idle. I still don't get why we need smartredraw when we have DR. Sounds like the same thing.
Sony BRAVIA KD-65XF9005 (FW V6.6520 / Android TV Oreo 8.0)
Reply
#18
I was having frustrating issues with Kodi on a S912 (vontar t95z plus) box runn atvxperience vH.  Frames would drop from videos with certain codecs being worse.  Subtitles made the frame drops much worse. The GUI was extremely sluggish and unresponsive when video was playing.

I tried the dirty regions thing and while it did fix the subtitles causing extra frame drops it overall made the frame dropping worse.

I finally figured it out tho.  In the android settings -> Video Playback -> Auto Frame Rate I changed from Level 2 to Off.  I then set kodi to change frame rate on start/stop.  This seems to have fixed most of the frame drop issues.  I no longer get bad stuttering from subtitles either.

I think the two frame rate settings where conflicting with each other.  Look for that option in out Android video playback settings.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Kodi's Dirty Regions - ARM GPU Tech - improving Kodi rendering performance00