•   
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 7
  •   
Solved -  v18 - [Windows] Hardware accelerated playback is choppy unless an overlay is present
#16
(2018-05-24, 18:23)popy Wrote: @JoshDi and others with this issue.

@afedchin has reverted an commit which maybe is the cause of our dxva issues.

Please try upcoming nightly (25.05.2018) and report back here.

Would be nice if you could also add the info to your test results, which gpu and drivers you are using.

pOpY

I will check later tonight and post an update with the x64 5/25/18 nightly build
Reply
#17
Just tested KodiSetup-20180525-8a6c6c70-master-x64 on my desktop (Win10 x64, Nvidia 1080Ti) and that's gone from an unwatchable stuttery mess with DXVA2 acceleration enabled to dropping/skipping zero frames.  I'll swap one of the NUCs back from LibreElec to Win10 over the weekend some time and try that too.  Nice work!
Reply
#18
(2018-05-26, 08:29)beeswax Wrote: Just tested KodiSetup-20180525-8a6c6c70-master-x64 on my desktop (Win10 x64, Nvidia 1080Ti) and that's gone from an unwatchable stuttery mess with DXVA2 acceleration enabled to dropping/skipping zero frames.  I'll swap one of the NUCs back from LibreElec to Win10 over the weekend some time and try that too.  Nice work!
Also for me it's working but not when automatically switching baudrate. Then the stutter is back. So you have switching baudrate on?
Reply
#19
I remembered I had some Acronis backups of the NUCs when they were still on Win10 so it only took a few minutes to revert back and install the new nightly - confirmed fixed on an Intel NUC on Win10 1709 x64 too!

Popy, if you mean refresh rate, you now need to whitelist your resolutions in the System section otherwise everything will output at your default (usually 60Hz).  For most TVs, you should be able to whitelist 24Hz, 30Hz, 50Hz and 60Hz.

The only remaining problem now is PVR deinterlacing, still doensn't look right under Windows.
Reply
#20
(2018-05-26, 09:38)beeswax Wrote: I remembered I had some Acronis backups of the NUCs when they were still on Win10 so it only took a few minutes to revert back and install the new nightly - confirmed fixed on an Intel NUC on Win10 1709 x64 too!

Popy, if you mean refresh rate, you now need to whitelist your resolutions in the System section otherwise everything will output at your default (usually 60Hz).  For most TVs, you should be able to whitelist 24Hz, 30Hz, 50Hz and 60Hz.

The only remaining problem now is PVR deinterlacing, still doensn't look right under Windows.
Thx for the hint, already whitelisted. Without refresh rate change @50hz dxva is working, but when refresh switches to 24 hz stutter is back

Which nvidia driver do you use?
Reply
#21
Hm, I'm getting mixed results now. After everything looked ok in a portable install of the latest nightly, I installed it properly and tested on my TV (was testing on the monitor before) but I'm back to the terrible stuttering again now. I was on the next-to-latest Nvidia driver so updated to the new one with no improvement.

On the test NUC, everything looked fine with Win10 1709 but I just did a clean install of 1803 and the new nightly - back to stuttering again. Further investigation required
Reply
#22
Popy, looks like I have the same result as you on the desktop 1080Ti system - when I'm outputting to my monitor (which displays everything at 60Hz) everything looks OK.  When I switch to my TV, which lets refresh rate switching kick in, it's the same terrible stutter as before at 24Hz.

I need to do some more testing with the NUC.
Reply
#23
(2018-05-26, 13:58)beeswax Wrote: Hm, I'm getting mixed results now. After everything looked ok in a portable install of the latest nightly, I installed it properly and tested on my TV (was testing on the monitor before) but I'm back to the terrible stuttering again now. I was on the next-to-latest Nvidia driver so updated to the new one with no improvement.

On the test NUC, everything looked fine with Win10 1709 but I just did a clean install of 1803 and the new nightly - back to stuttering again. Further investigation required
 Are you sure you do not have some "Cinema Mode" in the TV enabled? Some TVs are quite dump when they are asked to calculate intermediate images, actively breaking correct 24p playback? Please turn all those off.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#24
Hi fritsch, no its nothing to do with the TV, I'm very familiar with my set and I can discern motion interpolation related stutter from anything else.  That, and the fact that the video debug OSD shows 150+ dropped frames within a 60 second test clip Smile

24p playback is absolutely fine on the TV outside of Kodi 18.  It's fine on Krypton and it's fine in MPC-HC/MadVR.
Reply
#25
@fritsch Made a couple of videos for you showing how this looks at my end.  Here is a clip running on the monitor at 60Hz, with the player OSD showing:

https://drive.google.com/file/d/1ZTDv6pf...sp=sharing

and here is the same clip on the TV, with refresh rate switching enabled at 24Hz:

https://drive.google.com/file/d/1IQdLahN...sp=sharing

This is not limited to VC-1, I can produce the same level of stutter and drops with H.264 content.#

edit: I reverted one of the NUCs to Win10 1709 and tested - as long as I have the Ctrl-Shift-O OSD on, almost no frames get dropped/skipped.  With the OSD off however, there doesn't seem to be much improvement.
Reply
#26
The Debug Log is much more important as it shows hurry and lateness ..
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#27
Hasn't Popy supplied lots of logs for this issue already?
Reply
#28
Not with the latest version where he shortly said: it's fixed.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#29
(2018-05-26, 14:55)beeswax Wrote: Popy, looks like I have the same result as you on the desktop 1080Ti system - when I'm outputting to my monitor (which displays everything at 60Hz) everything looks OK.  When I switch to my TV, which lets refresh rate switching kick in, it's the same terrible stutter as before at 24Hz.

I need to do some more testing with the NUC.
So we are facing the same issue. That's good for me the same, when I'll disable refresh rate change and stay at 50 hz, playing of an 24hz content is smooth (stutter every second is normal because of playing 24hz material at 50hz). But when refresh rate change is activated and my TV switches to 24hz, it's unwatchable and dropped frames counts unless osd is on (old issue).

It seems that also the old code has its issues after refresh rate change.

Here I have posted logs on the ticket with the refresh rate change and without.

My currently workaround (to get the WAF high is to disable refresh rate change, activate sync video to display and at least disable dxva).
Reply
#30
(2018-05-26, 14:55)fritsch Wrote:
(2018-05-26, 13:58)beeswax Wrote: Hm, I'm getting mixed results now. After everything looked ok in a portable install of the latest nightly, I installed it properly and tested on my TV (was testing on the monitor before) but I'm back to the terrible stuttering again now. I was on the next-to-latest Nvidia driver so updated to the new one with no improvement.

On the test NUC, everything looked fine with Win10 1709 but I just did a clean install of 1803 and the new nightly - back to stuttering again. Further investigation required
 Are you sure you do not have some "Cinema Mode" in the TV enabled? Some TVs are quite dump when they are asked to calculate intermediate images, actively breaking correct 24p playback? Please turn all those off.
Nothing such activated, my lg plasma is 10 years old and I am happy that it displays something

24p dxva playback with same hardware was no issue in v17.
Reply
  •   
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 7
  •   
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
v18 - [Windows] Hardware accelerated playback is choppy unless an overlay is present00