•   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  •   
Solved v18 - [Windows] Hardware accelerated playback is choppy unless an overlay is present
#61
(2018-06-03, 20:54)fritsch Wrote:
(2018-06-03, 17:41)popy Wrote:
(2018-06-03, 17:05)fritsch Wrote: Just use v18 nightly ... 
That doesn't solve it for me.
Just disable Dxva, enable sync to display and disable change refresh rate.

That's the only reliable workaround for me.

pOpY  

What I really wonder is: have you tried downgrading nvidia drivers? to one 6 months ago? 
I've just tried 384.76 from 2017.6.29 (which is the oldest one I can find on NVidia's website) and it results in the same issues.
Reply
#62
(2018-06-05, 06:59)sPurf Wrote:
(2018-06-03, 20:54)fritsch Wrote:
(2018-06-03, 17:41)popy Wrote: That doesn't solve it for me.
Just disable Dxva, enable sync to display and disable change refresh rate.

That's the only reliable workaround for me.

pOpY  

What I really wonder is: have you tried downgrading nvidia drivers? to one 6 months ago? 
I've just tried 384.76 from 2017.6.29 (which is the oldest one I can find on NVidia's website) and it results in the same issues.
Thx for the test, it seems that something is broken regarding dxva in kodi.

pOpY
Reply
#63
I wonder if it is possible to code a workaround to display a transparent overlay to trigger whatever effect stabilises the playback?

It would be a bit of a band-aid fix but given there is no clear cause and we know this fixes it why not?  Huh
Reply
#64
(2018-06-05, 13:52)sPurf Wrote: I wonder if it is possible to code a workaround to display a transparent overlay to trigger whatever effect stabilises the playback?

It would be a bit of a band-aid fix but given there is no clear cause and we know this fixes it why not?  Huh
Add it in kodi's default skin ...
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#65
(2018-06-05, 20:28)fritsch Wrote:
(2018-06-05, 13:52)sPurf Wrote: I wonder if it is possible to code a workaround to display a transparent overlay to trigger whatever effect stabilises the playback?

It would be a bit of a band-aid fix but given there is no clear cause and we know this fixes it why not?  Huh
Add it in kodi's default skin ... 
Sorry for the noob question...but how do you add it to the default skin? I'm currently using a custom skin, is it possible to apply this to this skin too?
Reply
#66
i have the same problem. my dirty workaround since some weeks is to display a small Overlay at the top right corner of the screen. FPS overlay with Rivatuner. (fontsize ultrasmall) pvr plays perfect, its the same like kodi OSD displayed.
still hoping a good nightly will fix this problem.
Reply
#67
Please try 24.06 nightly, there are some reports that the issue is fixed.
Reply
#68
(2018-06-26, 10:59)popy Wrote: Please try 24.06 nightly, there are some reports that the issue is fixed.

Using 25.06 nightly and it is better, but not completely fixed.
Reply
#69
This fixed my terrible framedrops even with OSD, now i have maby 10 drops in 10 min wirh osd, before i had like 500-600 drops every minute.
Reply
#70
25.6.2018 - buttersmoth 4k worldcup playback
Reply
#71
Thx for your reports, please make a debug log and mention @afedchin so he can look into it.
Reply
#72
Sample file: http://distribution.bbb3d.renderfarming....normal.mp4

Log: https://pastebin.com/75VaFe9v

Using KodiSetup-20180626-0910789a-master-x64 the file plays properly when Use fullscreen window option is enabled. With it disabled there is stuttering and playback is not smooth. Debug logging level needs to be set to 1 to hide the on-screen debug log info or you can't repro it
Reply
#73
(2018-06-26, 17:22)drpizznock Wrote:
(2018-06-26, 10:59)popy Wrote: Please try 24.06 nightly, there are some reports that the issue is fixed.

Using 25.06 nightly and it is better, but not completely fixed. 

Also for me its not completly fixed in "KodiSetup-20180626-0910789a-master-x64.exe", but way better, thx a lot @afedchin !!!!
When running the tv @50hz and watching content with 50hz (with DVBViewer PVR addon) there are some drops (sync to display off).
After enabling sync to display the drops are completly gone.

But i had two crashes when enabling "change refresh rate" and starting an 24p movie.
Kodi switches framerate of tv to 23,976 hz but then kodi crashes. Not all the time and sadly not reproduceable with debug log enabled.

I just have an log with debug  disabled: https://paste.ubuntu.com/p/XxXSmcGbvs/

pOpY
Reply
#74
Still there in 18.2 and recent nightlies.

Related
Reply
#75
I report my experience, I posted it on the wrong section, I did not notice this post...

331968 (thread)

Tested also the lastest nightly (KodiSetup-20180806-08fa24aa-master-x64.exe), but even if a little better, the videos is always choppy especially in 4k...
Also for me keep the osd constantly active on screen, seems that it solves at least the worst of the problem but unthinkable this solution on plasma tv...
Development on Kodi Netflix add-on - Skills Python, C#, VB.NET
Reply
  •   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  •   
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
v18 - [Windows] Hardware accelerated playback is choppy unless an overlay is present00