Req Kodi Plugin for MediaPortal 2.2 TV-Server
#16
Yes. I just recompiled it for v2.2.1. I could not fully test it since I just discovered that they have shutdown the DVB-T service here in the Netherlands and I don't have a DVB-T2 stick yet.
See the TVServerKodi plugin homepage or the Github releases page
Developer of the MediaPortal PVR addon and retired developer of the Argus-TV PVR-addon.
http://www.scintilla.utwente.nl/~marcelg/xbmc
Reply
#17
Thank you  Margro,

Everything seems to be working as it should.

Kind Regards

Bucky...
Reply
#18
(2019-04-19, 16:03)bmonster Wrote: Hi All,

Is there a Kodi TVplugin for mediaportal 2.2.1 yet?

Kind Regards

Bucky

https://users.scintilla.utwente.nl/marce...rxbmc.html
Image
HTPC 1 : OSMC 4K, Titan Bingie
HTPC 2 : Nvidia Shield 4K, Titan Bingie
Reply
#19
Hi - Is there a update for mediaportal 2.2.3 yet ?
Reply
#20
(2020-04-10, 20:46)kx32 Wrote: Hi - Is there a update for mediaportal 2.2.3 yet ?

I've not yet seen. But let me see, if I can find or even comile it.
Reply
#21
I compiled the plugin for MP2.2.3. Please give it a try.
TVServerKodi_MP223
Reply
#22
(2020-04-12, 11:15)ge2301 Wrote: I compiled the plugin for MP2.2.3. Please give it a try.
TVServerKodi_MP223
Hi - Sorry didn't work for me, so went back to the previous version of media portal MP222
Reply
#23
(2020-04-22, 14:39)kx32 Wrote:
(2020-04-12, 11:15)ge2301 Wrote: I compiled the plugin for MP2.2.3. Please give it a try.
TVServerKodi_MP223
Hi - Sorry didn't work for me, so went back to the previous version of media portal MP222 

 v1.21.0.141 (2.2.1) works with 2.2.3

https://github.com/margro/TVServerXBMC/r..._rev141.7z
Reply
#24
(2020-04-22, 14:39)kx32 Wrote:
(2020-04-12, 11:15)ge2301 Wrote: I compiled the plugin for MP2.2.3. Please give it a try.
TVServerKodi_MP223
Hi - Sorry didn't work for me, so went back to the previous version of media portal MP222 
Just in case I've recompiled it and updated the file in the link above.

I also added the plugin version for the soon released major version 2.3 of MP2. This plugin version I tested by myself and it is working nicely.
Reply
#25
Hi all, new installer and user nere. I have confirmed that MP 2.2.3 works well with the compiled plugin above (2.2.1.rev141) for Android & Mac OS X Kodi apps using the bundled MP PVR client plugin (v3.5.18).

However, Linux installed Kodi (Ubuntu) & the MP PVR client from the Linux repo (kodi-pvr-mediaportal-tvserver(3.5.19-1~focal).) is not able to start the stream.

I'm unable to determine which log file to look into for the issue or exception.

Has anyone else confirmed this behavior? Why is the Ubuntu version different than the bundled pvr client add on? Seems like the issue is there or maybe the patch for v141 wasn't applied to the Ubuntu repo yet? TIA
Reply
#26
(2020-07-22, 13:38)dasfiend Wrote: Hi all, new installer and user nere. I have confirmed that MP 2.2.3 works well with the compiled plugin above (2.2.1.rev141) for Android & Mac OS X Kodi apps using the bundled MP PVR client plugin (v3.5.18).

However, Linux installed Kodi (Ubuntu) & the MP PVR client from the Linux repo (kodi-pvr-mediaportal-tvserver(3.5.19-1~focal).) is not able to start the stream.

I'm unable to determine which log file to look into for the issue or exception.

Has anyone else confirmed this behavior? Why is the Ubuntu version different than the bundled pvr client add on? Seems like the issue is there or maybe the patch for v141 wasn't applied to the Ubuntu repo yet? TIA
I'm hitting a file permission issue actually. Will debug that and report back.
Reply
#27
(2020-07-22, 15:02)dasfiend Wrote:
(2020-07-22, 13:38)dasfiend Wrote: Hi all, new installer and user nere. I have confirmed that MP 2.2.3 works well with the compiled plugin above (2.2.1.rev141) for Android & Mac OS X Kodi apps using the bundled MP PVR client plugin (v3.5.18).

However, Linux installed Kodi (Ubuntu) & the MP PVR client from the Linux repo (kodi-pvr-mediaportal-tvserver(3.5.19-1~focal).) is not able to start the stream.

I'm unable to determine which log file to look into for the issue or exception.

Has anyone else confirmed this behavior? Why is the Ubuntu version different than the bundled pvr client add on? Seems like the issue is there or maybe the patch for v141 wasn't applied to the Ubuntu repo yet? TIA
I'm hitting a file permission issue actually. Will debug that and report back.
Update:

Worked passed the file access issue and am stalled on the streaming itself. Some more details:

I've confirmed that access to the recording folders are fine via SMB from the client machine to the server. I've confirmed that starting the stream does indeed create the timeshift and recording files in the directory, but something is failing trying to open them which then closes the stream and removes the files. Files in this directory are also accessible via client and SMB.

Something is causing the opening of the file to fail and the stream then closes, removes the file etc
2020-07-22 11:10:47.540 T:139846694799104  NOTICE: AddOnLog: MediaPortal PVR Client: Translate path C:\Users\Public\Recorded TV\live4-0.ts.tsbuffer -> smb://SLOTH10/Recorded TV/live4-0.ts.tsbuffer

The only ERROR I see in the logs are:
2020-07-22 11:10:48.822 T:139846694799104   ERROR: AddOnLog: MediaPortal PVR Client: FileReader::OpenFile(), open file smb://SLOTH10/Recorded TV/live4-0.ts.tsbuffer failed.
Reply
#28
(2020-07-22, 17:29)dasfiend Wrote:
(2020-07-22, 15:02)dasfiend Wrote:
(2020-07-22, 13:38)dasfiend Wrote: Hi all, new installer and user nere. I have confirmed that MP 2.2.3 works well with the compiled plugin above (2.2.1.rev141) for Android & Mac OS X Kodi apps using the bundled MP PVR client plugin (v3.5.18).

However, Linux installed Kodi (Ubuntu) & the MP PVR client from the Linux repo (kodi-pvr-mediaportal-tvserver(3.5.19-1~focal).) is not able to start the stream.

I'm unable to determine which log file to look into for the issue or exception.

Has anyone else confirmed this behavior? Why is the Ubuntu version different than the bundled pvr client add on? Seems like the issue is there or maybe the patch for v141 wasn't applied to the Ubuntu repo yet? TIA
I'm hitting a file permission issue actually. Will debug that and report back.
Update:

Worked passed the file access issue and am stalled on the streaming itself. Some more details:

I've confirmed that access to the recording folders are fine via SMB from the client machine to the server. I've confirmed that starting the stream does indeed create the timeshift and recording files in the directory, but something is failing trying to open them which then closes the stream and removes the files. Files in this directory are also accessible via client and SMB.

Something is causing the opening of the file to fail and the stream then closes, removes the file etc
2020-07-22 11:10:47.540 T:139846694799104  NOTICE: AddOnLog: MediaPortal PVR Client: Translate path C:\Users\Public\Recorded TV\live4-0.ts.tsbuffer -> smb://SLOTH10/Recorded TV/live4-0.ts.tsbuffer

The only ERROR I see in the logs are:
2020-07-22 11:10:48.822 T:139846694799104   ERROR: AddOnLog: MediaPortal PVR Client: FileReader::OpenFile(), open file smb://SLOTH10/Recorded TV/live4-0.ts.tsbuffer failed.

Last Update and confirmation that rev141 of the Kodi plugin 2.2.1 works for MP2-Server 2.2.3.

I must be hitting some sort of permission or access issue with SMB still. RTSP works on all my clients.
Reply



Logout Mark Read Team Forum Stats Members Help
Kodi Plugin for MediaPortal 2.2 TV-Server0
This forum uses Lukasz Tkacz MyBB addons.