•   
  • 1
  • 2
  • 3(current)
  • 4
  • 5
  • 13
  •   
Important -  Skinners: Please test PR13754
#31
(2018-04-11, 16:15)DaveBlake Wrote: @ksooo what nightly would you like any new issues (if any occur) checked against? In otherwords have you rebased your test build, or is it still against 20180409-9f206f47 master?
 The guiinfo-interface branch ist based on https://github.com/xbmc/xbmc/commit/76f1...bdb8d30529
Reply
#32
(2018-04-11, 16:52)Hitcher Wrote: @ksooo missing art is working perfectly; home widgets are almost working - the first item in my lists are empty which seems to be a problem when using list item position (0).

ie 
Container(2001).ListItemPosition(0).Icon

EDIT: Confluence Movies, TV shows, and music submenus are visible now but disappear when focused.
I'm not 100% sure what exactly home widgets are. Can you make a screenshot and highlight the misbehavior there?
Reply
#33
(2018-04-11, 15:56)ksooo Wrote: Following issues should be fixed:
* missing fanart/posters in info dialogs
* Confluence: music and video fullscreen OSD not working when debug logging is activated
* Confluence: next song information missing in fullscreen music OSD
* wrong song duration (format, hh:mm instead of mmConfuseds) displayed in music node side panel
* missing widget info labels for audio/video items (example: video/audio channels etc. in lower right of Estuary home screen)
Tested and can confirm those are fixed in 20180411-5e45ea57-guiinfo-interface. Thanks @ksooo
(2018-04-11, 15:56)ksooo Wrote: Are there any other open issues?
New issue as @Hitcher has reported with Confluence home screen submenus.
How to repeat: on home screen when "music" highlighted you can see the submenu beneath it, but it vanishes as soon as "muisc" loses focus so can't click on items on it.
Reply
#34
Just to clarify - the submenu button actual gets focus as seen in the debug info but the whole submenu slides out of focus for some reason.
Reply
#35
Thanks once again for the feedback, guys. New test builds available:

Windows:
http://mirrors.xbmc.org/test-builds/wind...ce-x64.exe

OSX:
http://mirrors.xbmc.org/test-builds/osx/...x86_64.dmg

Following issues should be fixed:
* Confluence: Disappearing home screen submenus on select

It would be nice if the issue reporters could retest and report back. Thanks.

Are there any other open issues?  I'm not aware of any and if there are no objections I plan to merge the PR this weekend.
Reply
#36
All issues I had are fixed now, thanks ksooo.
Reply
#37
Just to add to Dave's confirmation, the Confluence issues I'd noticed are fixed.
Reply
#38
I notice some issues in the InfoDialogs using KodiSetup-20180411-793b1b43-guiinfo-interface-x64.exe

On Estuary if you highlight a cast member the plot will disappear. It is like the INFOlabels are trying to show for id"50". It does the same in my skin for MusicInfo id="50" filling the labels and icon for the focused album instead of the artist info and the song info instead of the album info.

I also have an issue in my skin but it is kind of hard to describe what is happening so I posted some pics below.
Image

Image

It just keeps changing without any user interaction. It is a Recently Added TV Shows Widget provided by Skin.Helper showing Similar Shows from Extended Info.
I'm guessing that the ListItem.DBID is swapping on focus and that may be related to the things mentioned above.

Thanks.
Reply
#39
(2018-04-12, 22:00)mikeSiLVO Wrote: I notice some issues in the InfoDialogs using KodiSetup-20180411-793b1b43-guiinfo-interface-x64.exe

On Estuary if you highlight a cast member the plot will disappear. It is like the INFOlabels are trying to show for id"50". It does the same in my skin for MusicInfo id="50" filling the labels and icon for the focused album instead of the artist info and the song info instead of the album info.

I also have an issue in my skin but it is kind of hard to describe what is happening so I posted some pics below.

It just keeps changing without any user interaction. It is a Recently Added TV Shows Widget provided by Skin.Helper showing Similar Shows from Extended Info.
I'm guessing that the ListItem.DBID is swapping on focus and that may be related to the things mentioned above.

Thanks.

 The Estuary issue will be fixed with next test build. Thanks for reporting.

 Regarding the other issue, I doubt that this is caused by my code changes, especially as you are saying that it happens without any user interaction. Are you sure this does not happen in latest Kodi master (nightly build) as well?
Reply
#40
New (hopefully the last before merge) test builds available:

Windows:
http://mirrors.xbmc.org/test-builds/wind...ce-x64.exe

OSX:
http://mirrors.xbmc.org/test-builds/osx/...x86_64.dmg

Following issues should be fixed:
* Disappearing plot, fanart, ... in video/music info dialogs after selecting something from the cast members group list

It would be nice if the issue reporters could retest and report back. Thanks.

Are there any other open issues?  I'm not aware of any and if there are no objections I plan to merge the PR this weekend.
Reply
#41
Everything I mentioned above is fixed using KodiSetup-20180412-56fac675-guiinfo-interface-x64.exe including that weird swapping behavior which did not appear in master.

I noticed one other thing regarding ShowCase type views where you use incremental position numbering Huh... I don't know what it is called but here is an example:

$INFO[ListItem(1).Art(poster)]
$INFO[ListItem(2).Art(poster)]
or
$INFO[ListItem(1).Icon]
$INFO[ListItem(2).Icon]

All return the focused item instead of the correct image.

Image
Reply
#42
(2018-04-13, 11:54)mikeSiLVO Wrote: I noticed one other thing regarding ShowCase type views where you use incremental position numbering Huh... I don't know what it is called but here is an example:

$INFO[ListItem(1).Art(poster)]
$INFO[ListItem(2).Art(poster)]
or
$INFO[ListItem(1).Icon]
$INFO[ListItem(2).Icon]

All return the focused item instead of the correct image.

Image


Does this work correctly with the previous test build?
Reply
#43
(2018-04-13, 12:39)ksooo Wrote: Does this work correctly with the previous test build?
I just reinstalled 793b1b43 to check and it does work correctly in the previous build.
Reply
#44
Found a small one. Container(id).ListItemPosition(0).Label  returns the currently focused item instead the one of ListItemPosition(0). The ongoing numbers (1), (2), etc are working.
Reply
#45
(2018-04-13, 13:40)sualfred Wrote: Found a small one. Container(id).ListItemPosition(0).Label  returns the currently focused item instead the one of ListItemPosition(0). The ongoing numbers (1), (2), etc are working.
 This is with latest test build, right? Does it work correctly with previous test build?
Reply
  •   
  • 1
  • 2
  • 3(current)
  • 4
  • 5
  • 13
  •   
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Skinners: Please test PR1375400