PCM output through HDMI to receiver, what should the receiver display show?
#1
Hello all,

I have a tried a whole slew of different search terms to try and find the answer and so far have had no success.  This is a pretty simple question and I'm irritated with myself for not being able to find an answer through search.

So, I just setup a new raspberry pi with Kodi Krypton 17.6 running through LibreELEC.  I have an older Denon receiver that doesn't support decoding of DTS-MA and TrueHD, so I am interested in having the Pi and Kodi perform the decoding to multi-channel PCM.  Most of what we watch is movies that we buy, ripped with MakeMKV to, well, MKV container, with the DTS-MA or TrueHD soundtracks.  We have a fairly nice Klipsch 7.1 system so I would like to use 7.1 when possible.  I setup Kodi to disable pass-through, and set the channels to 2.0 and the receiver definitely has sound going through it.  The receiver displays PCM and Digital, but only shows that it is receiving the front left and front right channels.  Is that because I have it set to 2.0?

My question is, should the receiver show that it is receiving 5.1 or 7.1 channels when it is receiving multi-channel PCM?

Thank you,

-Louie
Reply
#2
I always feel like Kodi audio settings are a little bit of black magic with many things that are inter-related.  I *think* you need to disable passthru (which you did) and set the speaker settings to the actual speaker setup you have (so 7.1).  Otherwise I'm pretty sure the settings you have will downmix everything to 2.0 and then send 2 PCM channels.
Reply
#3
Indeed, if you have 7.1 channels, set it to that.

2.0 is for two different scenarios

- a true stereo system; or
- using spdif for passing through ac3 or DTS. Those are both compressed and encapsulated in two PCM channels.
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
#4
Thank you both!  So last night I set the number of channels in Kodi to 7.1 to see what that would do and I noticed that the display on the receiver now states Multichannel PCM so that is a huge leap forward!  The only thing (which I realize may take some debug copying and pasting that I can't do right now) is that the receiver is only getting 5.1 (or at least that is what it is telling me that it is getting).  The specific movie that I am telling it to play contains a 7.1 DTS-MA track that I am trying to play (Kodi even lists that as the track that I am playing during playback).

Does this sound abnormal and do I need to put a debug link in here to see what the Pi is really doing?

Thanks again,

-Louie
Reply
#5
Try a test track...
https://kodi.wiki/view/samples#HD_Audio_Test_Clips
Reply
#6
Thanks Doug.  I have those on my NAS so I figured I'd do some tinkering tonight... My observations are below...
  • I tested out the dolby_digital_plus_channel_check_lossless-DWEU using my existing settings (7.1 and Audio set to Optimized) and the receiver only shows Multi-Channel and 5.1 .   Equally odd is that, when the test track was going through the channels, there was no center channel output, only FR, FL, BL, and BR.  I also tested dts_hd_master_audio_sound_check_7_1_lossless-DWEU and saw the same exact performance or lack thereof.
  • I thought maybe something was wrong with my receiver so I snagged one of our Disney Pixar Blu-ray discs that has an "optimizer" in the menu.  I went in and did the audio configuration optimizer and had successful playback of sounds in all 7.1 speakers.
  • Based on the comment someone made about Kodi's "black magic" I decided to tinker a bit with the Audio settings in Kodi.  I went in and changed Optimized to Fixed, leaving 7.1 as the settings and that didn't do anything.  However, when I changed from Fixed to Best Match (leaving 7.1) all of a sudden the dolby_truehd_channel_check_lossless-DWEU test track started working as you would expect!  The receiver now showed Multi-Channel 7.1 and I heard successful sound generation at all the speakers!
  • I was completely pumped... until I went and played the dts_hd_master_audio_sound_check_7_1_lossless-DWEU test track and was right back to Multi-Channel 5.1 with the missing center channel.  I tested a few of the other DTS-MA test tracks (Dredd, etc.) and saw the same thing.  I hit the 'O' button on my keyboard during playback of the DTS-MA files and it showed FL, FR, FC, SB, SL, BL, BR, LFE along with the letters dca, and then 32 bit and 48kHz as if it thinks it is outputting sound to all the channels.  When I hit the 'O' button during playback with the dolby_truehd_channel_check_lossless-DWEU test track, it shows all of the same letters next to audio however dca is replaced by truehd.
  • I decided to go and test a movie that has DTS-MA and amazingly it worked perfectly with the same Best Match and 7.1 settings.... so now I am confused.  I just used MediaInfo to compare the audio section of the dts_hd test track and the movie (which I ripped from my BluRay using MakeMKV) and the characteristics look almost identical between the two (the Bit Rate of my MakeMKV rip is 4742 / 1509 kbps compared to Unknown / 1509 kbps for the dts_hd test track).  I tested a few movies with DTS-MA soundtracks and they all work just fine.
So, my question now is what could cause the DTS-MA test tracks not to link up in Multi-Channel 7.1 with the receiver and also to not even play the Multi-Channel 5.1 correctly that is displayed?

I shut the projector down before running debug mode tonight, but please let me know if that would be helpful and I will try to do that tomorrow.

Thanks!

-Louie
Reply
#7
To receive meaningful assistance you will need to provide a full debug log.

The instructions are here... debug log (wiki)

If you are using the Basic Method, then ensure the following is applied...
1.Enable debugging in Settings>System Settings>Logging,
2.Restart Kodi
3.Replicate the problem.

If you are using the Advanced Method ensure you have correctly created and applied the advancedsettings.xml file.

In both instances, you should see the word DEBUG throughout the log.

Note: Full logs only. No partial or redacted logs
Do NOT post your logs directly into the forum. Always use a paste site like pastebin.com. Post the link to your pasted log in the forum
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
#8
Here is the debug log:

Debug Log

After enabling Debug and reboot, I played the dolby_digital_plus_channel_check_lossless-DWEU test track which has a TrueHD 7.1 audio track that plays perfectly through our 7.1 system with the receiver showing Multi-Channel PCM 7.1

I then went and played the dts_hd_master_audio_sound_check_7_1_lossless-DWEU test track which has a DTS-MA audio track that doesn't play perfectly through our 7.1 system, the receiver shows Multi-Channel PCM 5.1 and there is no audio in the center channel (so not even 5.1 like displayed)

I then went and played our Blu-ray rip of Spectre, which has a 7.1 DTS-MA audio track and I witnessed something NEW.  Last night when I played it and I stated in my post above that the move played perfectly, I must have clicked Resume instead of Start From Beginning... tonight I told it to start from the beginning of the movie and it started the movie with the receiver showing Multi-Channel PCM 5.1, missing center channel audio just like the DTS-MA test track.  I clicked Stop and then selected the Spectre movie again, telling it to Resume, and whoila, Multi-Channel PCM 7.1 with all channels functioning.

So, is it something with the start of the movie not sync'ing up between the Pi and the receiver?

Thanks you all,

-Louie
Reply
#9
(2018-04-12, 03:42)k0diyack Wrote: Here is the debug log:

Debug Log

I notice from the log you have omxplayer enabled. That's not the default, nor recommended on Pi2/Pi3.
Can you try disabling that and report if the behaviour is any different?
Reply
#10
UPDATE:

I disabled the omxplayer and now it starts right up with the Multi-Channel PCM 7.1 so thank you!!

There is another hardware accelerator there called MMAL.  I just checked the Kodi WIKI and it says that omxplayer is the highest performance of the two.  I had them both enabled, now I have them both disabled.  I noticed a little bit of video lag when I would advance ahead in the video.  It would take a few seconds to catch up.  With MMAL enabled, the Multi-Channel PCM 7.1 works on the receiver like I want and the video seems to be better.

Question is should either of those hardware accelerators be enabled on the Pi for 1080p Blu-Ray video with Multi-Channel PCM 7.1 going to the receiver?  What does everybody else use?

Thanks again for helping!

-Louie
Reply
#11
(2018-04-15, 15:13)k0diyack Wrote: Question is should either of those hardware accelerators be enabled on the Pi for 1080p Blu-Ray video with Multi-Channel PCM 7.1 going to the receiver?  What does everybody else use?
I use the MMAL accelerator mostly because OMXPlayer can't seem to handle MPEG2 streams (which is how much of my live tv is delivered).  And in case anyone is wondering, yes I own the MPEG2 hardware decoding license.  My general recommendation is to definitely use one of the two hardware accelerators - OMXPlayer as a first choice, but MMAL is a fine alternative.
Reply
#12
(2018-04-15, 15:13)k0diyack Wrote: Question is should either of those hardware accelerators be enabled on the Pi for 1080p Blu-Ray video with Multi-Channel PCM 7.1 going to the receiver?  What does everybody else use?

99% of users should use the default. Which is OMXPlayer disabled and MMAL enabled on a Pi2/3.
If you are unsure what the default settings are then hit the "reset above settings to default" button in the settings page,
and only change options your are sure you need.
Reply



Logout Mark Read Team Forum Stats Members Help
PCM output through HDMI to receiver, what should the receiver display show?0
This forum uses Lukasz Tkacz MyBB addons.