Rii X1 and Rii i8 not working correctly with Krypton?
Did something change with regards to keyboards between Jarvis and Krypton?

I have been using Jarvis for ages because I am reluctant to change when something 'just works', but I have been forced to upgrade to Krypton after a hardware fault.
Under Jarvis everything on this keyboard worked great, but under Krypton some or most of the keys seem messed up.
Firstly, the number keys don't just type numbers, they scroll through numbers/symbols/letters like I'm typing on a telephone keypad.
Secondly, some of the symbols come up wrong or don't work at all.
Thirdly, the space bar doesn't work at all.

I'm a little confused about this. I tried looking for settings for the keyboard, as it was suggested that it might be being interpreted as a remote control, but no luck.

A friend also has a Rii i8 and that seems to be the same for some things (numbers) but not others (space bar works). Again, theirs was all fine under Jarvis.
Just tried in Windows (Kodi 17) and everything seems fine, so maybe it is an OS issue?

It worked fine in OpenELEC (Kodi 16), but issues arise in OSMC (Kodi 17) and LibrELEC (Kodi 17). I thought Kodi 17 was the common factor, but I guess not.
OK, I tried a normal USB keyboard last night and got the same result.

Is keyboard mapping screwed in Kodi 17, or is this and OS issue?

Logout Mark Read Team Forum Stats Members Help
Rii X1 and Rii i8 not working correctly with Krypton?0
This forum uses Lukasz Tkacz MyBB addons.