v17 -  ImportError with .pyd in windows
#1
Hello, I am trying to make PyQt5 work in kodi, I have managed to compile it and it works correctly in Python 2.7 32Bit in Windows but I can not get it to work in kodi 17

15:41:37.439 T:8532   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.ImportError'>
                                            Error Contents: DLL load failed: The specified procedure could not be found.
                                            Traceback (most recent call last):
                                              File "C:\Users\David\AppData\Roaming\Kodi\addons\plugin.video.test\default.py", line 5, in <module>
                                                from PyQt5 import QtWebKit
                                            ImportError: DLL load failed: The specified procedure could not be found
                                            -->End of Python script error report<--


Does anyone have any idea what the problem is?

Thank you.
Reply
#2
PyQt5 does not support Python 2. The latest version that did was 4.x IIRC .
Raspberry PI 2 + LibreELEC 8 (Kodi 17)
Samsung Galaxy Tab A 10.1 + Kodi 17 for Android
Reply
#3
PyQt5 is compatible with Python 2.7 if it is compiled for Python 2.7 I am using it with Python 2.7 without any problem, the problem is when I try to use it in kodi
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
ImportError with .pyd in windows00