XBOX Cannot open TV Shows in library - Debug Log Included
#16
This has been happening to me since first alpha...seems to be a size of tv library issue...as soon as i scan a certain amount of shows it locks - deleting the tv shows and cleaning up and then starting again fixes it
Reply
#17
I don’t know if my issue is related as I’m trying to add movies now via smb, but I successfully have added smb access on Xbox and added the folder I needed to for tv shows and movies, tv shows was up first and added a bunch of shows and then kodi crashed, reopening it again and forcing library update gets the percentage to 4% and then crashes again and won’t go past it.

As mentioned I’m trying the movie folder now and removed tv folder to see if anything happens again, but curious if my issues is related to what you here have been facing ??
Reply
#18
Ive come to another dead end.
I can update older series with new content yet when adding new content now it breaks the database.
It works again once you remove the latest addition to the series library.

Ive tried cleaning the database and the restarting kodi and re adding new content yet it still breaks the database.

https://paste.kodi.tv/jolevorota
 
 
@Karellen- Log removed
Reply
#19
@Humdrumv

There is little of use in your log. Enable Debugging and post the full log thanks.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#20
I did post the full URL above the it : https://paste.kodi.tv/jolevorota

however here you go :


@Karellen - Log removed
Reply
#21
@ [b]Karellen[/b] please let me know your thoughts
Reply
#22
Why would you post that log in the forum? Are you going to read that wall of words where the line returns have been stripped? And we don't allow logs in the forum. There is red text above the Post Reply button politely asking you to use a pastebin type site.

Your log in the link does not have debug mode enabled which is done in Settings>System Settings>Logging.

  1. Enable Debugging mode. Go to Settings>System Settings>Logging and it should be the first option
  2. Restart Kodi
  3. Replicate the problem.
  4. Upload the results to https://pastebin.com/ or https://paste.ubuntu.com/ and link back here.
Note: Full logs only. No partial or redacted logs
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#23
@Karellen 

my apologies I have enabled debug logging

please see URL below :

https://paste.kodi.tv/iduhijawej
Reply
#24
Ok much better, and better than the log from a week ago Smile

(2018-05-17, 02:45)Humdrumv Wrote: adding new content yet it still breaks the database.
Please explain what this means. What do you consider broken? All you have explained is that you add tv show and then the database breaks. I have no idea what is actually happening or not happening

As afedchin stated, I don't think there is anything wrong with the scraping process. The problem seems that you have not correctly set up your library. The following will not work.
VideoInfoScanner: Found episode match ftp://USER:[email protected]/4TBSeries/This.Is.Us.S01.720p.WEB-DL.x265-YSTeam/This.Is.Us.S01E01.720p.WEB-DL.x265-YST.mkv

In My Signature below is the link to Create Video Library. I suggest reading through it.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#25
@Karellen 

Basically what happens is it finds the tv show and adds it to the database.

I can see the tv show however when I select it to open it it briefly flashes and either nothing happens or it goes to the files menu.

This now applies to any tv show I have added previously I cant open them at all, When removing the last added show that caused this issue all the other shows work too.

Please note that it does find all the content it just cant transition to the next menu.

Ive renamed these files and the issue still persists.

Ive seen multiple posts about this in the forum with no explanation
Reply
#26
(2018-05-17, 02:50)Karellen Wrote: @Humdrumv

There is little of use in your log. Enable Debugging and post the full log thanks.

What’s the best way to get a log to show the reason of kodi crashing on Xbox?

I check the option to have the recent log file saved from the last use of kodi but it continues to only show the current log
Reply
#27
Ive now tried Kodi on Windows using FTP same as the Xbox and have added the show you say is incorrectly named and it worked no issues.
When I add it Xbox Kodi I can see the TV series info and episode count yet it still causes issues accessing the content as well as other series I remove it and all is well again.

any ideas
Reply
#28
@Humdrumv

Sorry, no idea. The xbox developer will need to look at it, now that it has been explained what is actually happening/not happening.

(2018-05-17, 14:23)ThatSlimGuy Wrote: What’s the best way to get a log to show the reason of kodi crashing on Xbox?
Enable debugging mode in Settings>System Settings>Logging, Restart Kodi, then replicate the problem. It should be noted that not all processes are captured in the log. Some faults require the developers to decode.
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#29
(2018-05-17, 22:15)Karellen Wrote: Enable debugging mode in Settings>System Settings>Logging, Restart Kodi, then replicate the problem. It should be noted that not all processes are captured in the log. Some faults require the developers to decode.

Yeah it’s strange. No matter what when I load back up kodi and go to view the log it treats that recent session in the log file rather than the previous session where the crash occurs if that makes sense
Reply
#30
Kodi starts a fresh log every time its started (or restarted). The log from the previous run is also kept though, as the file kodi.old.log in the same directory as the current debug log (wiki).

Offhand I'm not sure if the current version of the log uploader addon can directly access that though. But you can maybe go in manually and get it or transfer it somewhere else and upload it to a pastebin site yourself (it's just a text file)
|Banned add-ons (wiki)|Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

My Blog Posts
Reply



Logout Mark Read Team Forum Stats Members Help
Cannot open TV Shows in library - Debug Log Included0
This forum uses Lukasz Tkacz MyBB addons.