XBOX Cannot open TV Shows in library - Debug Log Included
#31
(2018-05-18, 14:47)DarrenHill Wrote: Kodi starts a fresh log every time its started (or restarted). The log from the previous run is also kept though, as the file kodi.old.log in the same directory as the current debug log (wiki).

Offhand I'm not sure if the current version of the log uploader addon can directly access that though. But you can maybe go in manually and get it or transfer it somewhere else and upload it to a pastebin site yourself (it's just a text file)

If there is a way to get it from the Xbox I’d love to know how. I can’t add any tv shows to the Xbox via smb at all. Movies, not an issue but tv shows will always crash kodi every single time.
Reply
#32
You can copy the log from xbox to a SMB share, as an example. There is also Kodi Logfile Uploader add-on https://forum.kodi.tv/showthread.php?tid=288153
Reply
#33
@Karellen 

So How do we escalate this to the Devs then, not sure how to do this?
Reply
#34
The main Xbox dev posted immediately before yours, so presumably is known...
|Banned add-ons (wiki)|Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

My Blog Posts
Reply
#35
I have this exact problem aswell, just been working around it by clicking on one of the recently watched shows, and it takes you to the file screen. then you can brows the directory but its annoying because you dont get all the advantages of kodi.

Is someone working on a fix for this?
Reply
#36
So this garbage is still "ongoing" even though a "Dev Knows about it"

So pathetic... 2 thumbs down....
Reply
#37
Then please submit your pull request and patch fix for the issue, if the volunteer work by our developers is so pathetic and you can do better.

Either that or take the attitude elsewhere, as we do not tolerate it here. Consider that a friendly warning.
|Banned add-ons (wiki)|Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

My Blog Posts
Reply
#38
Ok - Well I have submitted all the logs and the devs say they are aware of this issue apprently yet it stilll remains with more and more people complaining about it.

I have spent countless hours if not days working on this issue and submitting logs in hopes this can get fixed for furture users however I now see it was for nothing.

Its really fustrating when you put in the work and just get ignored and it seems like somehow Kodi got even worse at playing content which results in a kascade of fails like video and no sound even after restarting Kodi , Kodi becoming stuck and even causing my Xbox to shut down and freezing it.

So you say the best solution is to become a Dev and fix it myself , I dont mind triaging issues however I seem to get nowwhere here very frustrating,
Reply
#39
seeing exact same issue

it's looking like the uwp version is the poor kodi relation in terms of support
Reply
#40
Hi, has anyone got anywhere with a fix for this issue yet or is it still with the devs? I've had it for a few months now, i manage to access the tv shows through the file menu, which works, but i miss out on the sleek kodi interface
Reply
#41
Exact same problem here.. with the RC i wish they would fix it soon cause its a bit of a pain. but on the bright side movies work great!
Reply
#42
I am experiencing the same issue. I installed Kodi on both my Windows 10 laptop and my xbox and synced the TV Shows data sources. Tonight, when I got home from work. I am able to  watch TV shows browse on the laptop, but not  on the xbox. Selecting TV shows on the menu, and then going to in progress shows, the screen drops me in to the "videos" folder. If I select Files from there, I am able to open the videos.
Clicking on TV Shows in the menu, selecting Titles and then a tv show, leaves me on the TV Shows/Titles form. The only options on the TV Shows form that work are Years and Titles. I am able to get to the shows that are listed in each year, but I am not able to actually open the file from that point. I have uploaded the log from following these steps to paste.kodi.tv/opoxohahaw

To confirm that there isn't an issue with the database, I copied it from my xbox and opened it using DB Browse for SQL Lite. It opened fine and I am able to run the queries that are in the log files as causing issues. 

SELECT studio.studio_id, studio.name FROM studio JOIN studio_link ON studio.studio_id = studio_link.studio_id JOIN tvshow_view ON studio_link.media_id = tvshow_view.idShow AND studio_link.media_type='tvshow' GROUP BY studio.studio_id

80 rows returned in 6549ms from: SELECT studio.studio_id, studio.name FROM studio JOIN studio_link ON studio.studio_id = studio_link.studio_id JOIN tvshow_view ON studio_link.media_id = tvshow_view.idShow AND studio_link.media_type='tvshow' GROUP BY studio.studio_id

Running the debug mode created a a 70MB log on the Xbox which isn't uploadable. I was able to copy the database folder off and am now attempting to get the whole loadstate folder as well if that might help.  I have two logs from when I closed and reopened the app after I was unable to watch the TV shows. http://paste.kodi.tv/ejogosiger and then I ran a clean on the database to see if that would help. Same Issue. https://paste.kodi.tv/umimadibay

Cheers
Reply
#43
From the reports so far I preliminarily assume that we have a Kodi issue on UWP - @brogahn can you make a problem report over at GitHub? Don't think I've seen that one yet.
Reply
#44
Having this problem too, but only after the RC5 update (3. jan). Worked fine up until the latest update. Latest update also made me change to a new skin, don't know if that would make a difference.
Playing tv episodes by browsing in file mode works fine. But for tv shows if I use the tv show library, whenever I try to open a tv show, I get thrown to videos folder. Tv shows are inaccessible thru the tvshow library view.
Tried deleting library files and rescan, did not help. Tried reinstalling and rescan, did not help.
Reply
#45
I use a shared sql database and the inability to access TV shows is present on my xbox and my Android tablet. I believe the xbox caused the issue though as it was the one that migrated the database. I'm running the latest RC on both and the they using the same database/tables.
Reply



Logout Mark Read Team Forum Stats Members Help
Cannot open TV Shows in library - Debug Log Included0
This forum uses Lukasz Tkacz MyBB addons.