Automatically fetching any type of music artwork
#16
(2018-05-08, 20:24)DaveBlake Wrote: Believe it or not Scott I was trying to be more consistent with the image browse titles :p I will take another look.

But I would like to replay to one point immediately because it is something that has come up elsewhere too.
(2018-05-08, 03:36)scott967 Wrote: And is album fanart arttype now deprecated?
To my knowledge there as never been album fanart before in Kodi core, and it is not scraped (although could it be?). Have I missed something? Have addons been providing this?

Anyway now it is possible to add "fanart" as an extra album art type, and get it picked up as album fanart from the album folder. 
I was doing a straight A/B compare of the dialogs.  I realize now that before in musicinfo/albums that button 12 worked but actually was accessing the fanart for the associated album artist (never used it in practice I admit).  Adding fanart as an albumextraart did work as expected.

I see now the labels in the file browser make sense, except maybe remote art.  I guess that's due to scraper function that either returns "thumbs" or "fanart" so now the remote art for anything except artist fanart is listing the remote thumbs as "remote art". 

scott s.
.
maintainer of skin  Aeon MQ5 mods for post-Gotham Kodi releases:
Krypton
Leia
Reply
#17
(2018-05-09, 11:38)scott967 Wrote: I was doing a straight A/B compare of the dialogs.  I realize now that before in musicinfo/albums that button 12 worked but actually was accessing the fanart for the associated album artist (never used it in practice I admit). 
I thought that the fanart button was disabled for album info, it should have been, anyway it is now gone.
 
(2018-05-09, 11:38)scott967 Wrote: Adding fanart as an albumextraart did work as expected.
Thanks for that confirmation, all your testing is appreciated.
 
(2018-05-09, 11:38)scott967 Wrote: I see now the labels in the file browser make sense, except maybe remote art.  I guess that's due to scraper function that either returns "thumbs" or "fanart" so now the remote art for anything except artist fanart is listing the remote thumbs as "remote art". 
Historically (support for background colour?) artist fanart was kept separate from thumbs. That is no longer necessary, and sometime I will combine it (or someone will). Meanwhile the artist scraper results get split with only fanart urls in one field, and results for all other art types in another and XML option "aspect = " indicating art type of each entry.
Here is an extract from artist.strImage containing both "thumbs" (poster) and "clearlogo" art
Code:
<thumb aspect="poster" preview="https://assets.fanart.tv/preview/music/ce58d854-7430-4231-aa44-97f0144b3372/artistthumb/mclachlan-sarah-50f78f1d00154.jpg">https://assets.fanart.tv/fanart/music/ce58d854-7430-4231-aa44-97f0144b3372/artistthumb/mclachlan-sarah-50f78f1d00154.jpg</thumb>
<thumb aspect="clearlogo" preview="https://assets.fanart.tv/preview/music/ce58d854-7430-4231-aa44-97f0144b3372/hdmusiclogo/mclachlan-sarah-5ab7fb08785c3.png">https://assets.fanart.tv/fanart/music/ce58d854-7430-4231-aa44-97f0144b3372/hdmusiclogo/mclachlan-sarah-5ab7fb08785c3.png</thumb>
<thumb aspect="clearlogo" preview="https://assets.fanart.tv/preview/music/ce58d854-7430-4231-aa44-97f0144b3372/hdmusiclogo/mclachlan-sarah-5ab8a3f6920a1.png">https://assets.fanart.tv/fanart/music/ce58d854-7430-4231-aa44-97f0144b3372/hdmusiclogo/mclachlan-sarah-5ab8a3f6920a1.png</thumb>
What gets listed as the remote art for a given art type (except fanart) is a result of how CScraperUrl::GetThumbURLs works. It returns those scraped urls with aspect empty for every type, and all aspect values when type requested is empty or "thumb". While few art types are scraped it looks like remote art includes everything every time, but it doesn't. Say we have scraped artist art results with aspect values "" (no aspect option), "poster", "clearlogo", and "banner", the remote art for given art type is:

"thumb" lists all results (except fanart) inc the logo and the banner
"clearlogo" lists logos and those without aspect
"banner" lists banner and those without aspect
"own added type" lists those without aspect

Old scraped results are all thumbs don't have aspect values, hence you see all the thumbs as remote art for every type. As the scraper is improved and you rescrape, the remote art listed for a given art type will appear more selective (expect thumb that will continue to show all the art except fanart).

I hope that helps explain what you see Scott.
Reply
#18
Thanks for the scraper explanations.  Little of my music returns art in a scrape so I have mainly used local art files.

Something else, is that Kodi thumbnail generator uses different max dimensions for thumb and fanart.  I assume this works the same way (fanartres only is used for fanart arttype, imageres for everything else).

scott s.
.
maintainer of skin  Aeon MQ5 mods for post-Gotham Kodi releases:
Krypton
Leia
Reply
#19
(2018-05-11, 23:45)scott967 Wrote: Something else, is that Kodi thumbnail generator uses different max dimensions for thumb and fanart.  I assume this works the same way (fanartres only is used for fanart arttype, imageres for everything else).
Yes that is correct - fanartres only is used for fanart arttype imageres for everything else.
I'll keep that in mind if I ever get to trying to combine fanart into the rest.
Reply
#20
@DaveBlake
Has this feature been merged into the nightly builds already?

I followed the config detailed on your post here, as I wanted to test:-
http://forum.kodi.tv/showthread.php?tid=...pid2731639

Unfortunately, no discart is getting scraped for my library items. When I opt to manually add, discart is not listed as an option and I have to add it to the list of art types, then manually select discart for each album.
I know it's been a while since you posted this thread, so wasn't sure if something had now changed.
Reply
#21
Yes @Dumyat, my work on this is in the current nightly, and nothing has changed regarding it.

I guess an error in one of the config steps is most obvious issue, can you share your advancedsettings.xml, and a screenshot or something that shows where the images are and what they are called in an example.

Next would be to turn debug on, and provide a link to a log of some music (with images) being added to the library, that is when the local art is fetched.

Happy to see it being used, or at least trying to Smile
I will help you all I can.
Reply
#22
Hi @DaveBlake 
Thanks for the reply.
My advancedsettings.xml has been configured as follows:-

<musiclibrary>
     <artistextraart>
         <arttype>clearlogo</arttype>
     </artistextraart>
     <albumextraart>
         <arttype>discart</arttype>
         <arttype>backcover</arttype>
     </albumextraart>
 </musiclibrary>

Here is an example of a album folder, including the discart.png. The album NFO is in the same folder, just you can't see it as I've zoomed the image to make the path more visible:-

Image

I then open the album info dialog in Kodi and select the Choose art button, as no discart was scraped after I added my library:-
Image
And this is the screen I see, ie no discart art type available. I have to add it manually, then select the discart.png:-
Image

I know a lot of users make use of the advancedsettings.xml, but I've never really had any cause to do so until now, so wouldn't surprised if there was something wrong with my config. Any thoughts or feedback would be much appreciated.
Reply
#23
(2018-06-15, 21:28)Dumyat Wrote: I know a lot of users make use of the advancedsettings.xml, but I've never really had any cause to do so until now
I am wondering if you have made an error in the advancedsettings.xml

You posted your code above, can you confirm your file actually has the following code. You may have missed the <advancedsettings> tags.

<advancedsettings>
<musiclibrary>
<artistextraart>
<arttype>clearlogo</arttype>
</artistextraart>
<albumextraart>
<arttype>discart</arttype>
<arttype>backcover</arttype>
</albumextraart>
</musiclibrary>
</advancedsettings>
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic_controls (wiki) | Import-export_library (wiki) | Movie_sets (wiki) | NFO_files (wiki) | Quick start guide (wiki)
Reply
#24
(2018-06-15, 22:00)Karellen Wrote: I am wondering if you have made an error in the advancedsettings.xml

You posted your code above, can you confirm your file actually has the following code. You may have missed the <advancedsettings> tags.
Hi Karellen,
That could well be the problem, as I have indeed omitted <advancedsettings> tags. Will try adding now and report back if that fixes the issue. Smile
Reply
#25
Karellen, you are a star Smile
Now working like a charm. Feeling a bit foolish I must admit for not realising I needed those tags as well.... Blush
Just need to get busy now and rename everything from Cdart to discart.......

You wouldn't happen to know if the info label for the music codec has changed, as mine are not showing anymore. Been like it for a while now and kept meaning to ask the question.
Many thanks for the help, much appreciated Smile
Reply
#26
Great that it worked. No problems about the error, it happens quite often.

Are you using a bulk renamer to rename your files? Bulk Renamer is a good one for Windows

Can you post a screenshot of the music codec issue. Not really clear on it at the moment.
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic_controls (wiki) | Import-export_library (wiki) | Movie_sets (wiki) | NFO_files (wiki) | Quick start guide (wiki)
Reply
#27
Well, I'm in process of correcting many of the tags on my entire music library and I didn't think I had that many discart images on what I've updated so far, so had planned to manually rename. But in reality I seem to have far more than I thought, so the bulk renamer is probably a good idea.

Here's OSD of my Estuary Skin Mod. The file is dated the 5th May 2018 and you can see all the media flags are visible in the bottom right corner, but for some reason the Audio codec (Middle one) isn't showing now with the latest nightly I've been using. I don't think this due to anything I've done, as my main concentration has been on the PVR section, so was curious if the info label name had changed or something:-

Image
Reply
#28
I would initially have said it is a skin issue, but there has been a lot of changes in Music recently.

Maybe @DaveBlake can advise.
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic_controls (wiki) | Import-export_library (wiki) | Movie_sets (wiki) | NFO_files (wiki) | Quick start guide (wiki)
Reply
#29
Audio codec is a player info label not a music library one, so outside my area really. There have been GUI changes and player ones, no idea if this was effected.

Skin changes for Leia, check this post https://forum.kodi.tv/showthread.php?tid=298565

Glad the advancedsettings.xml issue was spotted and sorted, it was the first place to look Smile
Reply
#30
Yeah, I would have initially thought maybe a skin issue, but the same behaviour occurs on other skins as well. Does seem to depend on file type though, as I played a FLAC file earlier quite by chance more than anything and the media flag appears as normal, so maybe just confined to MP3 files which is what 99% of my music library probably consists of. No mention of anything on the skinning engine changes, so a bit of mystery for sure. Will ask one of other skinners to see if they know anything.
Thanks again to both of you for your help and assistance......
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Automatically fetching any type of music artwork00